Skip to content

Commit

Permalink
Update ruby-simplecov.
Browse files Browse the repository at this point in the history
Make this package to Ruby 1.9.3 only.

v0.7.1, 2012-10-12 ([changes](simplecov-ruby/simplecov@v0.7.0...v0.7.1))
-------------------

  * [BUGFIX] The gem packages of 0.7.0 (both simplecov and simplecov-html) pushed to Rubygems had some file
    permission issues, leading to problems when installing SimpleCov in a root/system Rubygems install and then
    trying to use it as a normal user (see simplecov-ruby/simplecov#171, thanks @envygeeks
    for bringing it up). The gem build process has been changed to always enforce proper permissions before packaging
    to avoid this issue in the future.


v0.7.0, 2012-10-10 ([changes](simplecov-ruby/simplecov@v0.6.4...v0.7.0))
-------------------

  * [FEATURE] The new `maximum_coverage_drop` and `minimum_coverage` now allow you to fail your build when the
    coverage dropped by more than what you allowed or is below a minimum value required. Also, `refuse_coverage_drop` disallows
    any coverage drops between test runs.
    See simplecov-ruby/simplecov#151, simplecov-ruby/simplecov#11,
    simplecov-ruby/simplecov#90, and simplecov-ruby/simplecov#96 (thanks to @infertux)
  * [FEATURE] SimpleCov now ships with a built-in MultiFormatter which allows the easy usage of multiple result formatters at
    the same time without the need to write custom wrapper code.
    See simplecov-ruby/simplecov#158 (thanks to @nikitug)
  * [BUGFIX] The usage of digits, hyphens and underscores in group names could lead to broken tab navigation
    in the default simplecov-html reports. See simplecov-ruby/simplecov-html#14 (thanks to @ebelgarts)
  * [REFACTORING] A few more ruby warnings removed. See simplecov-ruby/simplecov#106 and
    simplecov-ruby/simplecov#139. (thanks to @lukejahnke)
  * A [Pledgie button](simplecov-ruby/simplecov@63cfa99) for those that
    feel generous :)
  * The usual bunch of README fixes and documentation tweaks. Thanks to everyone who contributed those!
  • Loading branch information
taca committed Dec 16, 2012
1 parent c3af8f3 commit 4ceab0f
Show file tree
Hide file tree
Showing 3 changed files with 20 additions and 10 deletions.
8 changes: 5 additions & 3 deletions devel/ruby-simplecov/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.3 2012/06/02 00:51:30 taca Exp $
# $NetBSD: Makefile,v 1.4 2012/12/16 16:50:07 taca Exp $

DISTNAME= simplecov-0.6.4
DISTNAME= simplecov-0.7.1
CATEGORIES= devel

MAINTAINER= pkgsrc-users@NetBSD.org
Expand All @@ -9,7 +9,9 @@ COMMENT= Code coverage for Ruby 1.9
LICENSE= gnu-gpl-v2 OR ruby-license

DEPENDS+= ${RUBY_PKGPREFIX}-multi_json>=1.0<2:../../textproc/ruby-multi_json
DEPENDS+= ${RUBY_PKGPREFIX}-simplecov-html>=0.5.3<0.6:../../devel/ruby-simplecov-html
DEPENDS+= ${RUBY_PKGPREFIX}-simplecov-html>=0.7.1<0.8:../../devel/ruby-simplecov-html

RUBY_VERSION_SUPPORTED= 193

.include "../../lang/ruby/gem.mk"
.include "../../mk/bsd.pkg.mk"
14 changes: 11 additions & 3 deletions devel/ruby-simplecov/PLIST
Original file line number Diff line number Diff line change
@@ -1,9 +1,11 @@
@comment $NetBSD: PLIST,v 1.2 2012/06/02 00:51:30 taca Exp $
@comment $NetBSD: PLIST,v 1.3 2012/12/16 16:50:07 taca Exp $
${GEM_HOME}/cache/${GEM_NAME}.gem
${GEM_LIBDIR}/.gitignore
${GEM_LIBDIR}/.travis.yml
${GEM_LIBDIR}/.yardopts
${GEM_LIBDIR}/Appraisals
${GEM_LIBDIR}/CHANGELOG.md
${GEM_LIBDIR}/CONTRIBUTING.md
${GEM_LIBDIR}/Gemfile
${GEM_LIBDIR}/LICENSE
${GEM_LIBDIR}/README.md
Expand All @@ -14,12 +16,16 @@ ${GEM_LIBDIR}/features/config_autoload.feature
${GEM_LIBDIR}/features/config_command_name.feature
${GEM_LIBDIR}/features/config_coverage_dir.feature
${GEM_LIBDIR}/features/config_deactivate_merging.feature
${GEM_LIBDIR}/features/config_formatters.feature
${GEM_LIBDIR}/features/config_merge_timeout.feature
${GEM_LIBDIR}/features/config_nocov_token.feature
${GEM_LIBDIR}/features/config_project_name.feature
${GEM_LIBDIR}/features/config_styles.feature
${GEM_LIBDIR}/features/cucumber_basic.feature
${GEM_LIBDIR}/features/maximum_coverage_drop.feature
${GEM_LIBDIR}/features/merging_test_unit_and_rspec.feature
${GEM_LIBDIR}/features/minimum_coverage.feature
${GEM_LIBDIR}/features/refuse_coverage_drop.feature
${GEM_LIBDIR}/features/rspec_basic.feature
${GEM_LIBDIR}/features/rspec_fails_on_initialization.feature
${GEM_LIBDIR}/features/rspec_groups_and_filters_basic.feature
Expand All @@ -39,18 +45,20 @@ ${GEM_LIBDIR}/features/test_unit_groups_using_filter_class.feature
${GEM_LIBDIR}/features/test_unit_without_simplecov.feature
${GEM_LIBDIR}/features/unicode_compatiblity.feature
${GEM_LIBDIR}/gemfiles/multi_json-legacy.gemfile
${GEM_LIBDIR}/gemfiles/multi_json-legacy.gemfile.lock
${GEM_LIBDIR}/gemfiles/multi_json-new.gemfile
${GEM_LIBDIR}/gemfiles/multi_json-new.gemfile.lock
${GEM_LIBDIR}/lib/simplecov.rb
${GEM_LIBDIR}/lib/simplecov/adapters.rb
${GEM_LIBDIR}/lib/simplecov/command_guesser.rb
${GEM_LIBDIR}/lib/simplecov/configuration.rb
${GEM_LIBDIR}/lib/simplecov/defaults.rb
${GEM_LIBDIR}/lib/simplecov/exit_codes.rb
${GEM_LIBDIR}/lib/simplecov/file_list.rb
${GEM_LIBDIR}/lib/simplecov/filter.rb
${GEM_LIBDIR}/lib/simplecov/formatter.rb
${GEM_LIBDIR}/lib/simplecov/formatter/multi_formatter.rb
${GEM_LIBDIR}/lib/simplecov/formatter/simple_formatter.rb
${GEM_LIBDIR}/lib/simplecov/json.rb
${GEM_LIBDIR}/lib/simplecov/last_run.rb
${GEM_LIBDIR}/lib/simplecov/merge_helpers.rb
${GEM_LIBDIR}/lib/simplecov/railtie.rb
${GEM_LIBDIR}/lib/simplecov/railties/tasks.rake
Expand Down
8 changes: 4 additions & 4 deletions devel/ruby-simplecov/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.3 2012/06/02 00:51:30 taca Exp $
$NetBSD: distinfo,v 1.4 2012/12/16 16:50:07 taca Exp $

SHA1 (simplecov-0.6.4.gem) = 130ea427b822e31b0110d8c2e855eaae88db01e0
RMD160 (simplecov-0.6.4.gem) = f116999d6e4c247d80a94876c0218fb72b87963d
Size (simplecov-0.6.4.gem) = 41472 bytes
SHA1 (simplecov-0.7.1.gem) = aa80a122972b8ccca54e7135fe2e82d4037bdcea
RMD160 (simplecov-0.7.1.gem) = 4272ddd8700d6d2067481de16f87eb7d5e59c885
Size (simplecov-0.7.1.gem) = 44032 bytes

0 comments on commit 4ceab0f

Please sign in to comment.