-
Notifications
You must be signed in to change notification settings - Fork 164
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Version 1.4.1 * Deduplicate command line options when there is more than one TestReporter. Expose the function that does that, uniqueOptionDescriptions. Version 1.4.0.3 * Fix CPP warning/error macro expansion producing 'defined' has undefined behavior Version 1.4.0.2 * Automatically disable the dependency on the clock package when compiled by ghcjs. Version 1.4.0.1 * The only point of this release is to introduce compatibility with GHCs back to 7.0 (see UnkindPartition/tasty#287). Note, however, that these changes are not merged to the master branch, and the future releases will only support the GHC/base versions from the last 5 years, as per our usual policy. To test with even older GHCs, you'll have to use this particular version of tasty (or have the constraint solver pick it for you when testing with older GHCs). The source of this release is in the support-old-ghcs branch of the tasty repository. Version 1.4 * Change the TreeFold data type to give all functions access to OptionSet * Fix a bug where a looping failure message escaped the time out set for the test * Fix a bug where pattern changes inside the TestTree weren't respected Version 1.3.1 * Add an ability for a test provider to print colorful/formatted output Version 1.3 * IsOption has a new method showDefaultValue for customizing how defaultValues are rendered in the --help output. * Drop support for GHCs older than 5 years * Do not install handlers for the signals that dump core * Export the AnsiTricks type/option * In addition to a Parser, optionParser and suiteOptionParser now return a [String] representing warning messages: - A warning is emitted if an IsOption instance defines multiple options in the implementation of optionCLParser. - An warning is emitted if an IsOption instance's optionCLParser implementation assigns a default value (e.g., with Options.Applicative.value), as this interferes with tasty's ability to read environment variable arguments.
- Loading branch information
1 parent
a26dcb5
commit 12ca768
Showing
4 changed files
with
139 additions
and
129 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,21 +1,17 @@ | ||
# $NetBSD: Makefile,v 1.2 2020/04/03 07:30:53 wiz Exp $ | ||
# $NetBSD: Makefile,v 1.3 2021/04/24 05:25:25 pho Exp $ | ||
|
||
DISTNAME= tasty-1.2.3 | ||
DISTNAME= tasty-1.4.1 | ||
CATEGORIES= devel | ||
MASTER_SITES= ${MASTER_SITE_HASKELL_HACKAGE:=tasty-${PKGVERSION_NOREV}/} | ||
|
||
MAINTAINER= pkgsrc-users@NetBSD.org | ||
HOMEPAGE= https://github.com/feuerbach/tasty | ||
COMMENT= Modern and extensible testing framework | ||
LICENSE= mit | ||
|
||
DEPENDS+= hs-async-[0-9]*:../../devel/hs-async | ||
DEPENDS+= hs-tagged-[0-9]*:../../devel/hs-tagged | ||
|
||
USE_LANGUAGES= # none | ||
|
||
.include "../../devel/hs-ansi-terminal/buildlink3.mk" | ||
.include "../../devel/hs-optparse-applicative/buildlink3.mk" | ||
.include "../../devel/hs-tagged/buildlink3.mk" | ||
.include "../../devel/hs-unbounded-delays/buildlink3.mk" | ||
.include "../../mk/haskell.mk" | ||
.include "../../time/hs-clock/buildlink3.mk" | ||
.include "../../textproc/hs-wcwidth/buildlink3.mk" | ||
.include "../../mk/haskell.mk" | ||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,112 +1,119 @@ | ||
@comment $NetBSD: PLIST,v 1.1 2020/05/11 17:52:07 rillig Exp $ | ||
${HS_INTF}/package-description | ||
${HS_INTF}/package-id | ||
@comment $NetBSD: PLIST,v 1.2 2021/04/24 05:25:25 pho Exp $ | ||
lib/tasty-${PKGVERSION}/${HS_VERSION}/package-description | ||
lib/tasty-${PKGVERSION}/${HS_VERSION}/package-id | ||
lib/${HS_PLATFORM}/libHS${HS_PKGID}-${HS_VER}.so | ||
${HS_IMPL}/Test/Tasty.dyn_hi | ||
${HS_IMPL}/Test/Tasty.hi | ||
${HS_IMPL}/Test/Tasty.p_hi | ||
${HS_IMPL}/Test/Tasty/CmdLine.dyn_hi | ||
${HS_IMPL}/Test/Tasty/CmdLine.hi | ||
${HS_IMPL}/Test/Tasty/CmdLine.p_hi | ||
${HS_IMPL}/Test/Tasty/Core.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Core.hi | ||
${HS_IMPL}/Test/Tasty/Core.p_hi | ||
${HS_IMPL}/Test/Tasty/Ingredients.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Ingredients.hi | ||
${HS_IMPL}/Test/Tasty/Ingredients.p_hi | ||
${HS_IMPL}/Test/Tasty/Ingredients/Basic.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Ingredients/Basic.hi | ||
${HS_IMPL}/Test/Tasty/Ingredients/Basic.p_hi | ||
${HS_IMPL}/Test/Tasty/Ingredients/ConsoleReporter.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Ingredients/ConsoleReporter.hi | ||
${HS_IMPL}/Test/Tasty/Ingredients/ConsoleReporter.p_hi | ||
${HS_IMPL}/Test/Tasty/Ingredients/IncludingOptions.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Ingredients/IncludingOptions.hi | ||
${HS_IMPL}/Test/Tasty/Ingredients/IncludingOptions.p_hi | ||
${HS_IMPL}/Test/Tasty/Ingredients/ListTests.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Ingredients/ListTests.hi | ||
${HS_IMPL}/Test/Tasty/Ingredients/ListTests.p_hi | ||
${HS_IMPL}/Test/Tasty/Options.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Options.hi | ||
${HS_IMPL}/Test/Tasty/Options.p_hi | ||
${HS_IMPL}/Test/Tasty/Options/Core.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Options/Core.hi | ||
${HS_IMPL}/Test/Tasty/Options/Core.p_hi | ||
${HS_IMPL}/Test/Tasty/Options/Env.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Options/Env.hi | ||
${HS_IMPL}/Test/Tasty/Options/Env.p_hi | ||
${HS_IMPL}/Test/Tasty/Parallel.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Parallel.hi | ||
${HS_IMPL}/Test/Tasty/Parallel.p_hi | ||
${HS_IMPL}/Test/Tasty/Patterns.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Patterns.hi | ||
${HS_IMPL}/Test/Tasty/Patterns.p_hi | ||
${HS_IMPL}/Test/Tasty/Patterns/Eval.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Patterns/Eval.hi | ||
${HS_IMPL}/Test/Tasty/Patterns/Eval.p_hi | ||
${HS_IMPL}/Test/Tasty/Patterns/Expr.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Patterns/Expr.hi | ||
${HS_IMPL}/Test/Tasty/Patterns/Expr.p_hi | ||
${HS_IMPL}/Test/Tasty/Patterns/Parser.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Patterns/Parser.hi | ||
${HS_IMPL}/Test/Tasty/Patterns/Parser.p_hi | ||
${HS_IMPL}/Test/Tasty/Patterns/Types.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Patterns/Types.hi | ||
${HS_IMPL}/Test/Tasty/Patterns/Types.p_hi | ||
${HS_IMPL}/Test/Tasty/Providers.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Providers.hi | ||
${HS_IMPL}/Test/Tasty/Providers.p_hi | ||
${HS_IMPL}/Test/Tasty/Run.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Run.hi | ||
${HS_IMPL}/Test/Tasty/Run.p_hi | ||
${HS_IMPL}/Test/Tasty/Runners.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Runners.hi | ||
${HS_IMPL}/Test/Tasty/Runners.p_hi | ||
${HS_IMPL}/Test/Tasty/Runners/Reducers.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Runners/Reducers.hi | ||
${HS_IMPL}/Test/Tasty/Runners/Reducers.p_hi | ||
${HS_IMPL}/Test/Tasty/Runners/Utils.dyn_hi | ||
${HS_IMPL}/Test/Tasty/Runners/Utils.hi | ||
${HS_IMPL}/Test/Tasty/Runners/Utils.p_hi | ||
${HS_IMPL}/libHS${HS_PKGID}.a | ||
${HS_IMPL}/libHS${HS_PKGID}_p.a | ||
${HS_DOCS}/LICENSE | ||
${HS_DOCS}/html/Test-Tasty-Ingredients-Basic.html | ||
${HS_DOCS}/html/Test-Tasty-Ingredients-ConsoleReporter.html | ||
${HS_DOCS}/html/Test-Tasty-Ingredients.html | ||
${HS_DOCS}/html/Test-Tasty-Options.html | ||
${HS_DOCS}/html/Test-Tasty-Patterns-Eval.html | ||
${HS_DOCS}/html/Test-Tasty-Patterns-Parser.html | ||
${HS_DOCS}/html/Test-Tasty-Patterns-Types.html | ||
${HS_DOCS}/html/Test-Tasty-Providers.html | ||
${HS_DOCS}/html/Test-Tasty-Runners.html | ||
${HS_DOCS}/html/Test-Tasty.html | ||
${HS_DOCS}/html/doc-index-A.html | ||
${HS_DOCS}/html/doc-index-All.html | ||
${HS_DOCS}/html/doc-index-B.html | ||
${HS_DOCS}/html/doc-index-C.html | ||
${HS_DOCS}/html/doc-index-D.html | ||
${HS_DOCS}/html/doc-index-E.html | ||
${HS_DOCS}/html/doc-index-F.html | ||
${HS_DOCS}/html/doc-index-G.html | ||
${HS_DOCS}/html/doc-index-H.html | ||
${HS_DOCS}/html/doc-index-I.html | ||
${HS_DOCS}/html/doc-index-L.html | ||
${HS_DOCS}/html/doc-index-M.html | ||
${HS_DOCS}/html/doc-index-N.html | ||
${HS_DOCS}/html/doc-index-O.html | ||
${HS_DOCS}/html/doc-index-P.html | ||
${HS_DOCS}/html/doc-index-Q.html | ||
${HS_DOCS}/html/doc-index-R.html | ||
${HS_DOCS}/html/doc-index-S.html | ||
${HS_DOCS}/html/doc-index-T.html | ||
${HS_DOCS}/html/doc-index-U.html | ||
${HS_DOCS}/html/doc-index-W.html | ||
${HS_DOCS}/html/doc-index.html | ||
${HS_DOCS}/html/haddock-bundle.min.js | ||
${HS_DOCS}/html/index.html | ||
${HS_DOCS}/html/linuwial.css | ||
${HS_DOCS}/html/meta.json | ||
${HS_DOCS}/html/quick-jump.css | ||
${HS_DOCS}/html/synopsis.png | ||
${HS_DOCS}/html/tasty.haddock | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Control/Concurrent/Async.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Control/Concurrent/Async.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Control/Concurrent/Async.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/CmdLine.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/CmdLine.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/CmdLine.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Core.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Core.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Core.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Ingredients.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Ingredients.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Ingredients.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Ingredients/Basic.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Ingredients/Basic.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Ingredients/Basic.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Ingredients/ConsoleReporter.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Ingredients/ConsoleReporter.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Ingredients/ConsoleReporter.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Ingredients/IncludingOptions.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Ingredients/IncludingOptions.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Ingredients/IncludingOptions.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Ingredients/ListTests.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Ingredients/ListTests.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Ingredients/ListTests.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Options.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Options.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Options.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Options/Core.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Options/Core.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Options/Core.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Options/Env.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Options/Env.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Options/Env.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Parallel.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Parallel.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Parallel.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Patterns.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Patterns.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Patterns.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Patterns/Eval.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Patterns/Eval.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Patterns/Eval.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Patterns/Expr.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Patterns/Expr.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Patterns/Expr.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Patterns/Parser.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Patterns/Parser.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Patterns/Parser.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Patterns/Types.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Patterns/Types.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Patterns/Types.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Providers.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Providers.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Providers.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Providers/ConsoleFormat.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Providers/ConsoleFormat.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Providers/ConsoleFormat.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Run.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Run.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Run.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Runners.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Runners.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Runners.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Runners/Reducers.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Runners/Reducers.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Runners/Reducers.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Runners/Utils.dyn_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Runners/Utils.hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/Test/Tasty/Runners/Utils.p_hi | ||
lib/${HS_PLATFORM}/${HS_PKGID}/libHS${HS_PKGID}.a | ||
lib/${HS_PLATFORM}/${HS_PKGID}/libHS${HS_PKGID}_p.a | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/LICENSE | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/Test-Tasty-Ingredients-Basic.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/Test-Tasty-Ingredients-ConsoleReporter.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/Test-Tasty-Ingredients.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/Test-Tasty-Options.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/Test-Tasty-Patterns-Eval.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/Test-Tasty-Patterns-Parser.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/Test-Tasty-Patterns-Types.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/Test-Tasty-Providers-ConsoleFormat.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/Test-Tasty-Providers.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/Test-Tasty-Runners.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/Test-Tasty.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-A.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-All.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-B.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-C.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-D.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-E.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-F.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-G.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-H.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-I.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-L.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-M.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-N.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-O.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-P.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-Q.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-R.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-S.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-T.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-U.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index-W.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/doc-index.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/haddock-bundle.min.js | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/index.html | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/linuwial.css | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/meta.json | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/quick-jump.css | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/synopsis.png | ||
share/doc/${HS_PLATFORM}/tasty-${PKGVERSION}/html/tasty.haddock |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,13 +1,20 @@ | ||
# $NetBSD: buildlink3.mk,v 1.1 2020/03/30 16:51:09 riastradh Exp $ | ||
# $NetBSD: buildlink3.mk,v 1.2 2021/04/24 05:25:25 pho Exp $ | ||
|
||
BUILDLINK_TREE+= hs-tasty | ||
|
||
.if !defined(HS_TASTY_BUILDLINK3_MK) | ||
HS_TASTY_BUILDLINK3_MK:= | ||
|
||
BUILDLINK_API_DEPENDS.hs-tasty+= hs-tasty>=1.2.3 | ||
BUILDLINK_ABI_DEPENDS.hs-tasty+= hs-tasty>=1.2.3 | ||
BUILDLINK_API_DEPENDS.hs-tasty+= hs-tasty>=1.4.1 | ||
BUILDLINK_ABI_DEPENDS.hs-tasty+= hs-tasty>=1.4.1 | ||
BUILDLINK_PKGSRCDIR.hs-tasty?= ../../devel/hs-tasty | ||
|
||
.include "../../devel/hs-ansi-terminal/buildlink3.mk" | ||
.include "../../devel/hs-optparse-applicative/buildlink3.mk" | ||
.include "../../devel/hs-tagged/buildlink3.mk" | ||
.include "../../devel/hs-unbounded-delays/buildlink3.mk" | ||
.include "../../time/hs-clock/buildlink3.mk" | ||
.include "../../textproc/hs-wcwidth/buildlink3.mk" | ||
.endif # HS_TASTY_BUILDLINK3_MK | ||
|
||
BUILDLINK_TREE+= -hs-tasty |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,6 +1,6 @@ | ||
$NetBSD: distinfo,v 1.1 2020/03/30 16:51:09 riastradh Exp $ | ||
$NetBSD: distinfo,v 1.2 2021/04/24 05:25:25 pho Exp $ | ||
|
||
SHA1 (tasty-1.2.3.tar.gz) = 292e41bbc001921706ee414aef111385a26947dd | ||
RMD160 (tasty-1.2.3.tar.gz) = 927fb2ade24bd04a7165cce38504bb0de2c12ecd | ||
SHA512 (tasty-1.2.3.tar.gz) = 3922fc19c3ed74b1a39f8e6dc5fe243a955ab55d2e9d08d68b0932dfa0d16cb1efbc73bb2d793c1226d56986141494ce0490c9af70e7e612d07da64d5e2ee472 | ||
Size (tasty-1.2.3.tar.gz) = 49148 bytes | ||
SHA1 (tasty-1.4.1.tar.gz) = a95a249a0aba4427a99303d5541b20732a94c8a6 | ||
RMD160 (tasty-1.4.1.tar.gz) = c16333eae6b6e89b077bf98965d46ec97385040c | ||
SHA512 (tasty-1.4.1.tar.gz) = 72f7dfc60d1582be25ff7e5015ba735156fcc2e8074f0655c68eb4f0c0d2063aa882c2407fe8858a47a316d90b84f8b40a511663642bdc43739c3f02beb021b2 | ||
Size (tasty-1.4.1.tar.gz) = 56599 bytes |