Skip to content

Commit

Permalink
kernel: bump to 4.9.275, 4.14.239, 4.19.197
Browse files Browse the repository at this point in the history
Refreshed all patches.

Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
  • Loading branch information
1715173329 committed Jul 16, 2021
1 parent 63138ba commit 1ac8417
Show file tree
Hide file tree
Showing 40 changed files with 85 additions and 85 deletions.
12 changes: 6 additions & 6 deletions include/kernel-version.mk
Original file line number Diff line number Diff line change
Expand Up @@ -6,13 +6,13 @@ ifdef CONFIG_TESTING_KERNEL
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
endif

LINUX_VERSION-4.9 = .272
LINUX_VERSION-4.14 = .236
LINUX_VERSION-4.19 = .194
LINUX_VERSION-4.9 = .275
LINUX_VERSION-4.14 = .239
LINUX_VERSION-4.19 = .197

LINUX_KERNEL_HASH-4.9.272 = f8bf0c390ae40ca736e104f10f744446bc534bf87ba1b6dbb2b7c9a8bece1058
LINUX_KERNEL_HASH-4.14.236 = e4eae297a6fefefd8ce4781d98178a7c1ee51ca0a4c8a7e46e61b121fbab8b2a
LINUX_KERNEL_HASH-4.19.194 = aaaebdccf599f77148fe170642fa7dc2452cf994b5cbbb4d39cab9e7f4058896
LINUX_KERNEL_HASH-4.9.275 = 6651728a295b13ca6266f2b6ed55065302a2117785e5a6f80bb64c587f3dbf22
LINUX_KERNEL_HASH-4.14.239 = a0e7163e24675524d16b8077c055e4946bb16c0fe7cb0eaa20fbc7f846e5ff98
LINUX_KERNEL_HASH-4.19.197 = e601259beb5184a189db3f8871c97fad9a3bdaceb9cc62e8cdc64f8505217282

remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -325,7 +325,7 @@
for (p = *head; p; p = p->next) {
--- a/net/ipv4/route.c
+++ b/net/ipv4/route.c
@@ -465,7 +465,7 @@ static struct neighbour *ipv4_neigh_look
@@ -466,7 +466,7 @@ static struct neighbour *ipv4_neigh_look
else if (skb)
pkey = &ip_hdr(skb)->daddr;

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -26,7 +26,7 @@
#endif /* __MDIO_BOARD_INFO_H */
--- a/drivers/net/phy/mdio_bus.c
+++ b/drivers/net/phy/mdio_bus.c
@@ -455,6 +455,17 @@ void mdiobus_free(struct mii_bus *bus)
@@ -456,6 +456,17 @@ void mdiobus_free(struct mii_bus *bus)
}
EXPORT_SYMBOL(mdiobus_free);

Expand All @@ -44,15 +44,15 @@
/**
* mdiobus_scan - scan a bus for MDIO devices.
* @bus: mii_bus to scan
@@ -470,6 +481,7 @@ EXPORT_SYMBOL(mdiobus_free);
@@ -471,6 +482,7 @@ EXPORT_SYMBOL(mdiobus_free);
struct phy_device *mdiobus_scan(struct mii_bus *bus, int addr)
{
struct phy_device *phydev;
+ struct mdio_board_entry *be;
int err;

phydev = get_phy_device(bus, addr, false);
@@ -482,6 +494,12 @@ struct phy_device *mdiobus_scan(struct m
@@ -483,6 +495,12 @@ struct phy_device *mdiobus_scan(struct m
*/
of_mdiobus_link_mdiodev(bus, &phydev->mdio);

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -316,7 +316,7 @@
for (p = *head; p; p = p->next) {
--- a/net/ipv4/route.c
+++ b/net/ipv4/route.c
@@ -460,7 +460,7 @@ static struct neighbour *ipv4_neigh_look
@@ -461,7 +461,7 @@ static struct neighbour *ipv4_neigh_look
else if (skb)
pkey = &ip_hdr(skb)->daddr;

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -316,7 +316,7 @@
for (p = *head; p; p = p->next) {
--- a/net/ipv4/route.c
+++ b/net/ipv4/route.c
@@ -465,7 +465,7 @@ static struct neighbour *ipv4_neigh_look
@@ -466,7 +466,7 @@ static struct neighbour *ipv4_neigh_look
else if (skb)
pkey = &ip_hdr(skb)->daddr;

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -316,7 +316,7 @@
list_for_each_entry(p, head, list) {
--- a/net/ipv4/route.c
+++ b/net/ipv4/route.c
@@ -450,7 +450,7 @@ static struct neighbour *ipv4_neigh_look
@@ -451,7 +451,7 @@ static struct neighbour *ipv4_neigh_look
else if (skb)
pkey = &ip_hdr(skb)->daddr;

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -20,7 +20,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>

--- a/drivers/dma/Kconfig
+++ b/drivers/dma/Kconfig
@@ -131,7 +131,7 @@ config COH901318
@@ -132,7 +132,7 @@ config COH901318

config DMA_BCM2835
tristate "BCM2835 DMA engine support"
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -917,7 +917,7 @@ Fixes https://github.com/raspberrypi/linux/issues/2408
}
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
@@ -5247,7 +5247,7 @@ static void port_event(struct usb_hub *h
@@ -5249,7 +5249,7 @@ static void port_event(struct usb_hub *h
u16 status = 0, unused;
port_dev->over_current_count++;

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -178,7 +178,7 @@ Signed-off-by: Andrei Gherzan <andrei@gherzan.com>

--- a/drivers/dma/Kconfig
+++ b/drivers/dma/Kconfig
@@ -131,7 +131,7 @@ config COH901318
@@ -132,7 +132,7 @@ config COH901318

config DMA_BCM2835
tristate "BCM2835 DMA engine support"
Expand All @@ -187,7 +187,7 @@ Signed-off-by: Andrei Gherzan <andrei@gherzan.com>
select DMA_ENGINE
select DMA_VIRTUAL_CHANNELS

@@ -576,6 +576,10 @@ config TIMB_DMA
@@ -577,6 +577,10 @@ config TIMB_DMA
help
Enable support for the Timberdale FPGA DMA engine.

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -33,7 +33,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
#define USB_VENDOR_ID_BELKIN 0x050d
#define USB_DEVICE_ID_FLIP_KVM 0x3201

@@ -1223,6 +1226,9 @@
@@ -1224,6 +1227,9 @@
#define USB_VENDOR_ID_XAT 0x2505
#define USB_DEVICE_ID_XAT_CSR 0x0220

Expand All @@ -53,7 +53,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
{ HID_USB_DEVICE(USB_VENDOR_ID_CHICONY, USB_DEVICE_ID_CHICONY_MULTI_TOUCH), HID_QUIRK_MULTI_INPUT },
{ HID_USB_DEVICE(USB_VENDOR_ID_CHICONY, USB_DEVICE_ID_CHICONY_PIXART_USB_OPTICAL_MOUSE), HID_QUIRK_ALWAYS_POLL },
{ HID_USB_DEVICE(USB_VENDOR_ID_CHICONY, USB_DEVICE_ID_CHICONY_PIXART_USB_OPTICAL_MOUSE2), HID_QUIRK_ALWAYS_POLL },
@@ -186,6 +187,7 @@ static const struct hid_device_id hid_qu
@@ -187,6 +188,7 @@ static const struct hid_device_id hid_qu
{ HID_USB_DEVICE(USB_VENDOR_ID_WALTOP, USB_DEVICE_ID_WALTOP_SIRIUS_BATTERY_FREE_TABLET), HID_QUIRK_MULTI_INPUT },
{ HID_USB_DEVICE(USB_VENDOR_ID_WISEGROUP_LTD2, USB_DEVICE_ID_SMARTJOY_DUAL_PLUS), HID_QUIRK_NOGET | HID_QUIRK_MULTI_INPUT },
{ HID_USB_DEVICE(USB_VENDOR_ID_WISEGROUP, USB_DEVICE_ID_QUAD_USB_JOYPAD), HID_QUIRK_NOGET | HID_QUIRK_MULTI_INPUT },
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -10,7 +10,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>

--- a/arch/arm/kernel/setup.c
+++ b/arch/arm/kernel/setup.c
@@ -1238,6 +1238,8 @@ static int c_show(struct seq_file *m, vo
@@ -1240,6 +1240,8 @@ static int c_show(struct seq_file *m, vo
{
int i, j;
u32 cpuid;
Expand All @@ -19,7 +19,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>

for_each_online_cpu(i) {
/*
@@ -1297,6 +1299,14 @@ static int c_show(struct seq_file *m, vo
@@ -1299,6 +1301,14 @@ static int c_show(struct seq_file *m, vo
seq_printf(m, "Revision\t: %04x\n", system_rev);
seq_printf(m, "Serial\t\t: %s\n", system_serial);

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -83,7 +83,7 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
q->flows[reduced_hash].dsthost = dsthost_idx;
}
}
@@ -1817,20 +1821,30 @@ static s32 cake_enqueue(struct sk_buff *
@@ -1821,20 +1825,30 @@ static s32 cake_enqueue(struct sk_buff *
b->sparse_flow_count++;

if (cake_dsrc(q->flow_mode))
Expand Down Expand Up @@ -116,7 +116,7 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
}

if (q->buffer_used > q->buffer_max_used)
@@ -1998,23 +2012,8 @@ retry:
@@ -2002,23 +2016,8 @@ retry:
dsthost = &b->hosts[flow->dsthost];
host_load = 1;

Expand All @@ -140,7 +140,7 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
/* Keep all flows with deficits out of the sparse and decaying
* rotations. No non-empty flow can go into the decaying
* rotation, so they can't get deficits
@@ -2023,6 +2022,13 @@ retry:
@@ -2027,6 +2026,13 @@ retry:
if (flow->head) {
b->sparse_flow_count--;
b->bulk_flow_count++;
Expand All @@ -154,7 +154,7 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
flow->set = CAKE_SET_BULK;
} else {
/* we've moved it to the bulk rotation for
@@ -2032,6 +2038,22 @@ retry:
@@ -2036,6 +2042,22 @@ retry:
flow->set = CAKE_SET_SPARSE_WAIT;
}
}
Expand All @@ -177,7 +177,7 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
goto retry;
}

@@ -2052,6 +2074,13 @@ retry:
@@ -2056,6 +2078,13 @@ retry:
&b->decaying_flows);
if (flow->set == CAKE_SET_BULK) {
b->bulk_flow_count--;
Expand All @@ -191,7 +191,7 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
b->decaying_flow_count++;
} else if (flow->set == CAKE_SET_SPARSE ||
flow->set == CAKE_SET_SPARSE_WAIT) {
@@ -2065,14 +2094,19 @@ retry:
@@ -2069,14 +2098,19 @@ retry:
if (flow->set == CAKE_SET_SPARSE ||
flow->set == CAKE_SET_SPARSE_WAIT)
b->sparse_flow_count--;
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -91,7 +91,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
};

/* COBALT operates the Codel and BLUE algorithms in parallel, in order to
@@ -2647,6 +2648,13 @@ static int cake_change(struct Qdisc *sch
@@ -2651,6 +2652,13 @@ static int cake_change(struct Qdisc *sch
q->rate_flags &= ~CAKE_FLAG_SPLIT_GSO;
}

Expand All @@ -105,7 +105,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
if (q->tins) {
sch_tree_lock(sch);
cake_reconfigure(sch);
@@ -2806,6 +2814,10 @@ static int cake_dump(struct Qdisc *sch,
@@ -2810,6 +2818,10 @@ static int cake_dump(struct Qdisc *sch,
!!(q->rate_flags & CAKE_FLAG_SPLIT_GSO)))
goto nla_put_failure;

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -52,7 +52,7 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
};

/* COBALT operates the Codel and BLUE algorithms in parallel, in order to
@@ -1573,7 +1575,7 @@ static struct cake_tin_data *cake_select
@@ -1577,7 +1579,7 @@ static struct cake_tin_data *cake_select
struct sk_buff *skb)
{
struct cake_sched_data *q = qdisc_priv(sch);
Expand All @@ -61,23 +61,23 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
bool wash;
u8 dscp;

@@ -1584,6 +1586,7 @@ static struct cake_tin_data *cake_select
@@ -1588,6 +1590,7 @@ static struct cake_tin_data *cake_select
wash = !!(q->rate_flags & CAKE_FLAG_WASH);
if (wash)
dscp = cake_handle_diffserv(skb, wash);
+ mark = (skb->mark & q->fwmark_mask) >> q->fwmark_shft;

if (q->tin_mode == CAKE_DIFFSERV_BESTEFFORT)
tin = 0;
@@ -2202,6 +2205,7 @@ static const struct nla_policy cake_poli
@@ -2206,6 +2209,7 @@ static const struct nla_policy cake_poli
[TCA_CAKE_MPU] = { .type = NLA_U32 },
[TCA_CAKE_INGRESS] = { .type = NLA_U32 },
[TCA_CAKE_ACK_FILTER] = { .type = NLA_U32 },
+ [TCA_CAKE_FWMARK] = { .type = NLA_U32 },
};

static void cake_set_rate(struct cake_tin_data *b, u64 rate, u32 mtu,
@@ -2649,10 +2653,8 @@ static int cake_change(struct Qdisc *sch
@@ -2653,10 +2657,8 @@ static int cake_change(struct Qdisc *sch
}

if (tb[TCA_CAKE_FWMARK]) {
Expand All @@ -90,7 +90,7 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
}

if (q->tins) {
@@ -2814,8 +2816,7 @@ static int cake_dump(struct Qdisc *sch,
@@ -2818,8 +2820,7 @@ static int cake_dump(struct Qdisc *sch,
!!(q->rate_flags & CAKE_FLAG_SPLIT_GSO)))
goto nla_put_failure;

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -32,7 +32,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
s32 tin_deficit;
u32 tin_backlog;
u32 tin_dropped;
@@ -1940,7 +1939,7 @@ begin:
@@ -1944,7 +1943,7 @@ begin:
while (b->tin_deficit < 0 ||
!(b->sparse_flow_count + b->bulk_flow_count)) {
if (b->tin_deficit <= 0)
Expand All @@ -41,7 +41,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
if (b->sparse_flow_count + b->bulk_flow_count)
empty = false;

@@ -2261,8 +2260,7 @@ static int cake_config_besteffort(struct
@@ -2265,8 +2264,7 @@ static int cake_config_besteffort(struct

cake_set_rate(b, rate, mtu,
us_to_ns(q->target), us_to_ns(q->interval));
Expand All @@ -51,7 +51,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>

return 0;
}
@@ -2273,8 +2271,7 @@ static int cake_config_precedence(struct
@@ -2277,8 +2275,7 @@ static int cake_config_precedence(struct
struct cake_sched_data *q = qdisc_priv(sch);
u32 mtu = psched_mtu(qdisc_dev(sch));
u64 rate = q->rate_bps;
Expand All @@ -61,7 +61,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
u32 i;

q->tin_cnt = 8;
@@ -2287,18 +2284,14 @@ static int cake_config_precedence(struct
@@ -2291,18 +2288,14 @@ static int cake_config_precedence(struct
cake_set_rate(b, rate, mtu, us_to_ns(q->target),
us_to_ns(q->interval));

Expand All @@ -83,7 +83,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
}

return 0;
@@ -2367,8 +2360,7 @@ static int cake_config_diffserv8(struct
@@ -2371,8 +2364,7 @@ static int cake_config_diffserv8(struct
struct cake_sched_data *q = qdisc_priv(sch);
u32 mtu = psched_mtu(qdisc_dev(sch));
u64 rate = q->rate_bps;
Expand All @@ -93,7 +93,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
u32 i;

q->tin_cnt = 8;
@@ -2384,18 +2376,14 @@ static int cake_config_diffserv8(struct
@@ -2388,18 +2380,14 @@ static int cake_config_diffserv8(struct
cake_set_rate(b, rate, mtu, us_to_ns(q->target),
us_to_ns(q->interval));

Expand All @@ -115,7 +115,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
}

return 0;
@@ -2434,17 +2422,11 @@ static int cake_config_diffserv4(struct
@@ -2438,17 +2426,11 @@ static int cake_config_diffserv4(struct
cake_set_rate(&q->tins[3], rate >> 2, mtu,
us_to_ns(q->target), us_to_ns(q->interval));

Expand All @@ -137,7 +137,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>

return 0;
}
@@ -2475,15 +2457,10 @@ static int cake_config_diffserv3(struct
@@ -2479,15 +2461,10 @@ static int cake_config_diffserv3(struct
cake_set_rate(&q->tins[2], rate >> 2, mtu,
us_to_ns(q->target), us_to_ns(q->interval));

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -20,7 +20,7 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>

--- a/net/sched/sch_cake.c
+++ b/net/sched/sch_cake.c
@@ -2204,6 +2204,7 @@ static const struct nla_policy cake_poli
@@ -2208,6 +2208,7 @@ static const struct nla_policy cake_poli
[TCA_CAKE_MPU] = { .type = NLA_U32 },
[TCA_CAKE_INGRESS] = { .type = NLA_U32 },
[TCA_CAKE_ACK_FILTER] = { .type = NLA_U32 },
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -960,7 +960,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
pasemi_mac_restart_tx_intr(mac);
--- a/drivers/net/ethernet/qlogic/netxen/netxen_nic_main.c
+++ b/drivers/net/ethernet/qlogic/netxen/netxen_nic_main.c
@@ -2386,7 +2386,7 @@ static int netxen_nic_poll(struct napi_s
@@ -2388,7 +2388,7 @@ static int netxen_nic_poll(struct napi_s
work_done = budget;

if (work_done < budget) {
Expand Down
4 changes: 2 additions & 2 deletions target/linux/generic/hack-4.14/207-disable-modorder.patch
Original file line number Diff line number Diff line change
Expand Up @@ -15,15 +15,15 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>

--- a/Makefile
+++ b/Makefile
@@ -1261,7 +1261,6 @@ endif
@@ -1260,7 +1260,6 @@ endif

PHONY += modules
modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
- $(Q)$(AWK) '!x[$$0]++' $(vmlinux-dirs:%=$(objtree)/%/modules.order) > $(objtree)/modules.order
@$(kecho) ' Building modules, stage 2.';
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost

@@ -1290,7 +1289,6 @@ _modinst_:
@@ -1289,7 +1288,6 @@ _modinst_:
rm -f $(MODLIB)/build ; \
ln -s $(CURDIR) $(MODLIB)/build ; \
fi
Expand Down
2 changes: 1 addition & 1 deletion target/linux/generic/hack-4.14/220-gc_sections.patch
Original file line number Diff line number Diff line change
Expand Up @@ -33,7 +33,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
@@ -786,11 +791,6 @@ ifdef CONFIG_DEBUG_SECTION_MISMATCH
@@ -785,11 +790,6 @@ ifdef CONFIG_DEBUG_SECTION_MISMATCH
KBUILD_CFLAGS += $(call cc-option, -fno-inline-functions-called-once)
endif

Expand Down
2 changes: 1 addition & 1 deletion target/linux/generic/hack-4.14/902-debloat_proc.patch
Original file line number Diff line number Diff line change
Expand Up @@ -393,7 +393,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>

--- a/net/ipv4/route.c
+++ b/net/ipv4/route.c
@@ -427,6 +427,9 @@ static struct pernet_operations ip_rt_pr
@@ -428,6 +428,9 @@ static struct pernet_operations ip_rt_pr

static int __init ip_rt_proc_init(void)
{
Expand Down
Loading

0 comments on commit 1ac8417

Please sign in to comment.