Skip to content
/ openwrt Public
forked from openwrt/openwrt

Commit

Permalink
ath79: add support for UniFi AC-Mesh Pro
Browse files Browse the repository at this point in the history
The Unifi AC-Mesh Pro has identical hardware to the Unifi AC-Pro except
USB support.
Furthermore for setting parameters like antenna gain it is helpful to
know the exact device variant.

Signed-off-by: Christoph Krapp <achterin@googlemail.com>
  • Loading branch information
achterin authored and mkresin committed Jul 7, 2018
1 parent 16d6a63 commit e420b7b
Show file tree
Hide file tree
Showing 6 changed files with 44 additions and 23 deletions.
1 change: 1 addition & 0 deletions target/linux/ath79/base-files/etc/board.d/02_network
Original file line number Diff line number Diff line change
Expand Up @@ -114,6 +114,7 @@ ath79_setup_interfaces()
ucidef_add_switch "switch0" \
"0@eth0" "3:lan:1" "5:lan:2" "4:wan"
;;
"ubnt,unifiac-mesh-pro"|\
"ubnt,unifiac-pro")
ucidef_add_switch "switch0" \
"0@eth0" "2:lan" "3:wan"
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -101,6 +101,7 @@ case "$FIRMWARE" in
;;
"ubnt,unifiac-lite"|\
"ubnt,unifiac-mesh"|\
"ubnt,unifiac-mesh-pro"|\
"ubnt,unifiac-pro")
ath10kcal_extract "EEPROM" 20480 2116
;;
Expand Down
9 changes: 9 additions & 0 deletions target/linux/ath79/dts/qca9563_ubnt_unifiac-mesh-pro.dts
Original file line number Diff line number Diff line change
@@ -0,0 +1,9 @@
// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
/dts-v1/;

#include "qca9563_ubnt_unifiac-pro.dtsi"

/ {
compatible = "ubnt,unifiac-mesh-pro", "qca,qca9563";
model = "Ubiquiti UniFi-AC-MESH PRO";
};
25 changes: 2 additions & 23 deletions target/linux/ath79/dts/qca9563_ubnt_unifiac-pro.dts
Original file line number Diff line number Diff line change
@@ -1,11 +1,11 @@
// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
/dts-v1/;

#include "qca9563_ubnt_unifiac.dtsi"
#include "qca9563_ubnt_unifiac-pro.dtsi"

/ {
compatible = "ubnt,unifiac-pro", "qca,qca9563";
model = "Ubiquiti UniFi-AC-PRO/MESH PRO";
model = "Ubiquiti UniFi-AC-PRO";
};

&usb_phy0 {
Expand All @@ -15,24 +15,3 @@
&usb0 {
status = "okay";
};

&mdio0 {
status = "okay";
phy-mask = <0>;

phy0: ethernet-phy@0 {
reg = <0>;
phy-mode = "sgmii";
qca,ar8327-initvals = <
0x04 0x00080080 /* PORT0 PAD MODE CTRL */
0x7c 0x0000007e /* PORT0_STATUS */
>;
};
};

&eth0 {
status = "okay";

mtd-mac-address = <&eeprom 0x0>;
phy-handle = <&phy0>;
};
24 changes: 24 additions & 0 deletions target/linux/ath79/dts/qca9563_ubnt_unifiac-pro.dtsi
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
// SPDX-License-Identifier: GPL-2.0-or-later OR MIT

#include "qca9563_ubnt_unifiac.dtsi"

&mdio0 {
status = "okay";
phy-mask = <0>;

phy0: ethernet-phy@0 {
reg = <0>;
phy-mode = "sgmii";
qca,ar8327-initvals = <
0x04 0x00080080 /* PORT0 PAD MODE CTRL */
0x7c 0x0000007e /* PORT0_STATUS */
>;
};
};

&eth0 {
status = "okay";

mtd-mac-address = <&eeprom 0x0>;
phy-handle = <&phy0>;
};
7 changes: 7 additions & 0 deletions target/linux/ath79/image/generic-ubnt.mk
Original file line number Diff line number Diff line change
Expand Up @@ -103,6 +103,13 @@ define Device/ubnt_unifiac-mesh
endef
TARGET_DEVICES += ubnt_unifiac-mesh

define Device/ubnt_unifiac-mesh-pro
$(Device/ubnt_unifiac)
DEVICE_TITLE := Ubiquiti UniFi AC-Mesh Pro
SUPPORTED_DEVICES += ubnt-unifiac-mesh-pro
endef
TARGET_DEVICES += ubnt_unifiac-mesh-pro

define Device/ubnt_unifiac-pro
$(Device/ubnt_unifiac)
DEVICE_TITLE := Ubiquiti UniFi AC-Pro
Expand Down

0 comments on commit e420b7b

Please sign in to comment.