forked from openwrt/openwrt
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
build: add ninja build tool and make it available for cmake
ninja is faster at building cmake packages than make, and according to reports also more reliable at handling parallel builds This commit includes a patch that adds GNU make jobserver support, in order to allow more precise control over the number of parallel tasks Enable parallel build by default for packages using ninja Signed-off-by: Felix Fietkau <nbd@nbd.name> Signed-off-by: Rosen Penev <rosenp@gmail.com>
- Loading branch information
Showing
5 changed files
with
2,359 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=ninja | ||
PKG_VERSION:=1.10.2 | ||
PKG_RELEASE:=1 | ||
|
||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz | ||
PKG_SOURCE_URL:=https://codeload.github.com/ninja-build/ninja/tar.gz/v$(PKG_VERSION)? | ||
PKG_HASH:=ce35865411f0490368a8fc383f29071de6690cbadc27704734978221f25e2bed | ||
|
||
include $(INCLUDE_DIR)/host-build.mk | ||
|
||
CONFIGURE_ARGS:= | ||
ifneq ($(findstring c,$(OPENWRT_VERBOSE)),) | ||
CONFIGURE_ARGS+=--verbose | ||
endif | ||
|
||
define Host/Configure | ||
endef | ||
|
||
define Host/Compile | ||
cd $(HOST_BUILD_DIR) && \ | ||
CXX="$(HOSTCXX)" \ | ||
CXXFLAGS="$(HOST_CXXFLAGS) $(HOST_CPPFLAGS)" \ | ||
LDFLAGS="$(HOST_LDFLAGS)" \ | ||
$(STAGING_DIR_HOST)/bin/$(PYTHON) configure.py --bootstrap $(CONFIGURE_ARGS) | ||
endef | ||
|
||
define Host/Install | ||
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin | ||
$(INSTALL_BIN) $(HOST_BUILD_DIR)/ninja $(STAGING_DIR_HOST)/bin/ | ||
endef | ||
|
||
define Host/Clean | ||
$(call Host/Clean/Default) | ||
rm -f $(STAGING_DIR_HOST)/bin/ninja | ||
endef | ||
|
||
$(eval $(call HostBuild)) |
Oops, something went wrong.