Skip to content
/ openwrt Public
forked from openwrt/openwrt

Commit

Permalink
uboot-imx: bump to 2018.03 which fixes the build issues with fdt64_t …
Browse files Browse the repository at this point in the history
…redefinitions

* change mx6qsabresd to mx6qsabres to match defconfig name
* merge wanboard profiles since there is only one defconfig for the target device
* move wanboard options from wandboard.h to defconfig
* remove legacy patches

Signed-off-by: Vladimir Vid <vladimir.vid@sartura.hr>
  • Loading branch information
Vladimir Vid authored and hauke committed Jul 7, 2018
1 parent 87493da commit 856cc6d
Show file tree
Hide file tree
Showing 9 changed files with 26 additions and 1,636 deletions.
28 changes: 9 additions & 19 deletions package/boot/uboot-imx6/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -7,10 +7,10 @@

include $(TOPDIR)/rules.mk

PKG_VERSION:=2014.04
PKG_VERSION:=2018.03
PKG_RELEASE:=1

PKG_HASH:=7b6444bd23eb61068c43bd1d44ec7e7bfdbce5cadeca20c833eee186b4d3fd31
PKG_HASH:=7e7477534409d5368eb1371ffde6820f0f79780a1a1f676161c48442cb303dfd

include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
Expand All @@ -20,7 +20,7 @@ define U-Boot/Default
UBOOT_IMAGE:=u-boot.imx
endef

define U-Boot/mx6qsabresd
define U-Boot/mx6sabresd
NAME:=SABRE i.MX6Quad board
endef

Expand Down Expand Up @@ -48,31 +48,21 @@ define U-Boot/nitrogen6s1g
NAME:=Nitrogen6x i.MX6Solo 1GB board
endef

define U-Boot/wandboard_dl
NAME:=Wandboard Dual Lite
BUILD_DEVICES:=wandboard
endef

define U-Boot/wandboard_quad
NAME:=Wandboard Quad
BUILD_DEVICES:=wandboard
endef

define U-Boot/wandboard_solo
NAME:=Wandboard Solo
define U-Boot/wandboard
NAME:=Wandboard Dual Lite/Quad/Solo
BUILD_DEVICES:=wandboard
endef

UBOOT_TARGETS := \
mx6qsabresd \
mx6sabresd \
nitrogen6dl \
nitrogen6dl2g \
nitrogen6q \
nitrogen6q2g \
nitrogen6s \
nitrogen6s1g \
wandboard_dl \
wandboard_quad \
wandboard_solo
wandboard

UBOOT_MAKE_FLAGS += u-boot.imx

$(eval $(call BuildPackage/U-Boot))
72 changes: 0 additions & 72 deletions package/boot/uboot-imx6/patches/002-use-static-inline.patch

This file was deleted.

80 changes: 0 additions & 80 deletions package/boot/uboot-imx6/patches/003-use-weak-in-board.patch

This file was deleted.

27 changes: 0 additions & 27 deletions package/boot/uboot-imx6/patches/004-use-weak-in-main.patch

This file was deleted.

27 changes: 17 additions & 10 deletions package/boot/uboot-imx6/patches/100-wandboard-enable-fit.patch
Original file line number Diff line number Diff line change
@@ -1,10 +1,17 @@
--- a/include/configs/wandboard.h
+++ b/include/configs/wandboard.h
@@ -238,4 +238,7 @@
#define CONFIG_CMD_CACHE
#endif

+#define CONFIG_FIT
+#define CONFIG_FIT_VERBOSE
+
#endif /* __CONFIG_H * */
--- a/configs/wandboard_defconfig
+++ b/configs/wandboard_defconfig
@@ -27,7 +27,7 @@ CONFIG_CMD_I2C=y
CONFIG_CMD_MMC=y
CONFIG_CMD_SATA=y
CONFIG_CMD_USB=y
-CONFIG_CMD_CACHE=y
+# CONFIG_CMD_CACHE is not set
CONFIG_CMD_EXT4_WRITE=y
CONFIG_ENV_IS_IN_MMC=y
CONFIG_DM=y
@@ -39,3 +39,5 @@ CONFIG_USB_STORAGE=y
CONFIG_VIDEO=y
# CONFIG_VIDEO_SW_CURSOR is not set
CONFIG_OF_LIBFDT=y
+CONFIG_FIT=y
+CONFIG_FIT_VERBOSE=y
Loading

0 comments on commit 856cc6d

Please sign in to comment.