JSON command-line swiss knife: diff, reordering, patch, pointer, validator, codegen
-
Updated
Dec 19, 2023 - PHP
JSON command-line swiss knife: diff, reordering, patch, pointer, validator, codegen
Read and transform JSON documents through JSON-Patch/Pointer
Implements JSON patch documents and JSON pointers
PHP JSON-Patch library based on RFC 6902 - Generate smart diffs, apply patches, rebuild structures
Zero-dependency JSON library with full RFC 8259 parsing, serialization, SAX-style streaming, NDJSON, JSON Pointer (RFC 6901), JSON Patch (RFC 6902), and schema validation (Rust/TS/Python/Go/PHP).
RFC 6902 JSON Patch and RFC 7396 JSON Merge Patch implementation for PHP.
To associate your repository with the json-patch topic, visit your repo's landing page and select "manage topics."