Skip to content

Commit

Permalink
abseil-cpp: update to 20220623.1
Browse files Browse the repository at this point in the history
  • Loading branch information
MehdiChinoune committed Sep 22, 2022
1 parent 8176636 commit d01bddd
Show file tree
Hide file tree
Showing 3 changed files with 4 additions and 52 deletions.
34 changes: 0 additions & 34 deletions mingw-w64-abseil-cpp/0001-abseil-Fix-compiler-warnings.patch
Original file line number Diff line number Diff line change
@@ -1,25 +1,3 @@
--- a/absl/base/attributes.h
+++ b/absl/base/attributes.h
@@ -138,7 +138,7 @@
// step, presumably because Windows doesn't use ELF binaries.
#if (ABSL_HAVE_ATTRIBUTE(weak) || \
(defined(__GNUC__) && !defined(__clang__))) && \
- (!defined(_WIN32) || __clang_major__ < 9) && !defined(__MINGW32__)
+ (!defined(_WIN32) || defined(__clang_major__) && __clang_major__ < 9) && !defined(__MINGW32__)
#undef ABSL_ATTRIBUTE_WEAK
#define ABSL_ATTRIBUTE_WEAK __attribute__((weak))
#define ABSL_HAVE_ATTRIBUTE_WEAK 1
--- a/absl/base/internal/direct_mmap.h
+++ b/absl/base/internal/direct_mmap.h
@@ -20,7 +20,7 @@

#include "absl/base/config.h"

-#if ABSL_HAVE_MMAP
+#ifdef ABSL_HAVE_MMAP

#include <sys/mman.h>

--- a/absl/base/internal/sysinfo.cc
+++ b/absl/base/internal/sysinfo.cc
@@ -77,7 +77,9 @@
Expand Down Expand Up @@ -61,18 +39,6 @@

#include <algorithm>
#include <cstring>
--- a/absl/random/internal/randen_detect.cc
+++ b/absl/random/internal/randen_detect.cc
@@ -40,7 +40,9 @@
#if defined(ABSL_INTERNAL_USE_X86_CPUID)
#if defined(_WIN32) || defined(_WIN64)
#include <intrin.h> // NOLINT(build/include_order)
+#ifdef _MSC_VER
#pragma intrinsic(__cpuid)
+#endif
#else
// MSVC-equivalent __cpuid intrinsic function.
static void __cpuid(int cpu_info[4], int info_type) {
--- a/absl/random/internal/seed_material.cc
+++ b/absl/random/internal/seed_material.cc
@@ -44,7 +44,9 @@
Expand Down
11 changes: 0 additions & 11 deletions mingw-w64-abseil-cpp/0003-abseil-Include-pthread-header.patch

This file was deleted.

11 changes: 4 additions & 7 deletions mingw-w64-abseil-cpp/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -3,8 +3,8 @@
_realname=abseil-cpp
pkgbase=mingw-w64-${_realname}
pkgname="${MINGW_PACKAGE_PREFIX}-${_realname}"
pkgver=20211102.0
pkgrel=6
pkgver=20220623.1
pkgrel=1
pkgdesc="Abseil Common Libraries (C++) from Google (mingw-w64)"
arch=('any')
mingw_arch=('mingw32' 'mingw64' 'ucrt64' 'clang64' 'clang32' 'clangarm64')
Expand All @@ -17,20 +17,17 @@ makedepends=("${MINGW_PACKAGE_PREFIX}-cmake"
source=("https://github.com/abseil/abseil-cpp/archive/$pkgver/$_realname-$pkgver.tar.gz"
"0001-abseil-Fix-compiler-warnings.patch"
"0002-abseil-Remove-librt-library.patch"
"0003-abseil-Include-pthread-header.patch"
"0004-abseil-Propagate-cxx-std-17.patch")
sha256sums=('dcf71b9cba8dc0ca9940c4b316a0c796be8fab42b070bb6b7cab62b48f0e66c4'
'd273d7fa05f912edc8d91c0c8ba6f1f0576d0d98714bc4bd9b624e148f7aad19'
sha256sums=('91ac87d30cc6d79f9ab974c51874a704de9c2647c40f6932597329a282217ba8'
'30fb7526d1c89f722dd0ce0c467e034370140fbf07a1ad4f91df301c7f442551'
'd3ecabcebf64c2211b40e07f376de028ad1b101051cba7e69d77f6074217238d'
'66bf9f2919aed3a4f71bba6b6809078dd6cb22faef763e63c3f813d3f54782c9'
'52cbf35dace3296dbe0f72acc2235cf009c0fffce8cf0fb455a99a71e5f25ab2')

prepare() {
cd "${_realname}-${pkgver}"

patch -Np1 -i "${srcdir}/0001-abseil-Fix-compiler-warnings.patch"
patch -Np1 -i "${srcdir}/0002-abseil-Remove-librt-library.patch"
patch -Np1 -i "${srcdir}/0003-abseil-Include-pthread-header.patch"
patch -Np1 -i "${srcdir}/0004-abseil-Propagate-cxx-std-17.patch"
}

Expand Down

0 comments on commit d01bddd

Please sign in to comment.