Skip to content

Commit

Permalink
dracut: Do not undefine _FILE_OFFSET_BITS
Browse files Browse the repository at this point in the history
Fixes build with 64bit time_t

Signed-off-by: Khem Raj <raj.khem@gmail.com>
  • Loading branch information
kraj committed Dec 31, 2022
1 parent c8a56b2 commit 944e9dc
Show file tree
Hide file tree
Showing 2 changed files with 33 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
From 7f8ef553b7c433af153d48c6a16b2943780abf67 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sat, 31 Dec 2022 14:41:52 -0800
Subject: [PATCH] install: Do not undef _FILE_OFFSET_BITS

_FILE_OFFSET_BITS is a feature test macro to determine largefile
support. Usually its set to 64 on systems supporting LFS. Its also
needed to be set to 64 for supporting 64bit time_t on glibc on 32bit
systems. If its undefined explicitly, then 64bit time_t can not be
enabled.

Upstream-Status: Submitted [https://github.com/dracutdevs/dracut/pull/2157]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
src/install/dracut-install.c | 1 -
1 file changed, 1 deletion(-)

diff --git a/src/install/dracut-install.c b/src/install/dracut-install.c
index dda0caca..05a67a03 100644
--- a/src/install/dracut-install.c
+++ b/src/install/dracut-install.c
@@ -22,7 +22,6 @@
#ifndef _GNU_SOURCE
#define _GNU_SOURCE
#endif
-#undef _FILE_OFFSET_BITS
#include <ctype.h>
#include <errno.h>
#include <fcntl.h>
--
2.39.0

1 change: 1 addition & 0 deletions meta-initramfs/recipes-devtools/dracut/dracut_056.bb
Original file line number Diff line number Diff line change
Expand Up @@ -11,6 +11,7 @@ SRCREV = "631d5f72a223288aa1f48bb8e8d0313e75947400"
SRC_URI = "git://git.kernel.org/pub/scm/boot/dracut/dracut.git;protocol=http;branch=master \
file://0001-util.h-include-sys-reg.h-when-libc-glibc.patch \
file://0001-Guard-against-__GLIBC_PREREQ-for-musl-libc.patch \
file://0001-install-Do-not-undef-_FILE_OFFSET_BITS.patch \
"

DEPENDS += "kmod"
Expand Down

0 comments on commit 944e9dc

Please sign in to comment.