-
Notifications
You must be signed in to change notification settings - Fork 17
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
129 changed files
with
1,088 additions
and
203 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1 @@ | ||
22 | ||
0 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,117 @@ | ||
# Maintainer: Chris Severance aur.severach AatT spamgourmet.com | ||
# Maintainer: Ainola | ||
# Contributor: Chris Fordham | ||
|
||
# This package is designed so that these PKGBUILD are easy to sync with Midnight Commander: | ||
# aws-cli & aws-cli-git | ||
# python-botocore & python-botocore-git | ||
|
||
# Note: the primary use of this package is with aws-cli | ||
|
||
# Use mcdiff to watch for changes | ||
_fn_foobar() { | ||
local _foobar=" | ||
#requirements-docs.txt | ||
Sphinx>=1.1.3,<1.3 | ||
guzzle_sphinx_theme>=0.7.10,<0.8 | ||
|
||
#requirements.txt | ||
tox==1.4 | ||
python-dateutil>=2.1,<3.0.0 | ||
nose==1.3.0 | ||
mock==1.3.0 | ||
wheel==0.24.0 | ||
docutils>=0.10 | ||
behave==1.2.5 | ||
-e git://github.com/boto/jmespath.git@develop#egg=jmespath | ||
|
||
#setup.py | ||
from setuptools import setup, find_packages | ||
|
||
|
||
requires = ['jmespath>=0.7.1,<1.0.0', | ||
'python-dateutil>=2.1,<3.0.0', | ||
'docutils>=0.10'] | ||
|
||
|
||
if sys.version_info[:2] == (2, 6): | ||
" | ||
} | ||
unset -f _fn_foobar | ||
|
||
set -u | ||
_pyver="python" | ||
_pybase='botocore' | ||
pkgname="${_pyver}-${_pybase}" | ||
pkgver=1.3.30 | ||
pkgrel=1 | ||
pkgdesc='A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3' | ||
arch=('any') | ||
url="https://github.com/boto/${_pybase}" | ||
license=('Apache') # Apache License 2.0 | ||
_pydepends=( # See setup.py, README.rst, and requirements.txt for version dependencies | ||
"${_pyver}-bcdoc<0.15.0" # AUR | ||
"${_pyver}-wheel>=0.24.0" # AUR == | ||
"${_pyver}-jmespath"{'>=0.7.1','<1.0.0'} # AUR == is possible for repositories. Makes upgrades impossible in AUR. | ||
"${_pyver}-tox>=1.4" # COM == is possible because this is from a repository. Unfortunatley Arch isn"t the primary dev environment for botocore/aws so our packages are likely to be newer. | ||
"${_pyver}-dateutil"{">=2.1","<3.0.0"} # COM | ||
"${_pyver}-nose>=1.3.0" # COM == | ||
"${_pyver}-mock>=1.3.0" # COM == | ||
"${_pyver}-docutils>=0.10" # COM | ||
"${_pyver}-six>=1.1.0" # COM This is in the sources but I'm not sure where the version comes from. | ||
# requirements-docs.txt | ||
"${_pyver}-sphinx>=1.1.3" #"${_pyver}-sphinx"{>=1.1.3,<1.3} # COM Arch is already newer. Documentation might not work. | ||
"${_pyver}-guzzle-sphinx-theme"{">=0.7.10","<0.8"} | ||
"${_pyver}-behave>=1.2.5" | ||
) | ||
depends=("${_pyver}" "${_pydepends[@]}") | ||
makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools | ||
options=('!strip') | ||
source=("${_pybase}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz") | ||
sha256sums=('4c80e1be6055003a366707e174800ec775bb805b3bc44777fe734b26ffe301b4') | ||
|
||
if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case | ||
_srcdir="${_pybase}" | ||
makedepends+=('git') | ||
provides+=("${pkgname%-git}=${pkgver%%.r*}") | ||
conflicts+=("${pkgname%-git}") | ||
source=("${_srcdir}::git+${url}.git") | ||
:;sha256sums=('SKIP') | ||
pkgver() { | ||
set -u | ||
cd "${_srcdir}" | ||
printf '%s.r%s.g%s' "$(sed -ne "s:__version__ = '\(.*\)'"'$:\1:p' 'botocore/__init__.py')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" # " | ||
set +u | ||
} | ||
else | ||
_srcdir="${_pybase}-${pkgver}" | ||
_verwatch=("${url}/releases" "${url#*github.com}/archive/\(.*\)\.tar\.gz" 'l') | ||
fi | ||
|
||
build() { | ||
set -u | ||
cd "${_srcdir}" | ||
${_pyver} setup.py build | ||
set +u | ||
} | ||
|
||
check() { | ||
set -u | ||
cd "${_srcdir}" | ||
# If pip is installed, some package tests download missing packages. We can't allow that. | ||
#${_pyver} setup.py test --verbose | ||
set +u | ||
} | ||
|
||
package() { | ||
set -u | ||
#depends=("${_pyver}" "${_pydepends[@]}") | ||
cd "${_srcdir}" | ||
${_pyver} setup.py install --root="${pkgdir}" --optimize=1 | ||
install -Dpm644 'README.rst' 'requirements.txt' -t "${pkgdir}/usr/share/doc/${pkgname%-git}/" | ||
install -Dpm644 'LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE" | ||
set +u | ||
} | ||
set +u | ||
|
||
# vim:set ts=2 sw=2 et: |
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
Empty file.
This file was deleted.
Oops, something went wrong.
Empty file.
File renamed without changes.
File renamed without changes.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
{"version":5,"type":"multiinfo","resultcount":2,"results":[{"ID":245498,"Name":"aurget","PackageBaseID":31933,"PackageBase":"aurget","Version":"4.6.0-1","Description":"A simple, Pacman-like AUR helper","URL":"https:\/\/github.com\/pbrisbin\/aurget","NumVotes":147,"Popularity":0.874734,"OutOfDate":null,"Maintainer":"brisbin33","FirstSubmitted":1257968246,"LastModified":1446668790,"URLPath":"\/cgit\/aur.git\/snapshot\/aurget.tar.gz","OptDepends":["customizepkg: for auto-customizing packages"],"License":["GPL"],"Keywords":[]},{"ID":210550,"Name":"chruby","PackageBaseID":66020,"PackageBase":"chruby","Version":"0.3.9-1","Description":"Changes the current ruby. Supports both zsh and bash.","URL":"https:\/\/github.com\/postmodern\/chruby","NumVotes":21,"Popularity":1.737352,"OutOfDate":null,"Maintainer":"jasonwryan","FirstSubmitted":1357326246,"LastModified":1436581847,"URLPath":"\/cgit\/aur.git\/snapshot\/chruby.tar.gz","Depends":["bash"],"MakeDepends":["gnupg"],"OptDepends":["zsh"],"License":["MIT"],"Keywords":[]}]} |
File renamed without changes.
File renamed without changes.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
{"version":5,"type":"multiinfo","resultcount":4,"results":[{"ID":279238,"Name":"aws-cli","PackageBaseID":66957,"PackageBase":"aws-cli","Version":"1.10.8-1","Description":"Universal Command Line Interface for Amazon Web Services awscli","URL":"https:\/\/github.com\/aws\/aws-cli","NumVotes":36,"Popularity":5.468268,"OutOfDate":null,"Maintainer":"severach","FirstSubmitted":1360020051,"LastModified":1456508307,"URLPath":"\/cgit\/aur.git\/snapshot\/aws-cli.tar.gz","Depends":["python","python-bcdoc","python-botocore>=1.3.30","python-colorama>=0.2.5","python-rsa>=3.2","python-rsa<=3.3.0","python-s3transfer>=0.0.1","python-wheel>=0.24.0","python-jmespath>=0.7.1","python-tox>=1.4","python-dateutil>=2.1","python-dateutil<3.0.0","python-nose>=1.3.0","python-mock>=1.3.0","python-docutils>=0.10","python-six>=1.1.0","python-guzzle-sphinx-theme>=0.7.10","python-guzzle-sphinx-theme<0.8"],"MakeDepends":["python","python-distribute"],"Conflicts":["python2-aws-cli","python-aws-cli","awscli"],"Provides":["awscli=1.10.8"],"License":["Apache"],"Keywords":[]},{"ID":278648,"Name":"codeclimate","PackageBaseID":95172,"PackageBase":"codeclimate","Version":"0.21.0-1","Description":"Command line interface for the Code Climate analysis platform. It allows you to run Code Climate engines on your local machine inside of Docker containers. Make sure that your current user belongs to docker group and that docker is running.","URL":"https:\/\/github.com\/codeclimate\/codeclimate","NumVotes":2,"Popularity":0.195245,"OutOfDate":null,"Maintainer":"manzo","FirstSubmitted":1435163516,"LastModified":1456341308,"URLPath":"\/cgit\/aur.git\/snapshot\/codeclimate.tar.gz","Depends":["docker"],"Groups":["codeclimate"],"License":["MIT"],"Keywords":[]},{"ID":279330,"Name":"google-cloud-sdk","PackageBaseID":82463,"PackageBase":"google-cloud-sdk","Version":"98.0.0-1","Description":"Contains tools and libraries that enable you to easily create and manage resources on Google Cloud Platform","URL":"https:\/\/cloud.google.com\/sdk\/","NumVotes":19,"Popularity":4.3396,"OutOfDate":null,"Maintainer":"troyengel","FirstSubmitted":1401783013,"LastModified":1456530951,"URLPath":"\/cgit\/aur.git\/snapshot\/google-cloud-sdk.tar.gz","Depends":["python2"],"MakeDepends":["python2"],"OptDepends":["go: for Go version of App Engine","java-environment: for Java version of App Engine","php: for PHP version of App Engine"],"License":["Apache"],"Keywords":["cloud","google","sdk"]},{"ID":279234,"Name":"python-botocore","PackageBaseID":97515,"PackageBase":"python-botocore","Version":"1.3.30-1","Description":"A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3","URL":"https:\/\/github.com\/boto\/botocore","NumVotes":10,"Popularity":2.234735,"OutOfDate":null,"Maintainer":"severach","FirstSubmitted":1439488478,"LastModified":1456507942,"URLPath":"\/cgit\/aur.git\/snapshot\/python-botocore.tar.gz","Depends":["python","python-bcdoc<0.15.0","python-wheel>=0.24.0","python-jmespath>=0.7.1","python-jmespath<1.0.0","python-tox>=1.4","python-dateutil>=2.1","python-dateutil<3.0.0","python-nose>=1.3.0","python-mock>=1.3.0","python-docutils>=0.10","python-six>=1.1.0","python-sphinx>=1.1.3","python-guzzle-sphinx-theme>=0.7.10","python-guzzle-sphinx-theme<0.8","python-behave>=1.2.5"],"MakeDepends":["python","python-distribute"],"License":["Apache"],"Keywords":[]}]} |
This file was deleted.
Oops, something went wrong.
Binary file not shown.
Binary file not shown.
File renamed without changes.
File renamed without changes.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
{"version":5,"type":"multiinfo","resultcount":1,"results":[{"ID":245498,"Name":"aurget","PackageBaseID":31933,"PackageBase":"aurget","Version":"4.6.0-1","Description":"A simple, Pacman-like AUR helper","URL":"https:\/\/github.com\/pbrisbin\/aurget","NumVotes":147,"Popularity":0.874734,"OutOfDate":null,"Maintainer":"brisbin33","FirstSubmitted":1257968246,"LastModified":1446668790,"URLPath":"\/cgit\/aur.git\/snapshot\/aurget.tar.gz","OptDepends":["customizepkg: for auto-customizing packages"],"License":["GPL"],"Keywords":[]}]} |
Oops, something went wrong.