Skip to content

Commit

Permalink
rust: update to 1.73.0
Browse files Browse the repository at this point in the history
patches refreshed.
changelog at https://github.com/rust-lang/rust/releases/tag/1.73.0

Signed-off-by: Oskari Rauta <oskari.rauta@gmail.com>
  • Loading branch information
oskarirauta committed Oct 12, 2023
1 parent b158d62 commit 13fe2cf
Show file tree
Hide file tree
Showing 3 changed files with 9 additions and 9 deletions.
6 changes: 3 additions & 3 deletions lang/rust/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -5,12 +5,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=rust
PKG_VERSION:=1.72.0
PKG_RELEASE:=3
PKG_VERSION:=1.73.0
PKG_RELEASE:=1

PKG_SOURCE:=rustc-$(PKG_VERSION)-src.tar.gz
PKG_SOURCE_URL:=https://static.rust-lang.org/dist/
PKG_HASH:=ea9d61bbb51d76b6ea681156f69f0e0596b59722f04414b01c6e100b4b5be3a1
PKG_HASH:=96d62e6d1f2d21df7ac8acb3b9882411f9e7c7036173f7f2ede9e1f1f6b1bb3a
HOST_BUILD_DIR:=$(BUILD_DIR)/host/rustc-$(PKG_VERSION)-src

PKG_MAINTAINER:=Luca Barbato <lu_zero@luminem.org>
Expand Down
4 changes: 2 additions & 2 deletions lang/rust/patches/0001-Update-xz2-and-use-it-static.patch
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,7 @@ Subject: [PATCH] Update xz2 and use it static

--- a/src/bootstrap/Cargo.lock
+++ b/src/bootstrap/Cargo.lock
@@ -430,9 +430,9 @@ dependencies = [
@@ -434,9 +434,9 @@ dependencies = [

[[package]]
name = "lzma-sys"
Expand All @@ -23,7 +23,7 @@ Subject: [PATCH] Update xz2 and use it static
dependencies = [
"cc",
"libc",
@@ -899,9 +899,9 @@ dependencies = [
@@ -903,9 +903,9 @@ dependencies = [

[[package]]
name = "xz2"
Expand Down
8 changes: 4 additions & 4 deletions lang/rust/patches/0002-rustc-bootstrap-cache.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/src/bootstrap/bootstrap.py
+++ b/src/bootstrap/bootstrap.py
@@ -543,7 +543,7 @@ class RustBuild(object):
@@ -546,7 +546,7 @@ class RustBuild(object):
shutil.rmtree(bin_root)

key = self.stage0_compiler.date
Expand All @@ -11,7 +11,7 @@
os.makedirs(rustc_cache)
--- a/src/bootstrap/download.rs
+++ b/src/bootstrap/download.rs
@@ -507,7 +507,10 @@ impl Config {
@@ -520,7 +520,10 @@ impl Config {
key: &str,
destination: &str,
) {
Expand All @@ -23,10 +23,10 @@
let cache_dir = cache_dst.join(key);
if !cache_dir.exists() {
t!(fs::create_dir_all(&cache_dir));
@@ -627,7 +630,10 @@ download-rustc = false
@@ -647,7 +650,10 @@ download-rustc = false
let llvm_assertions = self.llvm_assertions;

let cache_prefix = format!("llvm-{}-{}", llvm_sha, llvm_assertions);
let cache_prefix = format!("llvm-{llvm_sha}-{llvm_assertions}");
- let cache_dst = self.out.join("cache");
+ let cache_dst = match env::var_os("OPENWRT_RUSTC_BOOTSTRAP_CACHE") {
+ Some(v) => PathBuf::from(v),
Expand Down

0 comments on commit 13fe2cf

Please sign in to comment.