-
Notifications
You must be signed in to change notification settings - Fork 499
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
libxml-parser-perl: upgrade 2.46 -> 2.47
* Drop CheckLib.pm patch; no longer applies * Change to CPAN_MIRROR for SRC_URI * Drop SRC_URI[md5sum] * Drop redundant ptest-perl/run-ptest; ptest-perl inherit does this * Drop sed for Expat/Makefile; no longer shipped * Inherit pkgconfig to find expat lib * Patch Makefile.PL to not try to load host expat License-Update: Use LICENSE file; change to Artistic-2.0 https://metacpan.org/dist/XML-Parser/changes 2.47 2023-12-28 (by Todd Rinaldo) - #84 use $fh instead of $foo - #85 Fix typo in documentation - #89 Devel::CheckLib to from 0.99 -> 1.14 - Devel::CheckLibn 1.16 - #91 POD fix for verbatim text - #97 Add a LICENSE file - #94 Don't ship Expat/Makefile - Various github workflow improvements. Windows is still not working. Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
- Loading branch information
Showing
4 changed files
with
70 additions
and
83 deletions.
There are no files selected for viewing
24 changes: 0 additions & 24 deletions
24
...cipes-devtools/perl/files/0001-CheckLib.pm-do-not-attempt-to-run-a-cross-executable.patch
This file was deleted.
Oops, something went wrong.
28 changes: 28 additions & 0 deletions
28
...pes-devtools/perl/libxml-parser-perl/0001-Makefile.PL-make-check_lib-cross-friendly.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,28 @@ | ||
From bd9b0e10843da72276982bd1394ade734fea0289 Mon Sep 17 00:00:00 2001 | ||
From: Tim Orling <tim.orling@konsulko.com> | ||
Date: Fri, 2 Feb 2024 21:15:34 -0800 | ||
Subject: [PATCH] Makefile.PL: make check_lib cross friendly | ||
|
||
lib => qw(expat) does not seem to respect EXPATLIBPATH and | ||
EXPATINCPATH when we are cross-compiling. | ||
|
||
Upstream-Status: Inappropriate [OE specific] | ||
|
||
Signed-off-by: Tim Orling <tim.orling@konsulko.com> | ||
--- | ||
Makefile.PL | 2 +- | ||
1 file changed, 1 insertion(+), 1 deletion(-) | ||
|
||
diff --git a/Makefile.PL b/Makefile.PL | ||
index 505d1df..19f428b 100644 | ||
--- a/Makefile.PL | ||
+++ b/Makefile.PL | ||
@@ -30,7 +30,7 @@ foreach (@ARGV) { | ||
|
||
unless ( | ||
check_lib( # fill in what you prompted the user for here | ||
- lib => [qw(expat)], | ||
+ #lib => [qw(expat)], | ||
header => ['expat.h'], | ||
incpath => $expat_incpath, | ||
( $expat_libpath ? ( libpath => $expat_libpath ) : () ), |
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
SUMMARY = "XML::Parser - A perl module for parsing XML documents" | ||
HOMEPAGE = "https://libexpat.github.io/" | ||
SECTION = "libs" | ||
LICENSE = "Artistic-2.0" | ||
LIC_FILES_CHKSUM = "file://LICENSE;md5=4342f85bf14a1fdd6a751573f1e61c03" | ||
|
||
DEPENDS += "expat" | ||
|
||
SRC_URI = "${CPAN_MIRROR}/modules/by-module/XML/XML-Parser-${PV}.tar.gz \ | ||
file://0001-Makefile.PL-make-check_lib-cross-friendly.patch \ | ||
" | ||
|
||
SRC_URI[sha256sum] = "ad4aae643ec784f489b956abe952432871a622d4e2b5c619e8855accbfc4d1d8" | ||
|
||
S = "${WORKDIR}/XML-Parser-${PV}" | ||
|
||
EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR} CC='${CC}' LD='${CCLD}' FULL_AR='${AR}'" | ||
|
||
inherit cpan pkgconfig ptest-perl | ||
|
||
do_compile() { | ||
export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" | ||
cpan_do_compile | ||
} | ||
|
||
do_compile:class-native() { | ||
cpan_do_compile | ||
} | ||
|
||
do_install_ptest() { | ||
sed -i -e "s:/usr/local/bin/perl:/usr/bin/perl:g" ${B}/samples/xmlstats | ||
sed -i -e "s:/usr/local/bin/perl:/usr/bin/perl:g" ${B}/samples/xmlfilter | ||
sed -i -e "s:/usr/local/bin/perl:/usr/bin/perl:g" ${B}/samples/xmlcomments | ||
sed -i -e "s:/usr/local/bin/perl:/usr/bin/perl:g" ${B}/samples/canonical | ||
cp -r ${B}/samples ${D}${PTEST_PATH} | ||
chown -R root:root ${D}${PTEST_PATH}/samples | ||
} | ||
|
||
RDEPENDS:${PN} += "perl-module-carp perl-module-file-spec" | ||
RDEPENDS:${PN}-ptest += "perl-module-filehandle perl-module-if perl-module-test perl-module-test-more" | ||
|
||
BBCLASSEXTEND="native nativesdk" |