Skip to content

Commit

Permalink
python3-h5py: Upgrade 3.1.0 -> 3.2.1
Browse files Browse the repository at this point in the history
Upgrade to release 3.2.1:

- Added support to use the HDF5 ROS3 driver to access HDF5 files
  on S3
- Setting the config option default_file_mode to values other than
  'r' is deprecated. Pass the desired mode when opening a
  :class:`~.File` instead.
- :exc:`OSError` exceptions raised by h5py should now have a useful
  .errno attribute, where HDF5 provides this information.
  Subclasses such as :exc:`FileNotFoundError` should also be raised
  where appropriate.
- Fix reading data with a datatype of variable-length arrays of
  fixed length strings.
- Fix :meth:`.Dataset.read_direct` and :meth:`.Dataset.write_direct`
  when the source and destination have different shapes.
- Fix selecting data using integer indices in
  :meth:`.Dataset.read_direct` and :meth:`.Dataset.write_direct`.
- Fix exception handling in :meth:`.Group.visititems`.
- Issue a warning when File(..., swmr=True) is specified with any
  mode other than 'r', as the SWMR option is ignored in these cases.
- Fix NumPy 1.20 deprecation warnings concerning the use of None as
  shape, and the deprecated aliases np.float, np.int and np.bool.
- Fix :attr:`.File.driver` when the read-only S3 driver is
  available.

Add hdf5-native as a dependency to avoid:

error: libhdf5.so: cannot open shared object file: No such file or directory

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
  • Loading branch information
leon-anavi authored and kraj committed Apr 1, 2021
1 parent 8f3ee91 commit f95812d
Show file tree
Hide file tree
Showing 3 changed files with 8 additions and 7 deletions.
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From e6c0d487fb5e6063305b8b3187896fbfe5720ed2 Mon Sep 17 00:00:00 2001
From b1d4d171fd13624f3d8bb917f716b62494066501 Mon Sep 17 00:00:00 2001
From: Leon Anavi <leon.anavi@konsulko.com>
Date: Mon, 22 Feb 2021 18:42:43 +0200
Subject: [PATCH] setup.py: Fix numpy version
Expand All @@ -14,12 +14,12 @@ Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/setup.py b/setup.py
index 7dbe583..6602c97 100755
index 4b2890c..42ba21b 100755
--- a/setup.py
+++ b/setup.py
@@ -49,7 +49,7 @@ SETUP_REQUIRES = [
f"Cython >=0.29; python_version<'3.8'",
f"Cython >=0.29.14; python_version>='3.8'",
"Cython >=0.29.14; python_version=='3.8'",
"Cython >=0.29.15; python_version>='3.9'",
] + [
- f"numpy =={np_min}; python_version{py_condition}"
+ f"numpy >={np_min}; python_version{py_condition}"
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From 1a46082d0889a784037952c4da0cde3822849032 Mon Sep 17 00:00:00 2001
From 6f8cee826ef9309c174aa97cb6af2ba532ed9dba Mon Sep 17 00:00:00 2001
From: Mingli Yu <mingli.yu@windriver.com>
Date: Thu, 28 Jan 2021 18:44:10 -0800
Subject: [PATCH] setup_build.py: avoid absolute path
Expand All @@ -15,7 +15,7 @@ Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/setup_build.py b/setup_build.py
index 3c7c7ad..d824bdd 100644
index 78c6677..64db7f7 100644
--- a/setup_build.py
+++ b/setup_build.py
@@ -21,7 +21,7 @@ from setup_configure import BuildConfig
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@ SECTION = "devel/python"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=113251d71fb0384712c719b567261c5c"

SRC_URI[sha256sum] = "1e2516f190652beedcb8c7acfa1c6fa92d99b42331cbef5e5c7ec2d65b0fc3c2"
SRC_URI[sha256sum] = "89474be911bfcdb34cbf0d98b8ec48b578c27a89fdb1ae4ee7513f1ef8d9249e"

SRC_URI_append = " \
file://0001-setup_build.py-avoid-absolute-path.patch \
Expand All @@ -19,6 +19,7 @@ DEPENDS = "python3-pkgconfig-native \
python3-cython-native \
python3-numpy-native \
python3-six-native \
hdf5-native \
python3 \
hdf5 \
"
Expand Down

0 comments on commit f95812d

Please sign in to comment.