Skip to content

Commit

Permalink
tslib: Fix build with 4.x kernel headers
Browse files Browse the repository at this point in the history
Fixes
    | ../../tslib-1.21/tools/ts_uinput.c:337:15: error: 'struct input_event' has no member named 'input_event_usec'
    |   337 |    data->ev[c].input_event_usec = s[j][i].tv.tv_usec;
    |       |               ^

Signed-off-by: Khem Raj <raj.khem@gmail.com>
  • Loading branch information
kraj committed Apr 25, 2020
1 parent f663e84 commit 9201611
Show file tree
Hide file tree
Showing 2 changed files with 31 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
From 050bf24c16e95f63a76e13156346a072035d45b4 Mon Sep 17 00:00:00 2001
From: Evan Harvey <evanwork1234@gmail.com>
Date: Thu, 19 Mar 2020 01:32:03 -0700
Subject: [PATCH] Fix build error with input_event_sec for old kernel

Upstream-Status: Backport [https://github.com/libts/tslib/commit/050bf24c16e95f63a76e13156346a072035d45b4]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
tools/ts_uinput.c | 5 +++++
1 file changed, 5 insertions(+)

diff --git a/tools/ts_uinput.c b/tools/ts_uinput.c
index 1832a07..9c40bb3 100644
--- a/tools/ts_uinput.c
+++ b/tools/ts_uinput.c
@@ -51,6 +51,11 @@
#include <linux/fb.h>
#endif

+#ifndef input_event_sec
+#define input_event_sec time.tv_sec
+#define input_event_usec time.tv_usec
+#endif
+
#define RESET "\033[0m"
#define RED "\033[31m"
#define GREEN "\033[32m"
--
2.26.2

1 change: 1 addition & 0 deletions meta-oe/recipes-graphics/tslib/tslib_1.21.bb
Original file line number Diff line number Diff line change
Expand Up @@ -15,6 +15,7 @@ LIC_FILES_CHKSUM = "\

SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.tar.xz;downloadfilename=tslib-${PV}.tar.xz \
file://0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch \
file://0001-Fix-build-error-with-input_event_sec-for-old-kernel.patch \
file://ts.conf \
file://tslib.sh \
"
Expand Down

0 comments on commit 9201611

Please sign in to comment.