Skip to content

Commit

Permalink
abseil-cpp: Upgrade to head on 2022-10-14
Browse files Browse the repository at this point in the history
Our team wants to use absl/log which was recently added to abseil.
  • Loading branch information
UlysseM committed Oct 18, 2022
1 parent 6529e5f commit 4c54779
Show file tree
Hide file tree
Showing 3 changed files with 8 additions and 8 deletions.
Original file line number Diff line number Diff line change
Expand Up @@ -20,7 +20,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
#ifdef __GLIBC__
#include <sys/platform/ppc.h>
#elif defined(__FreeBSD__)
@@ -53,7 +53,7 @@ double UnscaledCycleClock::Frequency() {
@@ -58,7 +58,7 @@ double UnscaledCycleClock::Frequency() {
return base_internal::NominalCPUFrequency();
}

Expand All @@ -29,9 +29,9 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>

int64_t UnscaledCycleClock::Now() {
#ifdef __GLIBC__
--- a/absl/base/internal/unscaledcycleclock.h
+++ b/absl/base/internal/unscaledcycleclock.h
@@ -46,7 +46,8 @@
--- a/absl/base/internal/unscaledcycleclock_config.h
+++ b/absl/base/internal/unscaledcycleclock_config.h
@@ -21,7 +21,8 @@

// The following platforms have an implementation of a hardware counter.
#if defined(__i386__) || defined(__x86_64__) || defined(__aarch64__) || \
Expand Down
6 changes: 3 additions & 3 deletions meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
Original file line number Diff line number Diff line change
Expand Up @@ -7,9 +7,9 @@ SECTION = "libs"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=df52c6edb7adc22e533b2bacc3bd3915"

PV = "20220623.1"
SRCREV = "8c0b94e793a66495e0b1f34a5eb26bd7dc672db0"
BRANCH = "lts_2022_06_23"
PV = "20221014.0"
SRCREV = "5fa65f28e46e86c44966a1ca8a727a329d9c1ff8"
BRANCH = "master"
SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH};protocol=https \
file://0001-absl-always-use-asm-sgidefs.h.patch \
file://0002-Remove-maes-option-from-cross-compilation.patch \
Expand Down
2 changes: 1 addition & 1 deletion meta-oe/recipes-devtools/grpc/grpc_1.45.2.bb
Original file line number Diff line number Diff line change
Expand Up @@ -28,7 +28,7 @@ SRC_URI = "git://github.com/grpc/grpc.git;protocol=https;name=grpc;branch=${BRAN
file://0001-cmake-Link-with-libatomic-on-rv32-rv64.patch \
"
# Fixes build with older compilers 4.8 especially on ubuntu 14.04
CXXFLAGS:append:class-native = " -Wl,--no-as-needed"
CXXFLAGS:append:class-native = " -Wl,--no-as-needed -std=c++14"

inherit cmake pkgconfig

Expand Down

0 comments on commit 4c54779

Please sign in to comment.