forked from openwrt/packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge pull request openwrt#5988 from diizzyy/patch-9
bluez: Update to 5.49
- Loading branch information
Showing
7 changed files
with
93 additions
and
59 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,10 @@ | ||
--- a/src/shared/util.h.old 2016-09-26 07:29:00.000000000 -0500 | ||
+++ b/src/shared/util.h 2017-12-27 22:49:50.538716424 -0600 | ||
@@ -26,6 +26,7 @@ | ||
#include <alloca.h> | ||
#include <byteswap.h> | ||
#include <string.h> | ||
+#include <endian.h> | ||
|
||
#if __BYTE_ORDER == __LITTLE_ENDIAN | ||
#define le16_to_cpu(val) (val) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,61 @@ | ||
Submitted By: Armin K. <krejzi at email dot com> | ||
Date: 2013-04-29 | ||
Initial Package Version: 5.17 | ||
Upstream Status: unknown | ||
Origin: Arch Linux (Giovanni Campagna) | ||
Description: Allow using obexd without systemd in the user session | ||
|
||
Not all sessions run systemd --user (actually, the majority | ||
doesn't), so the dbus daemon must be able to spawn obexd | ||
directly, and to do so it needs the full path of the daemon. | ||
--- | ||
Makefile.obexd | 4 ++-- | ||
obexd/src/org.bluez.obex.service | 4 ---- | ||
obexd/src/org.bluez.obex.service.in | 4 ++++ | ||
3 files changed, 6 insertions(+), 6 deletions(-) | ||
delete mode 100644 obexd/src/org.bluez.obex.service | ||
create mode 100644 obexd/src/org.bluez.obex.service.in | ||
|
||
diff --git a/Makefile.obexd b/Makefile.obexd | ||
index 3760867..142e7c3 100644 | ||
--- a/Makefile.obexd | ||
+++ b/Makefile.obexd | ||
@@ -2,12 +2,12 @@ | ||
if SYSTEMD | ||
systemduserunitdir = @SYSTEMD_USERUNITDIR@ | ||
systemduserunit_DATA = obexd/src/obex.service | ||
+endif | ||
|
||
dbussessionbusdir = @DBUS_SESSIONBUSDIR@ | ||
dbussessionbus_DATA = obexd/src/org.bluez.obex.service | ||
-endif | ||
|
||
-EXTRA_DIST += obexd/src/obex.service.in obexd/src/org.bluez.obex.service | ||
+EXTRA_DIST += obexd/src/obex.service.in obexd/src/org.bluez.obex.service.in | ||
|
||
obex_plugindir = $(libdir)/obex/plugins | ||
|
||
diff --git a/obexd/src/org.bluez.obex.service b/obexd/src/org.bluez.obex.service | ||
deleted file mode 100644 | ||
index a538088..0000000 | ||
--- a/obexd/src/org.bluez.obex.service | ||
+++ /dev/null | ||
@@ -1,4 +0,0 @@ | ||
-[D-BUS Service] | ||
-Name=org.bluez.obex | ||
-Exec=/bin/false | ||
-SystemdService=dbus-org.bluez.obex.service | ||
diff --git a/obexd/src/org.bluez.obex.service.in b/obexd/src/org.bluez.obex.service.in | ||
new file mode 100644 | ||
index 0000000..9c815f2 | ||
--- /dev/null | ||
+++ b/obexd/src/org.bluez.obex.service.in | ||
@@ -0,0 +1,4 @@ | ||
+[D-BUS Service] | ||
+Name=org.bluez.obex | ||
+Exec=@libexecdir@/obexd | ||
+SystemdService=dbus-org.bluez.obex.service | ||
-- | ||
1.8.3.1 | ||
|
||
|