Skip to content

Commit

Permalink
build: consistently use 'depends on' instead of 'depends'
Browse files Browse the repository at this point in the history
make the syntax more compatible with kernel menuconfig

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 36351
  • Loading branch information
Felix Fietkau committed Apr 17, 2013
1 parent 6d3c6e3 commit 96bb7c1
Show file tree
Hide file tree
Showing 21 changed files with 150 additions and 150 deletions.
78 changes: 39 additions & 39 deletions Config.in
Original file line number Diff line number Diff line change
Expand Up @@ -25,7 +25,7 @@ menu "Target Images"
default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ar71xx
default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ramips
default TARGET_INITRAMFS_COMPRESSION_NONE
depends TARGET_ROOTFS_INITRAMFS
depends on TARGET_ROOTFS_INITRAMFS
help
Select ramdisk compression.

Expand Down Expand Up @@ -74,36 +74,36 @@ menu "Target Images"
config TARGET_ROOTFS_EXT4FS
bool "ext4"
default y if USES_EXT4
depends !TARGET_ROOTFS_INITRAMFS
depends on !TARGET_ROOTFS_INITRAMFS
help
Ext4 file system with some free space for uml images

config TARGET_ROOTFS_ISO
bool "iso"
default n
depends on TARGET_x86_generic
depends !TARGET_ROOTFS_INITRAMFS
depends on !TARGET_ROOTFS_INITRAMFS
help
Create some bootable ISO image

config TARGET_ROOTFS_JFFS2
bool "jffs2"
default y if USES_JFFS2
depends !TARGET_ROOTFS_INITRAMFS
depends on !TARGET_ROOTFS_INITRAMFS
help
Build a jffs2 root filesystem

config TARGET_ROOTFS_SQUASHFS
bool "squashfs"
default y if USES_SQUASHFS
depends !TARGET_ROOTFS_INITRAMFS
depends on !TARGET_ROOTFS_INITRAMFS
help
Build a squashfs-lzma root filesystem

config TARGET_ROOTFS_UBIFS
bool "ubifs"
default y if USES_UBIFS
depends !TARGET_ROOTFS_INITRAMFS && USES_UBIFS
depends on !TARGET_ROOTFS_INITRAMFS && USES_UBIFS
help
Build a ubifs root filesystem

Expand All @@ -113,21 +113,21 @@ menu "Target Images"

config TARGET_ROOTFS_PARTSIZE
int "Root filesystem partition size (in MB)"
depends X86_GRUB_IMAGES || TARGET_ROOTFS_EXT4FS || TARGET_rb532
depends on X86_GRUB_IMAGES || TARGET_ROOTFS_EXT4FS || TARGET_rb532
default 48
help
Allows you to change the root filesystem partition size

config TARGET_ROOTFS_MAXINODE
int "Maximum number of inodes in root filesystem"
depends TARGET_ROOTFS_EXT4FS
depends on TARGET_ROOTFS_EXT4FS
default 6000
help
Allows you to change the maximum number of inodes in the root filesystem

config TARGET_ROOTFS_RESERVED_PCT
int "Percentage of reserved blocks in root filesystem"
depends TARGET_ROOTFS_EXT4FS
depends on TARGET_ROOTFS_EXT4FS
default 0
help
Allows you to change the percentage of reserved blocks in the root filesystem
Expand Down Expand Up @@ -303,90 +303,90 @@ menu "Global build settings"
config KERNEL_FREEZER
bool
default y if KERNEL_CGROUP_FREEZER
depends KERNEL_CGROUPS
depends on KERNEL_CGROUPS

config KERNEL_CGROUP_FREEZER
bool
depends KERNEL_CGROUPS
depends on KERNEL_CGROUPS

config KERNEL_CGROUP_DEVICE
bool
depends KERNEL_CGROUPS
depends on KERNEL_CGROUPS

config KERNEL_CPUSETS
bool
default y if KERNEL_CGROUP_CPUACCT
depends KERNEL_CGROUPS
depends on KERNEL_CGROUPS

config KERNEL_PROC_PID_CPUSET
bool
default y if KERNEL_CGROUP_CPUACCT
depends KERNEL_CGROUPS
depends on KERNEL_CGROUPS

config KERNEL_CGROUP_CPUACCT
bool
depends KERNEL_CGROUPS
depends on KERNEL_CGROUPS

config KERNEL_RESOURCE_COUNTERS
bool
default y if KERNEL_CGROUP_MEM_RES_CTLR
depends KERNEL_CGROUPS
depends on KERNEL_CGROUPS

config KERNEL_CGROUP_MEM_RES_CTLR
bool
depends KERNEL_CGROUPS
depends on KERNEL_CGROUPS

config KERNEL_CGROUP_MEM_RES_CTLR_SWAP
bool
depends KERNEL_CGROUPS
depends on KERNEL_CGROUPS

config KERNEL_CGROUP_MEM_RES_CTLR_SWAP_ENABLED
bool
depends KERNEL_CGROUPS
depends on KERNEL_CGROUPS

config KERNEL_CGROUP_MEM_RES_CTLR_KMEM
bool
depends KERNEL_CGROUPS
depends on KERNEL_CGROUPS

config KERNEL_CGROUP_PERF
bool
depends KERNEL_CGROUPS
depends on KERNEL_CGROUPS

config KERNEL_CFS_BANDWIDTH
bool
default y if KERNEL_FAIR_GROUP_SCHED
depends KERNEL_CGROUP_SCHED
depends on KERNEL_CGROUP_SCHED

config KERNEL_FAIR_GROUP_SCHED
bool
default y if KERNEL_CGROUP_SCHED
depends KERNEL_CGROUP_SCHED
depends on KERNEL_CGROUP_SCHED

config KERNEL_RT_GROUP_SCHED
bool
default y if KERNEL_CGROUP_SCHED
depends KERNEL_CGROUP_SCHED
depends on KERNEL_CGROUP_SCHED

config KERNEL_CGROUP_SCHED
bool
depends KERNEL_CGROUPS
depends on KERNEL_CGROUPS

config KERNEL_NET_CLS_CGROUP
bool
depends KERNEL_CGROUPS
depends on KERNEL_CGROUPS

config KERNEL_NETPRIO_CGROUP
bool
depends KERNEL_CGROUPS
depends on KERNEL_CGROUPS

config KERNEL_BLK_CGROUP
bool
depends KERNEL_CGROUPS
depends on KERNEL_CGROUPS

config KERNEL_DEBUG_BLK_CGROUP
bool
default n if KERNEL_CGROUPS
depends KERNEL_CGROUPS
depends on KERNEL_CGROUPS

config KERNEL_CGROUPS
bool "Enable kernel cgroups"
Expand All @@ -410,27 +410,27 @@ menu "Global build settings"

config KERNEL_UTS_NS
bool
depends KERNEL_NAMESPACES
depends on KERNEL_NAMESPACES

config KERNEL_IPC_NS
bool
depends KERNEL_NAMESPACES
depends on KERNEL_NAMESPACES

config KERNEL_USER_NS
bool
depends KERNEL_NAMESPACES
depends on KERNEL_NAMESPACES

config KERNEL_PID_NS
bool
depends KERNEL_NAMESPACES
depends on KERNEL_NAMESPACES

config KERNEL_NET_NS
bool
depends KERNEL_NAMESPACES
depends on KERNEL_NAMESPACES

config KERNEL_DEVPTS_MULTIPLE_INSTANCES
bool
depends KERNEL_NAMESPACES
depends on KERNEL_NAMESPACES

config KERNEL_NAMESPACES
bool "Enable kernel namespaces"
Expand Down Expand Up @@ -536,17 +536,17 @@ menu "Global build settings"

config USE_SSTRIP
bool "sstrip"
depends !DEBUG
depends !USE_GLIBC
depends !USE_EGLIBC
depends on !DEBUG
depends on !USE_GLIBC
depends on !USE_EGLIBC
help
This will install binaries stripped using sstrip
endchoice

config STRIP_ARGS
string
prompt "Strip arguments"
depends USE_STRIP
depends on USE_STRIP
default "--strip-unneeded --remove-section=.comment --remove-section=.note" if DEBUG
default "--strip-all"
help
Expand Down
8 changes: 4 additions & 4 deletions package/libs/libpcap/Config.in
Original file line number Diff line number Diff line change
@@ -1,15 +1,15 @@
menu "Configuration"
depends PACKAGE_libpcap
depends on PACKAGE_libpcap

config PCAP_HAS_USB
bool "Include USB support"
depends PACKAGE_kmod-usb-core
depends on PACKAGE_kmod-usb-core
default n

config PCAP_HAS_BT
bool "Include bluetooth support"
depends PACKAGE_kmod-bluetooth
depends BROKEN
depends on PACKAGE_kmod-bluetooth
depends on BROKEN
default n

endmenu
2 changes: 1 addition & 1 deletion package/libs/openssl/Config.in
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ config OPENSSL_ENGINE_CRYPTO

config OPENSSL_ENGINE_DIGEST
bool
depends OPENSSL_ENGINE_CRYPTO
depends on OPENSSL_ENGINE_CRYPTO
prompt "Digests acceleration support"

endmenu
2 changes: 1 addition & 1 deletion package/mac80211/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -221,7 +221,7 @@ define KernelPackage/rt2x00-lib/config

config PACKAGE_RT2X00_LIB_DEBUGFS
bool "Enable rt2x00 debugfs support"
depends PACKAGE_MAC80211_DEBUGFS
depends on PACKAGE_MAC80211_DEBUGFS
help
Enable creation of debugfs files for the rt2x00 drivers.
These debugfs files support both reading and writing of the
Expand Down
6 changes: 3 additions & 3 deletions package/network/services/hostapd/Config.in
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# wpa_supplicant config
config WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
bool "Disable timestamp check"
depends PACKAGE_wpa-supplicant || PACKAGE_wpa-supplicant-mini || PACKAGE_wpad || PACKAGE_wpad-mini
depends on PACKAGE_wpa-supplicant || PACKAGE_wpa-supplicant-mini || PACKAGE_wpad || PACKAGE_wpad-mini
default n
help
This disables the timestamp check for certificates in wpa_supplicant
Expand All @@ -10,7 +10,7 @@ config WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
choice
prompt "Choose TLS provider"
default WPA_SUPPLICANT_INTERNAL
depends PACKAGE_wpa-supplicant || PACKAGE_wpad
depends on PACKAGE_wpa-supplicant || PACKAGE_wpad

config WPA_SUPPLICANT_INTERNAL
bool "internal"
Expand All @@ -23,7 +23,7 @@ endchoice

config WPA_RFKILL_SUPPORT
bool "Add rfkill support"
depends PACKAGE_wpa-supplicant || PACKAGE_wpa-supplicant-mini || PACKAGE_wpad || PACKAGE_wpad-mini
depends on PACKAGE_wpa-supplicant || PACKAGE_wpa-supplicant-mini || PACKAGE_wpad || PACKAGE_wpad-mini
default n

config WPA_MSG_MIN_PRIORITY
Expand Down
2 changes: 1 addition & 1 deletion package/network/services/samba36/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -49,7 +49,7 @@ endef
define Package/samba36-server/config
config PACKAGE_SAMBA_MAX_DEBUG_LEVEL
int "Maximum level of compiled-in debug messages"
depends PACKAGE_samba36-server || PACKAGE_samba36-client
depends on PACKAGE_samba36-server || PACKAGE_samba36-client
default -1

endef
Expand Down
2 changes: 1 addition & 1 deletion package/system/mmc_over_gpio/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -25,7 +25,7 @@ endef

define Package/kmod-mmc-over-gpio/config
menu "Configuration"
depends PACKAGE_kmod-mmc-over-gpio
depends on PACKAGE_kmod-mmc-over-gpio

config KMOD_MMC_OVER_GPIO_DI_PIN
int "GPIO DI (Data-In) pin"
Expand Down
Loading

0 comments on commit 96bb7c1

Please sign in to comment.