Skip to content

Commit

Permalink
naja: init at 0-unstable-2024-07-21
Browse files Browse the repository at this point in the history
Co-authored-by: Cosima Neidahl <opna2608@protonmail.com>
  • Loading branch information
2 people authored and fricklerhandwerk committed Aug 1, 2024
1 parent d1648dd commit 5bb89ef
Showing 1 changed file with 69 additions and 0 deletions.
69 changes: 69 additions & 0 deletions pkgs/by-name/naja/package.nix
Original file line number Diff line number Diff line change
@@ -0,0 +1,69 @@
{
lib,
stdenv,
fetchFromGitHub,
cmake,
bison,
boost,
capnproto,
doxygen,
flex,
libdwarf-lite,
pkg-config,
python3,
tbb_2021_11,
}:
stdenv.mkDerivation {
pname = "naja";
version = "0-unstable-2024-07-21";

src = fetchFromGitHub {
owner = "najaeda";
repo = "naja";
rev = "8c068f3bd1bbd57b851547f191a58a375fd35cda";
hash = "sha256-aUYPJGr4D5n92fp0namPT6I/gMRZoF7YHnB7GoRzwYI=";
fetchSubmodules = true;
};

outputs = [
"dev"
"lib"
"out"
];

strictDeps = true;

nativeBuildInputs = [
bison
capnproto
cmake
doxygen
flex
pkg-config
python3
];

buildInputs = [
boost
capnproto # cmake modules
flex # include dir
libdwarf-lite
tbb_2021_11
];

cmakeFlags = [
(lib.cmakeBool "CPPTRACE_USE_EXTERNAL_LIBDWARF" true)
(lib.cmakeBool "CPPTRACE_USE_EXTERNAL_ZSTD" true)
];

doCheck = true;

meta = {
description = "Structural Netlist API (and more) for EDA post synthesis flow development";
homepage = "https://github.com/najaeda/naja";
license = lib.licenses.asl20;
maintainers = with lib.maintainers; [];
mainProgram = "naja_edit";
platforms = lib.platforms.all;
};
}

0 comments on commit 5bb89ef

Please sign in to comment.