-
Notifications
You must be signed in to change notification settings - Fork 18
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
nitrokey-firmware: migrate to monorepo
Co-authored-by: Auguste Baum <auguste.apple@gmail.com>
- Loading branch information
1 parent
78177f3
commit 45d5d29
Showing
8 changed files
with
77 additions
and
168 deletions.
There are no files selected for viewing
Some generated files are not rendered by default. Learn more about how customized files appear on GitHub.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
{inputs}: let | ||
system = "x86_64-linux"; | ||
overlays = [inputs.rust-overlay.overlays.default]; | ||
pkgs = import inputs.nixpkgs { | ||
inherit system overlays; | ||
}; | ||
pkgsArm = import inputs.nixpkgs { | ||
inherit system overlays; | ||
crossSystem.config = "arm-none-eabi"; | ||
config.allowUnfree = true; # nitrokey-fido2 → pynitrokey → nrfutil | ||
}; | ||
pkgsAvr = import inputs.nixpkgs { | ||
inherit system overlays; | ||
crossSystem.config = "avr"; | ||
}; | ||
in { | ||
nitrokey-3 = pkgs.callPackage ./devices/nitrokey-3.nix ( | ||
let | ||
rust = pkgs.rust-bin.stable.latest.default.override { | ||
extensions = ["llvm-tools-preview"]; | ||
targets = ["thumbv8m.main-none-eabi"]; | ||
}; | ||
in { | ||
rustPlatform = pkgs.recurseIntoAttrs (pkgs.makeRustPlatform { | ||
rustc = rust; | ||
cargo = rust; | ||
}); | ||
} | ||
); | ||
nitrokey-storage = pkgs.callPackage ./devices/nitrokey-storage.nix {}; | ||
nitrokey-fido2 = pkgsArm.callPackage ./devices/nitrokey-fido2.nix {}; | ||
nitrokey-pro = pkgsArm.callPackage ./devices/nitrokey-pro.nix {}; | ||
nitrokey-start = pkgsArm.callPackage ./devices/nitrokey-start.nix {}; | ||
nitrokey-trng-rs232 = pkgsAvr.callPackage ./devices/nitrokey-trng-rs232.nix {}; | ||
} |
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.