Repository navigation
[bug] Internal Server Error after installation of 29.0.5 #2283
Description
Activity
- changed the title
[-][bug] Internal Server Error[/-][+][bug] Internal Server Error: `Failed to open stream: No such file or directory at /var/www/html/lib/private/Config.php`[/+]on Aug 24, 2024 joshtrichards commented
on Aug 24, 2024 on Aug 24, 2024 · Hidden as resolvedshow commentMore actionsIs our 28.0.9 image broken too?
As mentioned before, installing and upgrading 28.0.9 and 29.0.4 images works fine (except for that minor issue with the latter).
Thanks for your prompt and careful remarks.
Reacted by JoshPossible workaround: Specify
NEXTCLOUD_ADMIN_USERandNEXTCLOUD_ADMIN_PASSWORD(skips the web installer)Reacted by walterzillaReacted by h4b4n3r0Oh man. :P Yesterday everything was working with my test setup and today ... it drove me crazy.
Thanks for giving the hint with the additional env variables. It worked for me!Reacted by Joshjoshtrichards commented
on Aug 24, 2024 on Aug 24, 2024 · Hidden as resolvedshow commentMore actionsPossible workaround: Specify
NEXTCLOUD_ADMIN_USERandNEXTCLOUD_ADMIN_PASSWORD(skips the web installer)Interesting idea...but I have to point out that in my case doing so results in at least two collateral inconveniences:
trusted_domainsconfig var being set tolocalhost- security warning
Your data directory and files are probably accessible from the internet(etc etc...) appearing
Both of them (especially first one) can be fixed in no time if one knows where to put its hands, still I guess meanwhile better stick to a more straightforward workaround like upgrading from previous release...
You can set
NEXTCLOUD_TRUSTED_DOMAINStoo.You can set
NEXTCLOUD_TRUSTED_DOMAINStoo.Sure, that's the reason I wrote expecially first one...still it takes some more effort to solve second one so I reckon it's going to be only a waste of time for a docker typical user wishing to keep things simple.
- changed the title
[-][bug] Internal Server Error: `Failed to open stream: No such file or directory at /var/www/html/lib/private/Config.php`[/-][+][bug] Internal Server Error after installation of 29.0.5[/+]on Aug 27, 2024 Confirmed to be upstream (server) as suspected.
Fixed in nextcloud/server#47521
Reacted by walterzillaKeeping open until:
- Upstream backport is merged into stable29: [stable29] fix(logger): ignore session logging during setup server#47549
- Upstream publishes a new release (29.0.6): tracker TBD
- We publish a new image after the above are completed
Reacted by walterzilla, Manu, h4b4n3r0 and inwerk- pinned this issue
on Aug 27, 2024 Upstream 29.0.6 published formally: nextcloud-releases/updater_server#1113
Reacted by walterzillaReacted by Manu- Reacted by walterzilla
Setting up brand new istance using stock composer file with latest
nextcloudimage results inInternal Server Errorshortly after pressing Install button.No errors in containers log but inside NC one I can found following:
Failed to open stream: No such file or directory at /var/www/html/lib/private/Config.phpAnyway said file is there...
Quick workaround would be installing and upgrading previous minor release (29.0.4) but in that case one's facing a
Connection refusederror which requires editing mariadb container's default hostname (from container's one to host's one) so maybe would be better installing and upgrading previous major release (28.0.9) instead.