Skip to content

Commit

Permalink
boost: build with cmake
Browse files Browse the repository at this point in the history
  • Loading branch information
MehdiChinoune committed Sep 29, 2024
1 parent ad045b5 commit b2d3117
Show file tree
Hide file tree
Showing 13 changed files with 108 additions and 612 deletions.
41 changes: 41 additions & 0 deletions mingw-w64-boost/0001-Fix-building-with-cmake-on-MINGW.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
--- a/libs/cobalt/CMakeLists.txt
+++ b/libs/cobalt/CMakeLists.txt
@@ -60,6 +60,12 @@
Boost::throw_exception
Boost::variant2
)
+ if(MINGW)
+ target_link_libraries(boost_cobalt
+ PRIVATE
+ ws2_32
+ )
+ endif()

target_compile_definitions(boost_cobalt
PUBLIC BOOST_COBALT_NO_LIB=1
--- a/libs/log/CMakeLists.txt
+++ b/libs/log/CMakeLists.txt
@@ -656,6 +656,12 @@
PRIVATE
${boost_log_common_private_linkflags}
)
+ if(MINGW)
+ target_link_libraries(boost_log_setup
+ PRIVATE
+ ws2_32
+ )
+ endif()
else()
add_library(boost_log_setup INTERFACE)
target_include_directories(boost_log_setup INTERFACE include)
--- a/libs/process/CMakeLists.txt
+++ b/libs/process/CMakeLists.txt
@@ -57,7 +57,7 @@
endif()

if (WIN32)
- target_link_libraries(boost_process PUBLIC ntdll shell32 advapi32 user32)
+ target_link_libraries(boost_process PUBLIC ntdll shell32 advapi32 user32 ws2_32)
endif()

if(BUILD_SHARED_LIBS)
12 changes: 12 additions & 0 deletions mingw-w64-boost/0002-No-Arch-in-library-name-tag.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
--- a/tools/cmake/include/BoostInstall.cmake
+++ b/tools/cmake/include/BoostInstall.cmake
@@ -175,9 +175,6 @@
endif()

endif()
-
- string(APPEND name_debug "-${arch}${bits}")
- string(APPEND name_release "-${arch}${bits}")

endif()

20 changes: 0 additions & 20 deletions mingw-w64-boost/0009-Fix-undefined-reference-to-ws2_32.patch

This file was deleted.

This file was deleted.

17 changes: 0 additions & 17 deletions mingw-w64-boost/0012-allow-longer-path-on-mingw-w64.patch

This file was deleted.

Loading

0 comments on commit b2d3117

Please sign in to comment.