-
Notifications
You must be signed in to change notification settings - Fork 1.2k
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
1 parent
ad045b5
commit b2d3117
Showing
13 changed files
with
108 additions
and
612 deletions.
There are no files selected for viewing
41 changes: 41 additions & 0 deletions
41
mingw-w64-boost/0001-Fix-building-with-cmake-on-MINGW.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,41 @@ | ||
--- a/libs/cobalt/CMakeLists.txt | ||
+++ b/libs/cobalt/CMakeLists.txt | ||
@@ -60,6 +60,12 @@ | ||
Boost::throw_exception | ||
Boost::variant2 | ||
) | ||
+ if(MINGW) | ||
+ target_link_libraries(boost_cobalt | ||
+ PRIVATE | ||
+ ws2_32 | ||
+ ) | ||
+ endif() | ||
|
||
target_compile_definitions(boost_cobalt | ||
PUBLIC BOOST_COBALT_NO_LIB=1 | ||
--- a/libs/log/CMakeLists.txt | ||
+++ b/libs/log/CMakeLists.txt | ||
@@ -656,6 +656,12 @@ | ||
PRIVATE | ||
${boost_log_common_private_linkflags} | ||
) | ||
+ if(MINGW) | ||
+ target_link_libraries(boost_log_setup | ||
+ PRIVATE | ||
+ ws2_32 | ||
+ ) | ||
+ endif() | ||
else() | ||
add_library(boost_log_setup INTERFACE) | ||
target_include_directories(boost_log_setup INTERFACE include) | ||
--- a/libs/process/CMakeLists.txt | ||
+++ b/libs/process/CMakeLists.txt | ||
@@ -57,7 +57,7 @@ | ||
endif() | ||
|
||
if (WIN32) | ||
- target_link_libraries(boost_process PUBLIC ntdll shell32 advapi32 user32) | ||
+ target_link_libraries(boost_process PUBLIC ntdll shell32 advapi32 user32 ws2_32) | ||
endif() | ||
|
||
if(BUILD_SHARED_LIBS) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
--- a/tools/cmake/include/BoostInstall.cmake | ||
+++ b/tools/cmake/include/BoostInstall.cmake | ||
@@ -175,9 +175,6 @@ | ||
endif() | ||
|
||
endif() | ||
- | ||
- string(APPEND name_debug "-${arch}${bits}") | ||
- string(APPEND name_release "-${arch}${bits}") | ||
|
||
endif() | ||
|
20 changes: 0 additions & 20 deletions
20
mingw-w64-boost/0009-Fix-undefined-reference-to-ws2_32.patch
This file was deleted.
Oops, something went wrong.
33 changes: 0 additions & 33 deletions
33
mingw-w64-boost/0010-cmake-prefer-shared-libs-over-static-on-MINGW.patch
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
Oops, something went wrong.