Skip to content

Commit

Permalink
v2ray-core: fix build with Go 1.21
Browse files Browse the repository at this point in the history
Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
  • Loading branch information
1715173329 committed Sep 30, 2023
1 parent c95f313 commit e67820b
Show file tree
Hide file tree
Showing 6 changed files with 828 additions and 1 deletion.
2 changes: 1 addition & 1 deletion v2ray-core/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk

PKG_NAME:=v2ray-core
PKG_VERSION:=5.7.0
PKG_RELEASE:=1
PKG_RELEASE:=2

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/v2fly/v2ray-core/tar.gz/v$(PKG_VERSION)?
Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
From cd9f183fa836caba816ee73d486dda507a4e9c56 Mon Sep 17 00:00:00 2001
From: dyhkwong <50692134+dyhkwong@users.noreply.github.com>
Date: Wed, 28 Jun 2023 14:28:23 +0800
Subject: [PATCH] DNS over QUIC should not have "http/1.1" and "h2" ALPNs
(#2570)

---
app/dns/nameserver_quic.go | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)

--- a/app/dns/nameserver_quic.go
+++ b/app/dns/nameserver_quic.go
@@ -11,7 +11,6 @@ import (

"github.com/quic-go/quic-go"
"golang.org/x/net/dns/dnsmessage"
- "golang.org/x/net/http2"

"github.com/v2fly/v2ray-core/v5/common"
"github.com/v2fly/v2ray-core/v5/common/buf"
@@ -25,7 +24,7 @@ import (
)

// NextProtoDQ - During connection establishment, DNS/QUIC support is indicated
-// by selecting the ALPN token "dq" in the crypto handshake.
+// by selecting the ALPN token "doq" in the crypto handshake.
const NextProtoDQ = "doq"

const handshakeIdleTimeout = time.Second * 8
@@ -383,7 +382,7 @@ func (s *QUICNameServer) openConnection(
HandshakeIdleTimeout: handshakeIdleTimeout,
}

- conn, err := quic.DialAddrContext(ctx, s.destination.NetAddr(), tlsConfig.GetTLSConfig(tls.WithNextProto("http/1.1", http2.NextProtoTLS, NextProtoDQ)), quicConfig)
+ conn, err := quic.DialAddrContext(ctx, s.destination.NetAddr(), tlsConfig.GetTLSConfig(tls.WithNextProto(NextProtoDQ)), quicConfig)
if err != nil {
return nil, err
}
Loading

0 comments on commit e67820b

Please sign in to comment.