-
Notifications
You must be signed in to change notification settings - Fork 9
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
git-svn-id: svn://helios.math.rwth-aachen.de/home2/thuban/svnuser/orb/trunk/orb@223 84b55aed-c907-0410-b598-ae02b0970699
- Loading branch information
neunhoef
committed
Mar 18, 2009
1 parent
cdd69f7
commit eb77436
Showing
7 changed files
with
291 additions
and
61 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,80 @@ | ||
# | ||
# makefile for the orb package Max Neunhoeffer | ||
# | ||
## Copyright (C) 2009 Max Neunhoeffer | ||
## This file is free software, see license information at the end. | ||
# | ||
CC=cc | ||
|
||
COMPILEOPTIONS="-O3 -fomit-frame-pointer" | ||
#COMPILEOPTIONS="-O3 -g -fomit-frame-pointer" | ||
#COMPILEOPTIONS="-O0 -g -Wall" | ||
# Some experiments: | ||
#COMPILEOPTIONS="-march=i686 -mcpu=pentium4 -O3 -fomit-frame-pointer" | ||
#COMPILEOPTIONS="-march=i686 -mcpu=pentium4 -O3 -fomit-frame-pointer -falign-loops=5 -finline-limit=6000" | ||
|
||
GAPINCL=-I$(GAPPATH)/src -I$(GAPPATH)/bin/@GAPARCH@ | ||
|
||
.PHONY: bindir clean doc test | ||
|
||
default: bindir bin/@GAPARCH@/orb.so | ||
|
||
# this target creates a bin-directory | ||
bindir: | ||
if test ! -d bin; then mkdir bin; fi | ||
if test ! -d bin/@GAPARCH@; then mkdir bin/@GAPARCH@; fi | ||
|
||
bin/@GAPARCH@/orb.so: src/orb.c | ||
cp $(GAPPATH)/bin/@GAPARCH@/config.h bin/@GAPARCH@ | ||
$(GAPPATH)/bin/@GAPARCH@/gac -p ${COMPILEOPTIONS} -d -o bin/@GAPARCH@/orb.so src/orb.c | ||
|
||
# make a statically linked GAP including the orb module | ||
static: | ||
(cd $(GAPPATH)/bin/@GAPARCH@; \ | ||
./gac -o gap-static -p "-DORBSTATIC" -p ${COMPILEOPTIONS} -P "-static" \ | ||
../../pkg/orb/src/orb.c) | ||
|
||
doc: doc/manual.six | ||
|
||
doc/manual.six: doc/basic.xml doc/hash.xml doc/orb.xml doc/search.xml \ | ||
doc/bysuborbit.xml doc/install.xml doc/quotfinder.xml \ | ||
doc/examples.xml doc/intro.xml doc/random.xml VERSION | ||
($(GAPPATH)/bin/gap.sh makedoc.g) | ||
|
||
clean: | ||
(cd doc ; ./clean) | ||
rm -rf bin/@GAPARCH@ Makefile | ||
|
||
archive: doc | ||
(cd .. ; tar czvf orb-`cat orb/VERSION`.tar.gz --exclude ".svn" --exclude bin --exclude test orb) | ||
|
||
WEBPOS=/scratch/neunhoef/mywebpage.pub/Computer/Software/Gap/orb | ||
|
||
towww: archive | ||
echo '<?xml version="1.0" encoding="ISO-8859-1"?>' >${WEBPOS}.version | ||
echo '<mixer>' >>${WEBPOS}.version | ||
cat VERSION >>${WEBPOS}.version | ||
echo '</mixer>' >>${WEBPOS}.version | ||
cp PackageInfo.g ${WEBPOS} | ||
cp README ${WEBPOS}/README.orb | ||
cp doc/manual.pdf ${WEBPOS}/orb.pdf | ||
cp ../orb-`cat VERSION`.tar.gz ${WEBPOS} | ||
@echo | ||
@echo Now please adjust the archive link in | ||
@echo " " ${WEBPOS}.mixer ! | ||
|
||
## | ||
## This program is free software; you can redistribute it and/or modify | ||
## it under the terms of the GNU General Public License as published by | ||
## the Free Software Foundation; version 2 of the License. | ||
## | ||
## This program is distributed in the hope that it will be useful, | ||
## but WITHOUT ANY WARRANTY; without even the implied warranty of | ||
## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the | ||
## GNU General Public License for more details. | ||
## | ||
## You should have received a copy of the GNU General Public License | ||
## along with this program; if not, write to the Free Software | ||
## Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA | ||
## | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,16 @@ | ||
#!/bin/sh | ||
# configure script for the orb package, Max Neunhoeffer | ||
# usage: ./configure gappath | ||
# this script creates a `Makefile' from `Makefile.in' | ||
if [ x"$1" = "x" ]; then GAPPATH=../..; echo "Using ../.. as default GAP path"; | ||
else GAPPATH=$1; fi | ||
rm -f Makefile sedfile | ||
echo "#!/bin/sh" > Makefile | ||
cat $GAPPATH/sysinfo.gap >> Makefile | ||
echo "echo s/@GAPARCH@/\$GAParch/g >sedfile" >> Makefile | ||
chmod +x Makefile | ||
./Makefile | ||
rm -f Makefile | ||
echo GAPPATH=$GAPPATH >Makefile | ||
sed -f sedfile Makefile.in >>Makefile | ||
rm -f sedfile |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.