-
Notifications
You must be signed in to change notification settings - Fork 81
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
2 changed files
with
151 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,130 @@ | ||
diff -Naur vaporizer2/VASTvaporizer/Source/Engine/Filter/VASTQFilterCoefficients.cpp vaporizer2_/VASTvaporizer/Source/Engine/Filter/VASTQFilterCoefficients.cpp | ||
--- vaporizer2/VASTvaporizer/Source/Engine/Filter/VASTQFilterCoefficients.cpp 2025-01-20 22:39:15.000000000 +0800 | ||
+++ vaporizer2_/VASTvaporizer/Source/Engine/Filter/VASTQFilterCoefficients.cpp 2025-01-21 12:45:43.308594135 +0800 | ||
@@ -4,6 +4,9 @@ | ||
#include "../Utils/VASTSynthfunctions.h" //for pow | ||
#ifdef __aarch64__ //arm64 | ||
#include "../../sse2neon.h" | ||
+#elif defined(__riscv) | ||
+ #define SIMDE_ENABLE_NATIVE_ALIASES | ||
+ #include "simde/x86/sse2.h" | ||
#else | ||
#include "emmintrin.h" | ||
#endif | ||
diff -Naur vaporizer2/VASTvaporizer/Source/Engine/Filter/VASTQFilter.cpp vaporizer2_/VASTvaporizer/Source/Engine/Filter/VASTQFilter.cpp | ||
--- vaporizer2/VASTvaporizer/Source/Engine/Filter/VASTQFilter.cpp 2025-01-20 22:39:15.000000000 +0800 | ||
+++ vaporizer2_/VASTvaporizer/Source/Engine/Filter/VASTQFilter.cpp 2025-01-21 12:45:13.438593513 +0800 | ||
@@ -9,6 +9,9 @@ | ||
#include "../VASTVcf.h" | ||
#ifdef __aarch64__ //arm64 | ||
#include "../../sse2neon.h" | ||
+#elif defined(__riscv) | ||
+ #define SIMDE_ENABLE_NATIVE_ALIASES | ||
+ #include "simde/x86/sse2.h" | ||
#else | ||
#include "emmintrin.h" | ||
#endif | ||
diff -Naur vaporizer2/VASTvaporizer/Source/Engine/Filter/VASTQFilter.h vaporizer2_/VASTvaporizer/Source/Engine/Filter/VASTQFilter.h | ||
--- vaporizer2/VASTvaporizer/Source/Engine/Filter/VASTQFilter.h 2025-01-20 22:39:15.000000000 +0800 | ||
+++ vaporizer2_/VASTvaporizer/Source/Engine/Filter/VASTQFilter.h 2025-01-21 12:44:45.675259603 +0800 | ||
@@ -8,6 +8,9 @@ | ||
#include "VASTVCFCombFilter.h" | ||
#ifdef __aarch64__ //arm64 | ||
#include "../../sse2neon.h" | ||
+#elif defined(__riscv) | ||
+ #define SIMDE_ENABLE_NATIVE_ALIASES | ||
+ #include "simde/x86/sse2.h" | ||
#else | ||
#include "emmintrin.h" | ||
#endif | ||
diff -Naur vaporizer2/VASTvaporizer/Source/Engine/FX/VASTWaveshaper.cpp vaporizer2_/VASTvaporizer/Source/Engine/FX/VASTWaveshaper.cpp | ||
--- vaporizer2/VASTvaporizer/Source/Engine/FX/VASTWaveshaper.cpp 2025-01-20 22:39:15.000000000 +0800 | ||
+++ vaporizer2_/VASTvaporizer/Source/Engine/FX/VASTWaveshaper.cpp 2025-01-21 12:47:42.248596519 +0800 | ||
@@ -12,6 +12,9 @@ | ||
#include <math.h> | ||
#ifdef __aarch64__ //arm64 | ||
#include "../../sse2neon.h" | ||
+#elif defined(__riscv) | ||
+ #define SIMDE_ENABLE_NATIVE_ALIASES | ||
+ #include "simde/x86/sse2.h" | ||
#else | ||
#include "emmintrin.h" | ||
#endif | ||
diff -Naur vaporizer2/VASTvaporizer/Source/Engine/FX/VASTWaveshaper.h vaporizer2_/VASTvaporizer/Source/Engine/FX/VASTWaveshaper.h | ||
--- vaporizer2/VASTvaporizer/Source/Engine/FX/VASTWaveshaper.h 2025-01-20 22:39:15.000000000 +0800 | ||
+++ vaporizer2_/VASTvaporizer/Source/Engine/FX/VASTWaveshaper.h 2025-01-21 12:46:12.888594721 +0800 | ||
@@ -10,6 +10,9 @@ | ||
#include "VASTEffect.h" | ||
#ifdef __aarch64__ //arm64 | ||
#include "../../sse2neon.h" | ||
+#elif defined(__riscv) | ||
+ #define SIMDE_ENABLE_NATIVE_ALIASES | ||
+ #include "simde/x86/sse2.h" | ||
#else | ||
#include "emmintrin.h" | ||
#endif | ||
diff -Naur vaporizer2/VASTvaporizer/Source/Engine/Oversampler/VASTDecimator.cpp vaporizer2_/VASTvaporizer/Source/Engine/Oversampler/VASTDecimator.cpp | ||
--- vaporizer2/VASTvaporizer/Source/Engine/Oversampler/VASTDecimator.cpp 2025-01-20 22:39:15.000000000 +0800 | ||
+++ vaporizer2_/VASTvaporizer/Source/Engine/Oversampler/VASTDecimator.cpp 2025-01-21 12:42:50.458590691 +0800 | ||
@@ -7,6 +7,9 @@ | ||
|
||
#ifdef __aarch64__ //arm64 | ||
#include "../../sse2neon.h" | ||
+#elif defined(__riscv) | ||
+ #define SIMDE_ENABLE_NATIVE_ALIASES | ||
+ #include "simde/x86/sse2.h" | ||
#else | ||
#if defined _MACOSX || defined JUCE_LINUX | ||
#include <pmmintrin.h> | ||
diff -Naur vaporizer2/VASTvaporizer/Source/Engine/Oversampler/VASTDecimator.h vaporizer2_/VASTvaporizer/Source/Engine/Oversampler/VASTDecimator.h | ||
--- vaporizer2/VASTvaporizer/Source/Engine/Oversampler/VASTDecimator.h 2025-01-20 22:39:15.000000000 +0800 | ||
+++ vaporizer2_/VASTvaporizer/Source/Engine/Oversampler/VASTDecimator.h 2025-01-21 12:47:10.658595869 +0800 | ||
@@ -7,6 +7,9 @@ | ||
#include "VASTRateConvertor.h" | ||
#ifdef __aarch64__ //arm64 | ||
#include "../../sse2neon.h" | ||
+#elif defined(__riscv) | ||
+ #define SIMDE_ENABLE_NATIVE_ALIASES | ||
+ #include "simde/x86/sse2.h" | ||
#else | ||
#include "emmintrin.h" | ||
#endif | ||
diff -Naur vaporizer2/VASTvaporizer/Source/Engine/Utils/VASTSSEHelper.h vaporizer2_/VASTvaporizer/Source/Engine/Utils/VASTSSEHelper.h | ||
--- vaporizer2/VASTvaporizer/Source/Engine/Utils/VASTSSEHelper.h 2025-01-20 22:39:15.000000000 +0800 | ||
+++ vaporizer2_/VASTvaporizer/Source/Engine/Utils/VASTSSEHelper.h 2025-01-21 12:42:20.418590090 +0800 | ||
@@ -5,6 +5,9 @@ | ||
#include "../VASTEngineHeader.h" | ||
#ifdef __aarch64__ //arm64 | ||
#include "../../sse2neon.h" | ||
+#elif defined(__riscv) | ||
+ #define SIMDE_ENABLE_NATIVE_ALIASES | ||
+ #include "simde/x86/sse3.h" | ||
#else | ||
#include "immintrin.h" | ||
#endif | ||
diff -Naur vaporizer2/VASTvaporizer/Source/Engine/Utils/VASTSynthfunctions.h vaporizer2_/VASTvaporizer/Source/Engine/Utils/VASTSynthfunctions.h | ||
--- vaporizer2/VASTvaporizer/Source/Engine/Utils/VASTSynthfunctions.h 2025-01-20 22:39:15.000000000 +0800 | ||
+++ vaporizer2_/VASTvaporizer/Source/Engine/Utils/VASTSynthfunctions.h 2025-01-21 12:41:49.595256138 +0800 | ||
@@ -14,6 +14,9 @@ | ||
#include <stdio.h> | ||
#ifdef __aarch64__ //arm64 | ||
#include "../../sse2neon.h" | ||
+#elif defined(__riscv) | ||
+ #define SIMDE_ENABLE_NATIVE_ALIASES | ||
+ #include "simde/x86/sse2.h" | ||
#else | ||
#include "immintrin.h" | ||
#endif | ||
diff -Naur vaporizer2/VASTvaporizer/Source/Engine/VASTVcf.h vaporizer2_/VASTvaporizer/Source/Engine/VASTVcf.h | ||
--- vaporizer2/VASTvaporizer/Source/Engine/VASTVcf.h 2025-01-20 22:39:15.000000000 +0800 | ||
+++ vaporizer2_/VASTvaporizer/Source/Engine/VASTVcf.h 2025-01-21 12:46:44.558595373 +0800 | ||
@@ -18,6 +18,9 @@ | ||
/**************************/ | ||
#ifdef __aarch64__ //arm64 | ||
#include "../sse2neon.h" | ||
+#elif defined(__riscv) | ||
+ #define SIMDE_ENABLE_NATIVE_ALIASES | ||
+ #include "simde/x86/sse2.h" | ||
#else | ||
#include "emmintrin.h" | ||
#endif |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,21 @@ | ||
--- PKGBUILD | ||
+++ PKGBUILD | ||
@@ -74,6 +74,9 @@ prepare() { | ||
git config submodule.clap-libs/clap-helpers.url "$srcdir/github.com-free-audio-clap-helpers" | ||
git -c protocol.file.allow=always submodule update --init | ||
popd | ||
+ | ||
+ patch -p1 < $srcdir/add-riscv-simd-support.patch | ||
+ | ||
} | ||
|
||
build() { | ||
@@ -150,3 +153,8 @@ package_vaporizer2-standalone() { | ||
|
||
install -vDm755 -t "$pkgdir/usr/bin" build/VASTvaporizer2_artefacts/Release/Standalone/VASTvaporizer2 | ||
} | ||
+ | ||
+makedepends+=('simde') | ||
+source+=('add-riscv-simd-support.patch') | ||
+sha512sums+=("c7bd9d886f94725a80faf914db0c632abb66aedf1f7ce0e9d70517ffc98bd88cae8cc29e8903ee1ddf948176d079f96b89082c7993f4e9fc4d30436dcfa22efb") | ||
+b2sums+=("e002391122e3f62cbfea521d012102259db1f97278bdf45bf15fb83299f99941ad24b2fab2f72f8012b958efc49f0e3bdc89426222265863a39eebc28a979d7a") |