Skip to content

Commit

Permalink
Merge pull request #5 from eigendude/zeus-fixes
Browse files Browse the repository at this point in the history
Fixes for Yocto 3.0 Zeus
  • Loading branch information
eigendude authored Dec 7, 2019
2 parents aad5b3d + 77fb1d6 commit 08ddc67
Show file tree
Hide file tree
Showing 7 changed files with 41 additions and 4 deletions.
2 changes: 2 additions & 0 deletions meta-oe/recipes-devtools/protobuf/protobuf_3.9.2.bb
Original file line number Diff line number Diff line change
Expand Up @@ -84,6 +84,8 @@ MIPS_INSTRUCTION_SET = "mips"

BBCLASSEXTEND = "native nativesdk"

CXXFLAGS_append_class-target = " -fPIC"

LDFLAGS_append_arm = " -latomic"
LDFLAGS_append_mips = " -latomic"
LDFLAGS_append_powerpc = " -latomic"
Expand Down
2 changes: 1 addition & 1 deletion meta-oe/recipes-devtools/yasm/yasm_git.bb
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,7 @@ SRC_URI = "git://github.com/yasm/yasm.git"

S = "${WORKDIR}/git"

inherit autotools gettext pythonnative
inherit autotools gettext python3native

CACHED_CONFIGUREVARS = "CCLD_FOR_BUILD='${CC_FOR_BUILD}'"

Expand Down
4 changes: 2 additions & 2 deletions meta-oe/recipes-extended/libimobiledevice/libplist_2.0.0.bb
Original file line number Diff line number Diff line change
Expand Up @@ -4,9 +4,9 @@ LICENSE = "GPLv2 & LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=ebb5c50ab7cab4baeffba14977030c07 \
file://COPYING.LESSER;md5=6ab17b41640564434dda85c06b7124f7"

DEPENDS = "libxml2 glib-2.0 swig python"
DEPENDS = "libxml2 glib-2.0 swig python3"

inherit autotools pkgconfig pythonnative
inherit autotools pkgconfig python3native

SRCREV = "62ec804736435fa34e37e66e228e17e2aacee1d7"
SRC_URI = "git://github.com/libimobiledevice/libplist;protocol=https \
Expand Down
4 changes: 4 additions & 0 deletions meta-python/recipes-devtools/python/python-protobuf.inc
Original file line number Diff line number Diff line change
Expand Up @@ -7,6 +7,10 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=19e8f490f9526b1de8

inherit pypi

SRC_URI += " \
file://0001-setup.cfg-Change-location-of-statically-linked-libra.patch \
"

SRC_URI[md5sum] = "d634666c898148e4565ac62f3ba4a2ca"
SRC_URI[sha256sum] = "843f498e98ad1469ad54ecb4a7ccf48605a1c5d2bd26ae799c7a2cddab4a37ec"

Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
From d99244cf587c360f2ec2a5e8da90a0fa5ce510ad Mon Sep 17 00:00:00 2001
From: Garrett Brown <garrett.brown@aclima.io>
Date: Tue, 26 Nov 2019 18:18:43 -0800
Subject: [PATCH] setup.cfg: Change location of statically-linked libraries

TODO: Pass library directory from BitBake.
---
setup.py | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/setup.py b/setup.py
index 9aabbf7..9152264 100755
--- a/setup.py
+++ b/setup.py
@@ -174,8 +174,8 @@ if __name__ == '__main__':
extra_objects = None
if compile_static_ext:
libraries = None
- extra_objects = ['../src/.libs/libprotobuf.a',
- '../src/.libs/libprotobuf-lite.a']
+ extra_objects = ['../recipe-sysroot/usr/lib/libprotobuf.a',
+ '../recipe-sysroot/usr/lib/libprotobuf-lite.a']
test_conformance.target = 'test_python_cpp'

extra_compile_args = []
--
2.20.1

Original file line number Diff line number Diff line change
Expand Up @@ -8,3 +8,4 @@ inherit pypi setuptools3
SRC_URI[md5sum] = "f927529cd1735f6f50ee2c61628e9c1f"
SRC_URI[sha256sum] = "05eed71e2e327246ad6b38c540c4a3117230b19679b875190486ddd2d721422d"

BBCLASSEXTEND += "native"
Original file line number Diff line number Diff line change
@@ -1,8 +1,10 @@
inherit setuptools3
require python-protobuf.inc

FILESEXTRAPATHS_prepend := "${THISDIR}/python-protobuf:"

DEPENDS += "protobuf"
DISTUTILS_BUILD_ARGS += "--cpp_implementation"
DISTUTILS_BUILD_ARGS += "--cpp_implementation --compile_static_extension"
DISTUTILS_INSTALL_ARGS += "--cpp_implementation"

do_compile_prepend_class-native () {
Expand Down

0 comments on commit 08ddc67

Please sign in to comment.