forked from openembedded/openembedded-core
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
apr: Cache configure tests which use AC_TRY_RUN
AC_TRY_RUN macro means the test needs to run to find the result and we are cross compiling so this will always get wrong results, this results in miscompiling apache2 on musl because it disables rlimit (ac_cv_struct_rlimit) wrongly. All these variables are determined with AC_TRY_RUN checks Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com>
- Loading branch information
Showing
2 changed files
with
75 additions
and
2 deletions.
There are no files selected for viewing
62 changes: 62 additions & 0 deletions
62
meta/recipes-support/apr/apr/0001-configure-Remove-runtime-test-for-mmap-that-can-map-.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,62 @@ | ||
From ee728971fd9d2da39356f1574d58d5daa3b24520 Mon Sep 17 00:00:00 2001 | ||
From: Khem Raj <raj.khem@gmail.com> | ||
Date: Fri, 26 Aug 2022 00:28:08 -0700 | ||
Subject: [PATCH] configure: Remove runtime test for mmap that can map | ||
/dev/zero | ||
|
||
This never works for cross-compile moreover it ends up disabling | ||
ac_cv_file__dev_zero which then results in compiler errors in shared | ||
mutexes | ||
|
||
Upstream-Status: Inappropriate [Cross-compile specific] | ||
Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
--- | ||
configure.in | 32 -------------------------------- | ||
1 file changed, 32 deletions(-) | ||
|
||
diff --git a/configure.in b/configure.in | ||
index a99049d..f1f55c7 100644 | ||
--- a/configure.in | ||
+++ b/configure.in | ||
@@ -1182,38 +1182,6 @@ AC_CHECK_FUNCS([mmap munmap shm_open shm_unlink shmget shmat shmdt shmctl \ | ||
APR_CHECK_DEFINE(MAP_ANON, sys/mman.h) | ||
AC_CHECK_FILE(/dev/zero) | ||
|
||
-# Not all systems can mmap /dev/zero (such as HP-UX). Check for that. | ||
-if test "$ac_cv_func_mmap" = "yes" && | ||
- test "$ac_cv_file__dev_zero" = "yes"; then | ||
- AC_MSG_CHECKING(for mmap that can map /dev/zero) | ||
- AC_TRY_RUN([ | ||
-#include <sys/types.h> | ||
-#include <sys/stat.h> | ||
-#include <fcntl.h> | ||
-#ifdef HAVE_SYS_MMAN_H | ||
-#include <sys/mman.h> | ||
-#endif | ||
- int main() | ||
- { | ||
- int fd; | ||
- void *m; | ||
- fd = open("/dev/zero", O_RDWR); | ||
- if (fd < 0) { | ||
- return 1; | ||
- } | ||
- m = mmap(0, sizeof(void*), PROT_READ|PROT_WRITE, MAP_SHARED, fd, 0); | ||
- if (m == (void *)-1) { /* aka MAP_FAILED */ | ||
- return 2; | ||
- } | ||
- if (munmap(m, sizeof(void*)) < 0) { | ||
- return 3; | ||
- } | ||
- return 0; | ||
- }], [], [ac_cv_file__dev_zero=no], [ac_cv_file__dev_zero=no]) | ||
- | ||
- AC_MSG_RESULT($ac_cv_file__dev_zero) | ||
-fi | ||
- | ||
# Now we determine which one is our anonymous shmem preference. | ||
haveshmgetanon="0" | ||
havemmapzero="0" | ||
-- | ||
2.37.2 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters