Skip to content
This repository has been archived by the owner on Oct 27, 2022. It is now read-only.

Commit

Permalink
setuptools: Autospec creation for update from version 60.1.1 to versi…
Browse files Browse the repository at this point in the history
…on 60.2.0

Anderson Bravalheri (1):
      Remove workaround for test/CI dependency on Sphinx

Christoph Reiter (6):
      sysconfig: use get_config_h_filename() from the stdlib
      sysconfig: use parse_config_h() from stdlib sysconfig
      tests: use loadTestsFromTestCase() instead of the deprecated makeSuite()
      tests: fix tests on Ubuntu 22.04
      tests: use sys.executable instead of hardcoding "python"
      sysconfig: use get_makefile_filename() from stdlib sysconfig

Jason R. Coombs (17):
      👹 Feed the hobgoblins (delint).
      Use line-based matrix values for nicer diffs. Remove Python 3.6 and bump to Python 3.10, matching jaraco/skeleton and pypa/setuptools approaches.
      Leave sphinx unpinned as found upstream.
      Add setuptools.log to supersede distutils.log. Ref #2973.
      Monkey patch distutils.log.set_threshold so the Python logger honors calls to it.
      Restore assertion about expected distutils.
      Check early for the presence of local distutils and bail out if the found version of Setuptools doesn't have distutils.
      Update changelog.
      Restore 'add_shim' as the way to invoke the hook. Avoids compatibility issues between different versions of Setuptools with the distutils local implementation. Renamed the former 'add_shim' as 'insert_shim'. Fixes #2983
      Restore 'get_versions' attribute, allowing older mpi4py to monkeypatch it. Fixes pypa/setuptools#2969.
      Disable setuptools installation. Fixes pypa/distutils#99.
      Also use PEP 517 to build things like pytest-virtualenv.
      39 is actually required to get the right packages.
      Unset VIRTUALENV_NO_SETUPTOOLS for ci_setuptools because pytest-virtualenv can't install without it. Ref man-group/pytest-plugins#190
      It really must be literally 39.
      Add changelog.
      Bump version: 60.1.1 → 60.2.0

Matt Davis (1):
      distutils shim should ignore setuptools on another path
  • Loading branch information
fenrus75 authored and clrpackages committed Jan 2, 2022
1 parent 0f97fdb commit 053df24
Show file tree
Hide file tree
Showing 6 changed files with 13 additions and 13 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := setuptools
URL = https://files.pythonhosted.org/packages/15/8f/cf533796488c53b4824be97b79b86ac161bcc011af9613bec6027f52e78d/setuptools-60.1.1.tar.gz
URL = https://files.pythonhosted.org/packages/9b/be/13f54335c7dba713b0e97e11e7a41db3df4a85073d6c5a6e7f6468b22ee2/setuptools-60.2.0.tar.gz
ARCHIVES =

include ../common/Makefile.common
2 changes: 1 addition & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = setuptools
url = https://files.pythonhosted.org/packages/15/8f/cf533796488c53b4824be97b79b86ac161bcc011af9613bec6027f52e78d/setuptools-60.1.1.tar.gz
url = https://files.pythonhosted.org/packages/9b/be/13f54335c7dba713b0e97e11e7a41db3df4a85073d6c5a6e7f6468b22ee2/setuptools-60.2.0.tar.gz
archives =
giturl = https://github.com/pypa/setuptools.git
domain =
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
244
245
16 changes: 8 additions & 8 deletions setuptools.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,10 +3,10 @@
# Generated by: autospec.py
#
Name : setuptools
Version : 60.1.1
Release : 244
URL : https://files.pythonhosted.org/packages/15/8f/cf533796488c53b4824be97b79b86ac161bcc011af9613bec6027f52e78d/setuptools-60.1.1.tar.gz
Source0 : https://files.pythonhosted.org/packages/15/8f/cf533796488c53b4824be97b79b86ac161bcc011af9613bec6027f52e78d/setuptools-60.1.1.tar.gz
Version : 60.2.0
Release : 245
URL : https://files.pythonhosted.org/packages/9b/be/13f54335c7dba713b0e97e11e7a41db3df4a85073d6c5a6e7f6468b22ee2/setuptools-60.2.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/9b/be/13f54335c7dba713b0e97e11e7a41db3df4a85073d6c5a6e7f6468b22ee2/setuptools-60.2.0.tar.gz
Summary : Easily download, build, install, upgrade, and uninstall Python packages
Group : Development/Tools
License : MIT Python-2.0 ZPL-2.0
Expand Down Expand Up @@ -59,16 +59,16 @@ python3 components for the setuptools package.


%prep
%setup -q -n setuptools-60.1.1
cd %{_builddir}/setuptools-60.1.1
%setup -q -n setuptools-60.2.0
cd %{_builddir}/setuptools-60.2.0
%patch1 -p1

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1640806273
export SOURCE_DATE_EPOCH=1640901574
export GCC_IGNORE_WERROR=1
export AR=gcc-ar
export RANLIB=gcc-ranlib
Expand All @@ -84,7 +84,7 @@ python3 setup.py build
export MAKEFLAGS=%{?_smp_mflags}
rm -rf %{buildroot}
mkdir -p %{buildroot}/usr/share/package-licenses/setuptools
cp %{_builddir}/setuptools-60.1.1/LICENSE %{buildroot}/usr/share/package-licenses/setuptools/8e6689d37f82d5617b7f7f7232c94024d41066d1
cp %{_builddir}/setuptools-60.2.0/LICENSE %{buildroot}/usr/share/package-licenses/setuptools/8e6689d37f82d5617b7f7f7232c94024d41066d1
python3 -tt setup.py build install --root=%{buildroot}
echo ----[ mark ]----
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
Expand Down
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
7cdc6704c256925c8d17548422c22eda76badf85/setuptools-60.1.1.tar.gz
3f9f2c673ce97c6f479acf65cf7cbb1ab9055895/setuptools-60.2.0.tar.gz
2 changes: 1 addition & 1 deletion versions
Original file line number Diff line number Diff line change
@@ -1 +1 @@
60.1.1
60.2.0

0 comments on commit 053df24

Please sign in to comment.