Skip to content

Commit

Permalink
repo: add mgr-dashboard-node-version.patch
Browse files Browse the repository at this point in the history
up the bundled node version to 16, so as to fix node-gyp errors
originating from a too-old npm version in 14.

Basically, python 3.11 removed a deprecated file open option from
python, which consequently blows up `npm ci`, preventing the build.

Issue: #12
References: npm/cli#5113
References: npm/cli#4664
References: npm/cli#4660
  • Loading branch information
bazaah committed May 8, 2023
1 parent abe5a35 commit d931804
Showing 1 changed file with 13 additions and 0 deletions.
13 changes: 13 additions & 0 deletions ceph-17.2.6-mgr-dashboard-node-version.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
diff --git a/src/pybind/mgr/dashboard/frontend/CMakeLists.txt b/src/pybind/mgr/dashboard/frontend/CMakeLists.txt
index 4fd2130b93a..7df5de57c66 100644
--- a/src/pybind/mgr/dashboard/frontend/CMakeLists.txt
+++ b/src/pybind/mgr/dashboard/frontend/CMakeLists.txt
@@ -63,7 +63,7 @@ else(WITH_SYSTEM_NPM)
OUTPUT "${mgr-dashboard-nodeenv-dir}/bin/npm"
COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${MGR_PYTHON_EXECUTABLE} ${mgr-dashboard-nodeenv-dir}
COMMAND ${mgr-dashboard-nodeenv-dir}/bin/pip install nodeenv
- COMMAND ${mgr-dashboard-nodeenv-dir}/bin/nodeenv --verbose ${node_mirror_opt} -p --node=14.15.1
+ COMMAND ${mgr-dashboard-nodeenv-dir}/bin/nodeenv --verbose ${node_mirror_opt} -p --node=16.15.0
COMMAND mkdir ${mgr-dashboard-nodeenv-dir}/.npm
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
COMMENT "dashboard nodeenv is being installed")

0 comments on commit d931804

Please sign in to comment.