forked from lllyasviel/ControlNet-v1-1-nightly
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
0 parents
commit db0f480
Showing
375 changed files
with
48,175 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,140 @@ | ||
.idea/ | ||
|
||
training/ | ||
lightning_logs/ | ||
image_log/ | ||
|
||
*.pth | ||
*.pt | ||
*.ckpt | ||
*.safetensors | ||
|
||
# Byte-compiled / optimized / DLL files | ||
__pycache__/ | ||
*.py[cod] | ||
*$py.class | ||
|
||
# C extensions | ||
*.so | ||
|
||
# Distribution / packaging | ||
.Python | ||
build/ | ||
develop-eggs/ | ||
dist/ | ||
downloads/ | ||
eggs/ | ||
.eggs/ | ||
lib/ | ||
lib64/ | ||
parts/ | ||
sdist/ | ||
var/ | ||
wheels/ | ||
pip-wheel-metadata/ | ||
share/python-wheels/ | ||
*.egg-info/ | ||
.installed.cfg | ||
*.egg | ||
MANIFEST | ||
|
||
# PyInstaller | ||
# Usually these files are written by a python script from a template | ||
# before PyInstaller builds the exe, so as to inject date/other infos into it. | ||
*.manifest | ||
*.spec | ||
|
||
# Installer logs | ||
pip-log.txt | ||
pip-delete-this-directory.txt | ||
|
||
# Unit test / coverage reports | ||
htmlcov/ | ||
.tox/ | ||
.nox/ | ||
.coverage | ||
.coverage.* | ||
.cache | ||
nosetests.xml | ||
coverage.xml | ||
*.cover | ||
*.py,cover | ||
.hypothesis/ | ||
.pytest_cache/ | ||
|
||
# Translations | ||
*.mo | ||
*.pot | ||
|
||
# Django stuff: | ||
*.log | ||
local_settings.py | ||
db.sqlite3 | ||
db.sqlite3-journal | ||
|
||
# Flask stuff: | ||
instance/ | ||
.webassets-cache | ||
|
||
# Scrapy stuff: | ||
.scrapy | ||
|
||
# Sphinx documentation | ||
docs/_build/ | ||
|
||
# PyBuilder | ||
target/ | ||
|
||
# Jupyter Notebook | ||
.ipynb_checkpoints | ||
|
||
# IPython | ||
profile_default/ | ||
ipython_config.py | ||
|
||
# pyenv | ||
.python-version | ||
|
||
# pipenv | ||
# According to pypa/pipenv#598, it is recommended to include Pipfile.lock in version control. | ||
# However, in case of collaboration, if having platform-specific dependencies or dependencies | ||
# having no cross-platform support, pipenv may install dependencies that don't work, or not | ||
# install all needed dependencies. | ||
#Pipfile.lock | ||
|
||
# PEP 582; used by e.g. github.com/David-OConnor/pyflow | ||
__pypackages__/ | ||
|
||
# Celery stuff | ||
celerybeat-schedule | ||
celerybeat.pid | ||
|
||
# SageMath parsed files | ||
*.sage.py | ||
|
||
# Environments | ||
.env | ||
.venv | ||
env/ | ||
venv/ | ||
ENV/ | ||
env.bak/ | ||
venv.bak/ | ||
|
||
# Spyder project settings | ||
.spyderproject | ||
.spyproject | ||
|
||
# Rope project settings | ||
.ropeproject | ||
|
||
# mkdocs documentation | ||
/site | ||
|
||
# mypy | ||
.mypy_cache/ | ||
.dmypy.json | ||
dmypy.json | ||
|
||
# Pyre type checker | ||
.pyre/ |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,6 @@ | ||
import cv2 | ||
|
||
|
||
class CannyDetector: | ||
def __call__(self, img, low_threshold, high_threshold): | ||
return cv2.Canny(img, low_threshold, high_threshold) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
Weights here. |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,114 @@ | ||
import numpy as np | ||
import cv2 | ||
import os | ||
import torch | ||
from einops import rearrange | ||
from annotator.util import annotator_ckpts_path | ||
|
||
|
||
class Network(torch.nn.Module): | ||
def __init__(self, model_path): | ||
super().__init__() | ||
|
||
self.netVggOne = torch.nn.Sequential( | ||
torch.nn.Conv2d(in_channels=3, out_channels=64, kernel_size=3, stride=1, padding=1), | ||
torch.nn.ReLU(inplace=False), | ||
torch.nn.Conv2d(in_channels=64, out_channels=64, kernel_size=3, stride=1, padding=1), | ||
torch.nn.ReLU(inplace=False) | ||
) | ||
|
||
self.netVggTwo = torch.nn.Sequential( | ||
torch.nn.MaxPool2d(kernel_size=2, stride=2), | ||
torch.nn.Conv2d(in_channels=64, out_channels=128, kernel_size=3, stride=1, padding=1), | ||
torch.nn.ReLU(inplace=False), | ||
torch.nn.Conv2d(in_channels=128, out_channels=128, kernel_size=3, stride=1, padding=1), | ||
torch.nn.ReLU(inplace=False) | ||
) | ||
|
||
self.netVggThr = torch.nn.Sequential( | ||
torch.nn.MaxPool2d(kernel_size=2, stride=2), | ||
torch.nn.Conv2d(in_channels=128, out_channels=256, kernel_size=3, stride=1, padding=1), | ||
torch.nn.ReLU(inplace=False), | ||
torch.nn.Conv2d(in_channels=256, out_channels=256, kernel_size=3, stride=1, padding=1), | ||
torch.nn.ReLU(inplace=False), | ||
torch.nn.Conv2d(in_channels=256, out_channels=256, kernel_size=3, stride=1, padding=1), | ||
torch.nn.ReLU(inplace=False) | ||
) | ||
|
||
self.netVggFou = torch.nn.Sequential( | ||
torch.nn.MaxPool2d(kernel_size=2, stride=2), | ||
torch.nn.Conv2d(in_channels=256, out_channels=512, kernel_size=3, stride=1, padding=1), | ||
torch.nn.ReLU(inplace=False), | ||
torch.nn.Conv2d(in_channels=512, out_channels=512, kernel_size=3, stride=1, padding=1), | ||
torch.nn.ReLU(inplace=False), | ||
torch.nn.Conv2d(in_channels=512, out_channels=512, kernel_size=3, stride=1, padding=1), | ||
torch.nn.ReLU(inplace=False) | ||
) | ||
|
||
self.netVggFiv = torch.nn.Sequential( | ||
torch.nn.MaxPool2d(kernel_size=2, stride=2), | ||
torch.nn.Conv2d(in_channels=512, out_channels=512, kernel_size=3, stride=1, padding=1), | ||
torch.nn.ReLU(inplace=False), | ||
torch.nn.Conv2d(in_channels=512, out_channels=512, kernel_size=3, stride=1, padding=1), | ||
torch.nn.ReLU(inplace=False), | ||
torch.nn.Conv2d(in_channels=512, out_channels=512, kernel_size=3, stride=1, padding=1), | ||
torch.nn.ReLU(inplace=False) | ||
) | ||
|
||
self.netScoreOne = torch.nn.Conv2d(in_channels=64, out_channels=1, kernel_size=1, stride=1, padding=0) | ||
self.netScoreTwo = torch.nn.Conv2d(in_channels=128, out_channels=1, kernel_size=1, stride=1, padding=0) | ||
self.netScoreThr = torch.nn.Conv2d(in_channels=256, out_channels=1, kernel_size=1, stride=1, padding=0) | ||
self.netScoreFou = torch.nn.Conv2d(in_channels=512, out_channels=1, kernel_size=1, stride=1, padding=0) | ||
self.netScoreFiv = torch.nn.Conv2d(in_channels=512, out_channels=1, kernel_size=1, stride=1, padding=0) | ||
|
||
self.netCombine = torch.nn.Sequential( | ||
torch.nn.Conv2d(in_channels=5, out_channels=1, kernel_size=1, stride=1, padding=0), | ||
torch.nn.Sigmoid() | ||
) | ||
|
||
self.load_state_dict({strKey.replace('module', 'net'): tenWeight for strKey, tenWeight in torch.load(model_path).items()}) | ||
|
||
def forward(self, tenInput): | ||
tenInput = tenInput * 255.0 | ||
tenInput = tenInput - torch.tensor(data=[104.00698793, 116.66876762, 122.67891434], dtype=tenInput.dtype, device=tenInput.device).view(1, 3, 1, 1) | ||
|
||
tenVggOne = self.netVggOne(tenInput) | ||
tenVggTwo = self.netVggTwo(tenVggOne) | ||
tenVggThr = self.netVggThr(tenVggTwo) | ||
tenVggFou = self.netVggFou(tenVggThr) | ||
tenVggFiv = self.netVggFiv(tenVggFou) | ||
|
||
tenScoreOne = self.netScoreOne(tenVggOne) | ||
tenScoreTwo = self.netScoreTwo(tenVggTwo) | ||
tenScoreThr = self.netScoreThr(tenVggThr) | ||
tenScoreFou = self.netScoreFou(tenVggFou) | ||
tenScoreFiv = self.netScoreFiv(tenVggFiv) | ||
|
||
tenScoreOne = torch.nn.functional.interpolate(input=tenScoreOne, size=(tenInput.shape[2], tenInput.shape[3]), mode='bilinear', align_corners=False) | ||
tenScoreTwo = torch.nn.functional.interpolate(input=tenScoreTwo, size=(tenInput.shape[2], tenInput.shape[3]), mode='bilinear', align_corners=False) | ||
tenScoreThr = torch.nn.functional.interpolate(input=tenScoreThr, size=(tenInput.shape[2], tenInput.shape[3]), mode='bilinear', align_corners=False) | ||
tenScoreFou = torch.nn.functional.interpolate(input=tenScoreFou, size=(tenInput.shape[2], tenInput.shape[3]), mode='bilinear', align_corners=False) | ||
tenScoreFiv = torch.nn.functional.interpolate(input=tenScoreFiv, size=(tenInput.shape[2], tenInput.shape[3]), mode='bilinear', align_corners=False) | ||
|
||
return self.netCombine(torch.cat([ tenScoreOne, tenScoreTwo, tenScoreThr, tenScoreFou, tenScoreFiv ], 1)) | ||
|
||
|
||
class HEDdetector: | ||
def __init__(self): | ||
remote_model_path = "https://huggingface.co/lllyasviel/Annotators/resolve/main/network-bsds500.pth" | ||
modelpath = os.path.join(annotator_ckpts_path, "network-bsds500.pth") | ||
if not os.path.exists(modelpath): | ||
from basicsr.utils.download_util import load_file_from_url | ||
load_file_from_url(remote_model_path, model_dir=annotator_ckpts_path) | ||
self.netNetwork = Network(modelpath).cuda().eval() | ||
|
||
def __call__(self, input_image): | ||
assert input_image.ndim == 3 | ||
input_image = input_image[:, :, ::-1].copy() | ||
with torch.no_grad(): | ||
image_hed = torch.from_numpy(input_image).float().cuda() | ||
image_hed = image_hed / 255.0 | ||
image_hed = rearrange(image_hed, 'h w c -> 1 c h w') | ||
edge = self.netNetwork(image_hed)[0] | ||
edge = (edge.cpu().numpy() * 255.0).clip(0, 255).astype(np.uint8) | ||
return edge[0] |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,27 @@ | ||
import cv2 | ||
import numpy as np | ||
import torch | ||
|
||
from einops import rearrange | ||
from .api import MiDaSInference | ||
|
||
|
||
class MidasDetector: | ||
def __init__(self): | ||
self.model = MiDaSInference(model_type="dpt_hybrid").cuda() | ||
|
||
def __call__(self, input_image): | ||
assert input_image.ndim == 3 | ||
image_depth = input_image | ||
with torch.no_grad(): | ||
image_depth = torch.from_numpy(image_depth).float().cuda() | ||
image_depth = image_depth / 127.5 - 1.0 | ||
image_depth = rearrange(image_depth, 'h w c -> 1 c h w') | ||
depth = self.model(image_depth)[0] | ||
|
||
depth -= torch.min(depth) | ||
depth /= torch.max(depth) | ||
depth = depth.cpu().numpy() | ||
depth_image = (depth * 255.0).clip(0, 255).astype(np.uint8) | ||
|
||
return depth_image |
Oops, something went wrong.