Skip to content

Commit

Permalink
databases/mysql80-*: update to 8.0.25 GA release
Browse files Browse the repository at this point in the history
Release notes:	https://dev.mysql.com/doc/relnotes/mysql/8.0/en/news-8-0-25.html
		https://dev.mysql.com/doc/relnotes/mysql/8.0/en/news-8-0-24.html

PR:		255937
Submitted by:	delphij@
Approved by	joneum@ (implicit)
MFH:		2021Q2
  • Loading branch information
fluffykhv committed May 20, 2021
1 parent 18b2e48 commit c7fbbf1
Show file tree
Hide file tree
Showing 10 changed files with 53 additions and 67 deletions.
1 change: 0 additions & 1 deletion databases/mysql80-client/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# Created by: "Mahdi Mokhtari <mokhi64@gmail.com>"

PORTNAME= mysql
PORTREVISION= 1
PKGNAMESUFFIX= 80-client

COMMENT= Multithreaded SQL database (client)
Expand Down
1 change: 1 addition & 0 deletions databases/mysql80-client/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -3,6 +3,7 @@ bin/my_print_defaults
bin/mysql
bin/mysql_config
bin/mysql_config_editor
bin/mysql_migrate_keyring
bin/mysqladmin
bin/mysqlbinlog
bin/mysqlcheck
Expand Down
13 changes: 3 additions & 10 deletions databases/mysql80-server/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
# Created by: Mahdi Mokhtari <mokhi64@gmail.com>

PORTNAME?= mysql
PORTVERSION= 8.0.23
PORTREVISION?= 1
PORTVERSION= 8.0.25
PORTREVISION?= 0
CATEGORIES= databases
MASTER_SITES= MYSQL/MySQL-8.0
PKGNAMESUFFIX?= 80-server
Expand Down Expand Up @@ -48,7 +48,7 @@ BUILD_DEPENDS_powerpc64= libunwind>0:devel/libunwind
BUILD_DEPENDS_powerpc64le= libunwind>0:devel/libunwind

CMAKE_BUILD_TYPE= Release
CFLAGS+= -fPIC
CFLAGS+= -fPIC -DNDEBUG -malign-double

CMAKE_ARGS+= -DINSTALL_LAYOUT=FREEBSD \
-DINSTALL_LDCONFIGDIR="${LOCALBASE}/libdata/ldconfig" \
Expand Down Expand Up @@ -184,13 +184,6 @@ SUB_LIST+= LEGACY_LIMITS="" MODERN_LIMITS="@comment "
.include <bsd.port.pre.mk>
.if ${CHOSEN_COMPILER_TYPE} == clang && ${OPSYS} == FreeBSD && ${OSVERSION} >= 1300109 || ${ARCH} == "i386"
BUILD_DEPENDS+= clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT}
CC= ${LOCALBASE}/bin/clang${LLVM_DEFAULT}
CPP= ${LOCALBASE}/bin/clang${LLVM_DEFAULT}
CXX= ${LOCALBASE}/bin/clang++${LLVM_DEFAULT}
.endif
.if ${ARCH} == "i386" && ${OSVERSION} < 1200000
# clang 7.x and 8.x do not build properly on 11i386
CPP= clang-cpp${LLVM_DEFAULT}
Expand Down
6 changes: 3 additions & 3 deletions databases/mysql80-server/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1611995725
SHA256 (mysql-boost-8.0.23.tar.gz) = 1c7a424303c134758e59607a0b3172e43a21a27ff08e8c88c2439ffd4fc724a5
SIZE (mysql-boost-8.0.23.tar.gz) = 291039175
TIMESTAMP = 1621139131
SHA256 (mysql-boost-8.0.25.tar.gz) = 93c5f57cbd69573a8d9798725edec52e92830f70c398a1afaaea2227db331728
SIZE (mysql-boost-8.0.25.tar.gz) = 290265324
18 changes: 10 additions & 8 deletions databases/mysql80-server/files/patch-client_CMakeLists.txt
Original file line number Diff line number Diff line change
@@ -1,34 +1,36 @@
--- client/CMakeLists.txt.orig 2019-09-20 08:30:51 UTC
--- client/CMakeLists.txt.orig 2021-03-22 08:44:50 UTC
+++ client/CMakeLists.txt
@@ -28,8 +28,11 @@ DISABLE_MISSING_PROFILE_WARNING()
@@ -28,10 +28,13 @@ DISABLE_MISSING_PROFILE_WARNING()
## Subdirectory with common client code.
ADD_SUBDIRECTORY(base)
## Subdirectory for mysqlpump code.
+IF(WITHOUT_SERVER)
ADD_SUBDIRECTORY(dump)
## Subdirectory for mysql_migrate_keyring code.
ADD_SUBDIRECTORY(migrate_keyring)
+ENDIF()

+IF(NOT WITHOUT_CLIENTLIBS)
MYSQL_ADD_EXECUTABLE(mysql
${CMAKE_SOURCE_DIR}/sql-common/net_ns.cc
completion_hash.cc
@@ -39,6 +42,7 @@ MYSQL_ADD_EXECUTABLE(mysql
@@ -41,6 +44,7 @@ MYSQL_ADD_EXECUTABLE(mysql
client_query_attributes.cc
LINK_LIBRARIES mysqlclient client_base ${EDITLINE_LIBRARY}
)
+ENDIF()

IF(NOT WITHOUT_SERVER)
MYSQL_ADD_EXECUTABLE(mysql_upgrade
@@ -55,6 +59,7 @@ IF(SOLARIS_SPARC AND MY_COMPILER_IS_SUNPRO AND
@@ -57,6 +61,7 @@ IF(SOLARIS_SPARC AND MY_COMPILER_IS_SUNPRO AND
)
ENDIF()

+IF(NOT WITHOUT_SERVER)
MYSQL_ADD_EXECUTABLE(mysqltest
mysqltest.cc
mysqltest/error_names.cc
@@ -71,6 +76,9 @@ MYSQL_ADD_EXECUTABLE(mysqltest
@@ -73,6 +78,9 @@ MYSQL_ADD_EXECUTABLE(mysqltest
ENABLE_EXPORTS
LINK_LIBRARIES mysqlclient
)
Expand All @@ -38,7 +40,7 @@
MYSQL_ADD_EXECUTABLE(mysqlcheck
check/mysqlcheck.cc
check/mysqlcheck_core.cc
@@ -246,7 +254,9 @@ ENDIF()
@@ -248,7 +256,9 @@ ENDIF()

TARGET_COMPILE_DEFINITIONS(mysqlbinlog PRIVATE DISABLE_PSI_MUTEX)
TARGET_INCLUDE_DIRECTORIES(mysqlbinlog PRIVATE ${CMAKE_SOURCE_DIR}/sql)
Expand All @@ -48,7 +50,7 @@
MYSQL_ADD_EXECUTABLE(mysqladmin
mysqladmin.cc
LINK_LIBRARIES mysqlclient
@@ -259,6 +269,9 @@ MYSQL_ADD_EXECUTABLE(mysql_config_editor
@@ -261,6 +271,9 @@ MYSQL_ADD_EXECUTABLE(mysql_config_editor
mysql_config_editor.cc
LINK_LIBRARIES mysqlclient
)
Expand All @@ -58,7 +60,7 @@
MYSQL_ADD_EXECUTABLE(mysql_secure_installation
mysql_secure_installation.cc
LINK_LIBRARIES mysqlclient
@@ -269,6 +282,7 @@ MYSQL_ADD_EXECUTABLE(mysql_ssl_rsa_setup
@@ -271,6 +284,7 @@ MYSQL_ADD_EXECUTABLE(mysql_ssl_rsa_setup
path.cc
LINK_LIBRARIES mysys
)
Expand Down
17 changes: 0 additions & 17 deletions databases/mysql80-server/files/patch-icu68

This file was deleted.

20 changes: 10 additions & 10 deletions databases/mysql80-server/files/patch-mysys_my__default.cc
Original file line number Diff line number Diff line change
@@ -1,15 +1,15 @@
--- mysys/my_default.cc.orig 2019-09-20 08:30:51 UTC
--- mysys/my_default.cc.orig 2021-04-23 15:06:40 UTC
+++ mysys/my_default.cc
@@ -203,7 +203,7 @@ bool no_defaults = false;
@@ -204,7 +204,7 @@ bool no_defaults = false;

/* Which directories are searched for options (and in which order) */

-#define MAX_DEFAULT_DIRS 6
+#define MAX_DEFAULT_DIRS 7
#define DEFAULT_DIRS_SIZE (MAX_DEFAULT_DIRS + 1) /* Terminate with NULL */
static const char **default_directories = NULL;
static const char **default_directories = nullptr;

@@ -909,6 +909,14 @@ static int search_default_file_with_ext(Process_option
@@ -915,6 +915,14 @@ static int search_default_file_with_ext(Process_option
return 1; /* Ignore wrong files */
}

Expand All @@ -21,10 +21,10 @@
+ goto err;
+ }
+
while (mysql_file_getline(buff, sizeof(buff) - 1, fp, is_login_file)) {
line++;
/* Ignore comment and empty lines */
@@ -1228,7 +1236,8 @@ void my_print_default_files(const char *conf_file) {
while (true) {
auto fileline = mysql_file_getline(buff, sizeof(buff), fp, is_login_file);
char *linebuff = fileline.get();
@@ -1300,7 +1308,8 @@ void my_print_default_files(const char *conf_file) {
end[(strlen(end) - 1)] = ' ';
else
strxmov(end, conf_file, *ext, " ", NullS);
Expand All @@ -34,7 +34,7 @@
}
}
}
@@ -1565,14 +1574,9 @@ static const char **init_default_directories(MEM_ROOT
@@ -1640,14 +1649,9 @@ static const char **init_default_directories(MEM_ROOT

#else

Expand All @@ -51,7 +51,7 @@
#endif

if ((env = getenv("MYSQL_HOME"))) errors += add_directory(alloc, env, dirs);
@@ -1635,7 +1639,7 @@ int check_file_permissions(const char *file_name, bool
@@ -1710,7 +1714,7 @@ int check_file_permissions(const char *file_name, bool
#if !defined(_WIN32)
MY_STAT stat_info;

Expand Down
24 changes: 24 additions & 0 deletions databases/mysql80-server/files/patch-sql_binlog.cc
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
--- sql/binlog.cc.orig 2021-03-22 08:44:50 UTC
+++ sql/binlog.cc
@@ -9156,8 +9156,8 @@ void MYSQL_BIN_LOG::report_missing_purged_gtids(

char *missing_gtids = NULL;
char *slave_executed_gtids = NULL;
- gtid_missing.to_string(&missing_gtids, NULL);
- slave_executed_gtid_set->to_string(&slave_executed_gtids, NULL);
+ gtid_missing.to_string(&missing_gtids);
+ slave_executed_gtid_set->to_string(&slave_executed_gtids);

/*
Log the information about the missing purged GTIDs to the error log.
@@ -9210,8 +9210,8 @@ void MYSQL_BIN_LOG::report_missing_gtids(
Gtid_set gtid_missing(slave_executed_gtid_set->get_sid_map());
gtid_missing.add_gtid_set(slave_executed_gtid_set);
gtid_missing.remove_gtid_set(previous_gtid_set);
- gtid_missing.to_string(&missing_gtids, NULL);
- slave_executed_gtid_set->to_string(&slave_executed_gtids, NULL);
+ gtid_missing.to_string(&missing_gtids);
+ slave_executed_gtid_set->to_string(&slave_executed_gtids);
String tmp_uuid;
18 changes: 0 additions & 18 deletions databases/mysql80-server/files/patch-sql_item.h

This file was deleted.

2 changes: 2 additions & 0 deletions databases/mysql80-server/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -8,6 +8,7 @@ bin/myisamlog
bin/myisampack
bin/mysqldumpslow
bin/mysql_client_test
bin/mysql_keyring_encryption_test
bin/mysql_secure_installation
bin/mysql_ssl_rsa_setup
bin/mysql_tzinfo_to_sql
Expand Down Expand Up @@ -58,6 +59,7 @@ lib/mysql/plugin/component_audit_api_message_emit.so
lib/mysql/plugin/component_example_component1.so
lib/mysql/plugin/component_example_component2.so
lib/mysql/plugin/component_example_component3.so
lib/mysql/plugin/component_keyring_file.so
lib/mysql/plugin/component_log_filter_dragnet.so
lib/mysql/plugin/component_log_sink_json.so
lib/mysql/plugin/component_log_sink_syseventlog.so
Expand Down

0 comments on commit c7fbbf1

Please sign in to comment.