Skip to content

Commit

Permalink
python3-pydantic: enable ptest
Browse files Browse the repository at this point in the history
* Add to ptest-packelists-meta-python.inc "FAST" under 30 s

Signed-off-by: Tim Orling <ticotimo@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
  • Loading branch information
moto-timo authored and kraj committed Dec 20, 2023
1 parent 76b1d04 commit 2325469
Show file tree
Hide file tree
Showing 3 changed files with 26 additions and 0 deletions.
Original file line number Diff line number Diff line change
Expand Up @@ -27,6 +27,7 @@ PTESTS_FAST_META_PYTHON = "\
python3-polyline \
python3-precise-runner \
python3-prettytable \
python3-pydantic \
python3-pydantic-core \
python3-pylint \
python3-ptyprocess \
Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
#!/bin/sh

pytest --automake
22 changes: 22 additions & 0 deletions meta-python/recipes-devtools/python/python3-pydantic_2.5.2.bb
Original file line number Diff line number Diff line change
Expand Up @@ -29,3 +29,25 @@ RDEPENDS:${PN} += "\
python3-pydantic-core \
python3-typing-extensions \
"

inherit ptest
SRC_URI += "file://run-ptest"
RDEPENDS:${PN}-ptest += "\
python3-cloudpickle \
python3-dirty-equals \
python3-pytest \
python3-pytest-mock \
python3-unittest-automake-output \
"

do_install_ptest() {
cp -rf ${S}/tests/ ${D}${PTEST_PATH}/
# Requires 'ruff' (python3-ruff) which we cannot build
# until we have Rust 1.71+ in oe-core
rm -f ${D}${PTEST_PATH}/tests/test_docs.py
# We are not trying to support mypy
rm -f ${D}${PTEST_PATH}/tests/test_mypy.py
# We are not trying to run benchmarks
rm -rf ${D}${PTEST_PATH}/tests/benchmarks
}

0 comments on commit 2325469

Please sign in to comment.