Skip to content

Commit

Permalink
(geography/R-stars) Updated 0.4.3 to 0.5.3
Browse files Browse the repository at this point in the history
# version 0.5-3

* `read_stars()` accepts a function (or list with functions) as first argument,
   allowing for saving `stars` objects that read from package directories resolving
   platform-dependent paths at run-time

* handle categorical rasters starting at value 0 (by adding 1, and warning); #428

* add `%in%` method; #424

* `read_stars` gains an argument `tolerance` to control tolerance in
  dimension value comparisons; #414

* binary Ops (like `+`, `-`, `*` etc.) work for `stars_proxy` objects; #390

* `st_rasterize` rasterizes multiple attributes, and handles factors
  (when sf >= 0.9-9)

* `write_stars` deals better with `stars_proxy` objects; #404

* fix regression in reading some `stars_proxy` objects; #379

* add `[<-` (partially) and `is.na` methods for `stars_proxy` objects; #402

* add `replace_na` methods; #402

# version 0.5-2

* read and write factor levels as GDAL category names; write color table; #392

* handle `normalize_path` for choosing to `proxy`; #391

* ignore units when there are different units accross bands of a subdataset

* speed up `st_rgb` using faster `st_apply` approach; #315, #390

* improve handling of crs in Spatial objects (avoid loss of wkt comments)

* correctly write band subsets for smaller proxy objects; #291

* write arbitrarily cropped proxy objects; #291

* speed up `st_apply` when a function is provided that works on chunks
  at a time; #390

* warn when breaks = "quantile" results in a single class; #388

* fix `[` bug selecting bands in proxy objects; #388

* for `stars_proxy` objects, `write_stars` writes all objects into a
  multi-layer file; #385

* multi-file proxy objects can be `st_warp`ed with `use_gdal = TRUE`; #385

# version 0.5-1

* fix weird GDAL-related bug in stars2 vignette

* `read_ncdf` does not take time as mid-points of regular intervals,
  but as starting points; #378

# version 0.5-0

* fix handling of rasters with color tables; #375

* `st_apply` and other methods for `stars_proxy` objects handle ... ; #374

* add `st_bbox`, `st_crs` methods for terra's `SpatVector` objects;
  https://github.com/mtennekes/tmap/issues/536

* add `st_bbox`, `st_crs` and `st_as_stars` methods for terra's
  `SpatRaster` objects; https://github.com/mtennekes/tmap/issues/536

* allow for multi-resolution attributes in `stars_proxy` objects
  (e.g., all gray scale sentinel-2 bands); see vignettes 2 and 7 for
  examples.

* `plot` defaults to a categorical color scale when plotting a factor
  variable; https://github.com/mtennekes/tmap/issues/526

* `st_extract` extracts space-time points if `time_column` is
  specified, and handles time intervals; #352

* add `[[<-.stars` method, which is now called by `$<-.stars`, so that
  array names can be set programmatically

* add `transmute` methods

* `plot.stars` calls `droplevels` if a factor array has any `NA` levels; #339

* `read_stars` reads `NaN`s as `NA`; #333

* improve `st_extract` method for both `stars` and `stars_proxy`
  objects; interpolation options are reduced to bilinear; #322, #279,
  #290

* better handle categorical rasters that do not start at value 1; #329

* plot layout can be controlled with `mfrow = c(nr, nc)` argument

* `stars_proxy` objects have a normalized path; #331

* cropping or selecting with `bbox` treats cells always as small
  polygons; #330

* add faster `st_extract` method for `stars` objects; #322

* added vignette: "How `raster` functions map to `stars` functions",
  by Sebastien Rochette; #122, #325

* fix bug in dimension `values` field when downsampling; #324

* `write_stars` also writes out band names; #323

* add `rgdal` to Suggests:

* each `call_list` entry of a `stars_proxy` object carries its proper
  calling environment; #309

* `st_as_sf.stars` copes with zero attribute (empty) stars objects

* add `st_set_bbox` generic, to set raster extent, motivated by #315

* set up tic, with great help from @pat-s, #313

* get rid of more `proj4string`s for representing coordinate reference
  systems; #312

* as(x, "Spatial") correctly handles `from` dimension values different
  from one

* `read_stars` now sets the `BANDNAME` GDAL metadata item, or else the
  band's GetDescription() as the band's dimension values

* `st_as_stars.data.frame` reads simple tables (non-raster data) if
  `dims` has length less than 2

* band descriptions are in the band dimension values

* dimension tables are simpler, and are shown properly in Rstudio

* `st_rgb` gains a `probs` argument, to cut off and stretch based on
  quantiles

* `as(x, "Raster")` merges multiple attributes before converting to
  raster brick
  • Loading branch information
mef committed Sep 20, 2021
1 parent e866317 commit fd9906c
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 7 deletions.
34 changes: 32 additions & 2 deletions geography/R-stars/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.1 2020/08/09 15:24:46 brook Exp $
# $NetBSD: Makefile,v 1.2 2021/09/20 13:01:32 mef Exp $

R_PKGNAME= stars
R_PKGVER= 0.4-3
R_PKGVER= 0.5-3
CATEGORIES= geography

MAINTAINER= pkgsrc-users@NetBSD.org
Expand All @@ -14,6 +14,36 @@ DEPENDS+= R-sf>=0.9.0:../../geography/R-sf
DEPENDS+= R-abind>=1.4.5:../../math/R-abind
DEPENDS+= R-units>=0.6.5:../../math/R-units

# Packages suggested but not available:
# 'PCICt', 'clue', 'cubelyr', 'exactextractr', 'future.apply',
# 'ggforce', 'ncdfgeom', 'ncmeta', 'pbapply', 'plm', 'starsdata',
# 'terra'

TEST_DEPENDS+= R-RNetCDF-[0-9]*:../../math/R-RNetCDF
TEST_DEPENDS+= R-covr-[0-9]*:../../devel/R-covr
TEST_DEPENDS+= R-digest-[0-9]*:../../security/R-digest
TEST_DEPENDS+= R-dplyr-[0-9]*:../../math/R-dplyr
TEST_DEPENDS+= R-ggplot2-[0-9]*:../../graphics/R-ggplot2
TEST_DEPENDS+= R-ggthemes-[0-9]*:../../graphics/R-ggthemes
TEST_DEPENDS+= R-gstat-[0-9]*:../../math/R-gstat
TEST_DEPENDS+= R-httr-[0-9]*:../../www/R-httr
TEST_DEPENDS+= R-jsonlite-[0-9]*:../../textproc/R-jsonlite
TEST_DEPENDS+= R-knitr-[0-9]*:../../print/R-knitr
TEST_DEPENDS+= R-maps-[0-9]*:../../geography/R-maps
TEST_DEPENDS+= R-mapdata-[0-9]*:../../geography/R-mapdata
TEST_DEPENDS+= R-randomForest-[0-9]*:../../math/R-randomForest
TEST_DEPENDS+= R-raster-[0-9]*:../../geography/R-raster
TEST_DEPENDS+= R-rgdal-[0-9]*:../../geography/R-rgdal
TEST_DEPENDS+= R-rmarkdown-[0-9]*:../../textproc/R-rmarkdown
TEST_DEPENDS+= R-spacetime-[0-9]*:../../math/R-spacetime
TEST_DEPENDS+= R-spatstat-[0-9]*:../../geography/R-spatstat
TEST_DEPENDS+= R-spatstat.geom-[0-9]*:../../geography/R-spatstat.geom
TEST_DEPENDS+= R-testthat-[0-9]*:../../devel/R-testthat
TEST_DEPENDS+= R-tidyr-[0-9]*:../../math/R-tidyr
TEST_DEPENDS+= R-viridis-[0-9]*:../../graphics/R-viridis
TEST_DEPENDS+= R-xts-[0-9]*:../../math/R-xts
TEST_DEPENDS+= R-zoo-[0-9]*:../../math/R-zoo

USE_LANGUAGES= # none

.include "../../math/R/Makefile.extension"
Expand Down
10 changes: 5 additions & 5 deletions geography/R-stars/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.1 2020/08/09 15:24:46 brook Exp $
$NetBSD: distinfo,v 1.2 2021/09/20 13:01:32 mef Exp $

SHA1 (R/stars_0.4-3.tar.gz) = 0a63f476257d92bb9493c172876b2abcd344cf78
RMD160 (R/stars_0.4-3.tar.gz) = e1627e4e8993906bb832aabf92a4e8c142675606
SHA512 (R/stars_0.4-3.tar.gz) = 2bbc060ede9c8f88d7599861e0dcda2ee2722f8004448139b8e66133cfbcd7dbf78b28261feeb104acd20fc5c1879f9e594b9f8cfceca710aaaad3c83758d5ec
Size (R/stars_0.4-3.tar.gz) = 4745035 bytes
SHA1 (R/stars_0.5-3.tar.gz) = 0a8b3dfe38dd1cac6c5085a5fb36220dcd460dbe
RMD160 (R/stars_0.5-3.tar.gz) = 514cf7df1930539481ef18bad3556e22cfaf226d
SHA512 (R/stars_0.5-3.tar.gz) = 158b028f982ca2610c7935635f93bb76b2123eec08b27fe3b6a981ac202cfe3cd0a6749cb307d26e7ba47bece756cbcdafc02c7ff69791f18e9fc0b879cee419
Size (R/stars_0.5-3.tar.gz) = 5047525 bytes

0 comments on commit fd9906c

Please sign in to comment.