Skip to content

Commit

Permalink
(devel/R-cli) Updated 2.0.2 to 2.2.0
Browse files Browse the repository at this point in the history
# cli 2.2.0

* New `style_hyperlink()` function to add hyperlinks, on terminals that
  support them.

* `cli_format_method()` now works properly in knitr, and other environments
  that catch message conditions (#159).

* ANSI strings created by `col_*`, `bg_*` and `style_*` now also add the
  `character` class to the result. This fixes issues with code that
  expect `character` objects.

* New functions to manipulate ANSI strings: `ansi_aling()`,
  `ansi_has_any()`, `ansi_nchar()`, `ansi_regex()`, `ansi_strip()`,
  `ansi_strsplit()`, `ansi_substr()`, `ansi_substring()`.

# cli 2.1.0

* New `cli_vec()` function to allow easier formatting of collapsed
  vectors. It is now also possible to use styling to set the collapsing
  parameters (#129).

* New `pluralize()` function to perform pluralization without generating
  cli output (#155).

* `console_width()` works better now in RStudio, and also in terminals.

* Styling of verbatim text work properly now (#147, @tzakharko).

* Messages (ie. `message` conditions) coming from cli now have the
  `cliMessage` class, so you can easily suppress them without suppressing
  other messages (#156).

* cli prints the output to `stderr()` now, if there is an output or
  message sink. This is to make interactive and non-interactive sessions
  consistent (#153).

* Pluralization works corrently now if the last alternative is the
  empty string (#158).

* cli now caches the result of the dark background detection in iTerm on
  macOS. Reload cli to delete the cache (#131).

* The `is_dynamic_tty()`, `is_ansi_tty()` and `ansi_hide_cursor()` and
  releted functions now default to the `"auto"` stream, which is
  automatically selected to be either `stdout()` or `stderr()`.
  See the manual for details (#144).

* The default theme now quotes file names, paths, email addresses if they
  don't start or end with an alphanumeric character or a slash. This is
  to make it easier to spot names that start or end with a space (#167).

* `make_spinner()` clears the line properly now (@tzakharko, #164).

* Semantic cli functions now automatically replace Unicode non-breaking
  space characters (`\u00a0`) with regular space characters, right before
  output. They are still used to calculate the line breaks, but not
  outputted (#161).
* Progress bars now respect `is_dynamic_tty()` and do not output `\r` when this
  is false (@jimhester, #177)
  • Loading branch information
mef committed Jan 1, 2021
1 parent f9562fb commit edff8b9
Show file tree
Hide file tree
Showing 2 changed files with 8 additions and 7 deletions.
5 changes: 3 additions & 2 deletions devel/R-cli/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.8 2020/09/23 05:23:06 mef Exp $
# $NetBSD: Makefile,v 1.9 2021/01/01 04:15:16 mef Exp $

R_PKGNAME= cli
R_PKGVER= 2.0.2
R_PKGVER= 2.2.0
CATEGORIES= devel

MAINTAINER= minskim@NetBSD.org
Expand All @@ -18,6 +18,7 @@ TEST_DEPENDS+= R-prettycode-[0-9]*:../../devel/R-prettycode
TEST_DEPENDS+= R-covr-[0-9]*:../../devel/R-covr
TEST_DEPENDS+= R-knitr-[0-9]*:../../print/R-knitr
TEST_DEPENDS+= R-rmarkdown-[0-9]*:../../textproc/R-rmarkdown
TEST_DEPENDS+= tex-ec-[0-9]*:../../fonts/tex-ec

USE_LANGUAGES= # none

Expand Down
10 changes: 5 additions & 5 deletions devel/R-cli/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.4 2020/09/20 21:22:02 mef Exp $
$NetBSD: distinfo,v 1.5 2021/01/01 04:15:16 mef Exp $

SHA1 (R/cli_2.0.2.tar.gz) = 1f8bc210c6d2b6c872ccdc899937996c2acfc356
RMD160 (R/cli_2.0.2.tar.gz) = 713bd057281f47015b858b2ac9e643b716eea3e8
SHA512 (R/cli_2.0.2.tar.gz) = c5a398a35bfbc43b618b97477ef97785c674c1aad03fcbf20786f1eab057cd5f21da430ffa69161d14a331b2e538d8dc75b6a3a2699db799b1441dce31d3761e
Size (R/cli_2.0.2.tar.gz) = 116357 bytes
SHA1 (R/cli_2.2.0.tar.gz) = 2984fb13422ab0c51d5dd908ac7d71f82d5db033
RMD160 (R/cli_2.2.0.tar.gz) = 5506d107250781a1a4a1093fc30c73cc121107e2
SHA512 (R/cli_2.2.0.tar.gz) = a5ec962efaf9b9f691c03fd4aa4b18ead3d3473fca4a08d4173a901358f5399e696fe65549ff744e320379a5a05ed8fce84c363b41a7a5d227145e9e7a15214f
Size (R/cli_2.2.0.tar.gz) = 120676 bytes

0 comments on commit edff8b9

Please sign in to comment.