Skip to content

Commit

Permalink
libsoup: update to 2.68.1.
Browse files Browse the repository at this point in the history
Changes in libsoup from 2.68.0 to 2.68.1:

        * Several memory leaks fixed in tests, examples, and parsing code [Claudio Saavedra]

        * SoupServer: Fixes to Windows path handling [Ignacio Casal Quinteiro]

Changes in libsoup from 2.67.93 to 2.68.0:

        * Updated translations: Brazilian Portuguese, Croatian,
          Friulian, Italian, Turkish

Changes in libsoup from 2.67.92 to 2.67.93:

        * SoupMessage: Handle Transfer-Encoding: identity for
          compatibility reasons [#148, Thomas Bluemel, Normen Bolling]

        * WebSockets: Only poll IO stream when needed [Carlos Garcia
          Campos]

        * WebSockets: Properly set cookies received during handshake
          [Carlos Garcia Campos]

        * WebSockets: Plug a couple of memory leaks and fix a few
          read-after-free memory errors [Claudio Saavedra]

        * WebSockets: document how web socket extensions should treat
          buffers in case of error [Claudio Saavedrə]

        * SoupSession: Don't reset user GCancellable internally [Tom
          Bailey]

        * Tests: Make tests installable [Simon McVittie]

        * Remove deprecate GTimeVal internal usage [Claudio Saavedra]

        * CI: increase coverage by enabling all features during
          testing [Claudio Saavedra]

        * Updated translations: Korean, German, Galician, Hungarian,
          Slovenian, Latvian, Finnish, Serbian, Catalan, Polish

Changes in libsoup from 2.67.91 to 2.67.92:

        * Silence GTimeVal deprecation warnings. [Michael Catanzaro]

        * API documentation and annotation fixes [Дилян Палаузов, Claudio Saavedra]

        * Plug a couple of NTLM authentication memory leaks [#156, Claudio Saavedra]

        * Fix build in SmartOS/SunOS [#157, Juraj Lutter]

        * Meson: Use feature options [Xavier Claessens]

        * Meson: Do not fallback to system krb5-config for cross-compilation
          [Xavier Claessens]

        * NTLM: Fix build with NTLM enabled [Claudio Saavedra]

        * Updated translations: Basque, Czech, Indonesian, Lithuanian, Swedish

Changes in libsoup from 2.67.90 to 2.67.91:

        * HSTS: New API to retrieve information about existing HSTS policies
          [Claudio Saavedra]

        * Updated translations: French, Romanian, Spanish

Changes in libsoup from 2.67.3 to 2.67.90a:

        * WebSockets: add support for WebSocket extensions via new
          SoupWebsocketExtensionManager and SoupWebsocketExtension API
          [Carlos Garcia Campos]

        * WebSockets: add support for the permessage-deflate extension, enabled
          by default in SoupServer and in the client side only if SoupWebsocketExtensionManager
          is added to a session [Carlos Garcia Campos]

        * WebSockets: Allow sending close frames with no body [Carlos Garcia Campos]

        * WebSockets: ignore messages after close has been sent and received [Carlos Garcia Campos]

        * Meson: tls-check improved [Xavier Claessens]

        * Meson: improve Apache checks [Claudio Saavedra]

Changes in libsoup from 2.67.2 to 2.67.3:

        * WebSockets: allow sending empty binary data [Carlos Garcia Campos]

        * WebSockets: fail and load the connection on invalid payload length  [Carlos Garcia Campos]

        * WebSockets: allow NULL characters in text messages data [Carlos Garcia Campos]

        * WebSockets: Close connection on wrongly masked/unmasked frame as per RFC [Carlos Garcia Campos]

        * WebSockets: other code fixes [Carlos Garcia Campos]

        * NTLM: Fix NTLMv2 authentication [Thibaut Robert]

        * SoupMessage: fix several deprecation warnings related to private data [Claudio Saavedra]

Changes in libsoup from 2.67.1 to 2.67.2:

        * gobject-introspection: Fix annotation for soup_auth_new()
          [Rico Tzschichholz]

        * brotli: Do not advertise the decoder as it's failing with
          some websites [Patrick Griffis]

        * Meson: Fix xml2 and sqlite fallbacks [Xavier Claessens]

        * HSTS: Add SoupHSTSEnforcer:hsts-enforced signal [Claudio
          Saavedra]

        * HSTS: Fixes to the types used to store policies in the
          SQLite storage [Claudio Saavedra]

        * HSTS: Accept Strict-Transport-Security regardless of casing
          [Claudio Saavedra]

        * WebSockets: Ensure messages finishes when handshake fails
          [Carlos Garcia Campos]

        * WebSockets: Fix critical warnings and test failures [Carlos
          Garcia Campos]

Changes in libsoup from 2.66.2 to 2.67.1:

        * Add a brotli decoder. This adds a new dependency on libbrotli
	  [Patrick Griffis]

        * Add strict secure cookies support [Patrick Griffis]

        * Add HSTS enforcer SoupSession feature (with both memory
          and sqlite backends) [Adrien Plazas, Claudio Saavedra]

        * meson gtk-doc documentation fixes [Claudio Saavedra]

        * Bump the CI test image to Fedora 30 and add libbrotli
          dependency [Claudio Saavedra]
  • Loading branch information
0-wiz-0 committed Oct 10, 2019
1 parent a98d824 commit d11e0c9
Show file tree
Hide file tree
Showing 5 changed files with 20 additions and 32 deletions.
10 changes: 4 additions & 6 deletions net/libsoup/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.55 2019/10/07 09:28:13 prlw1 Exp $
# $NetBSD: Makefile,v 1.56 2019/10/10 12:43:28 wiz Exp $

DISTNAME= libsoup-2.66.2
PKGREVISION= 1
DISTNAME= libsoup-2.68.1
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/libsoup/${PKGVERSION_NOREV:R}/}
EXTRACT_SUFX= .tar.xz
Expand All @@ -21,9 +20,7 @@ PKGCONFIG_OVERRIDE_STAGE=pre-install
MAKE_ENV+= LD_LIBRARY_PATH=${WRKSRC}/output/${PKGBASE}

# disable vala detection
MESON_ARGS+= -Dvapi=false

LDFLAGS.SunOS+= -lsocket
MESON_ARGS+= -Dvapi=disabled

.include "../../mk/compiler.mk"
.if !empty(PKGSRC_COMPILER:Mclang)
Expand All @@ -34,6 +31,7 @@ CWRAPPERS_APPEND.cc+= -Wno-error=format-nonliteral

.include "options.mk"

.include "../../archivers/brotli/buildlink3.mk"
.include "../../databases/sqlite3/buildlink3.mk"
BUILDLINK_API_DEPENDS.glib2+= glib2>=2.38.0
.include "../../devel/glib2/buildlink3.mk"
Expand Down
9 changes: 8 additions & 1 deletion net/libsoup/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.13 2019/08/16 13:08:58 wiz Exp $
@comment $NetBSD: PLIST,v 1.14 2019/10/10 12:43:28 wiz Exp $
include/libsoup-2.4/libsoup/soup-address.h
include/libsoup-2.4/libsoup/soup-auth-domain-basic.h
include/libsoup-2.4/libsoup/soup-auth-domain-digest.h
Expand All @@ -17,6 +17,9 @@ include/libsoup-2.4/libsoup/soup-date.h
include/libsoup-2.4/libsoup/soup-enum-types.h
include/libsoup-2.4/libsoup/soup-form.h
include/libsoup-2.4/libsoup/soup-headers.h
include/libsoup-2.4/libsoup/soup-hsts-enforcer-db.h
include/libsoup-2.4/libsoup/soup-hsts-enforcer.h
include/libsoup-2.4/libsoup/soup-hsts-policy.h
include/libsoup-2.4/libsoup/soup-logger.h
include/libsoup-2.4/libsoup/soup-message-body.h
include/libsoup-2.4/libsoup/soup-message-headers.h
Expand Down Expand Up @@ -48,6 +51,9 @@ include/libsoup-2.4/libsoup/soup-uri.h
include/libsoup-2.4/libsoup/soup-value-utils.h
include/libsoup-2.4/libsoup/soup-version.h
include/libsoup-2.4/libsoup/soup-websocket-connection.h
include/libsoup-2.4/libsoup/soup-websocket-extension-deflate.h
include/libsoup-2.4/libsoup/soup-websocket-extension-manager.h
include/libsoup-2.4/libsoup/soup-websocket-extension.h
include/libsoup-2.4/libsoup/soup-websocket.h
include/libsoup-2.4/libsoup/soup-xmlrpc-old.h
include/libsoup-2.4/libsoup/soup-xmlrpc.h
Expand Down Expand Up @@ -85,6 +91,7 @@ share/locale/es/LC_MESSAGES/libsoup.mo
share/locale/et/LC_MESSAGES/libsoup.mo
share/locale/eu/LC_MESSAGES/libsoup.mo
share/locale/fa/LC_MESSAGES/libsoup.mo
share/locale/fi/LC_MESSAGES/libsoup.mo
share/locale/fr/LC_MESSAGES/libsoup.mo
share/locale/fur/LC_MESSAGES/libsoup.mo
share/locale/gd/LC_MESSAGES/libsoup.mo
Expand Down
11 changes: 5 additions & 6 deletions net/libsoup/distinfo
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.23 2019/08/19 20:01:52 otis Exp $
$NetBSD: distinfo,v 1.24 2019/10/10 12:43:28 wiz Exp $

SHA1 (libsoup-2.66.2.tar.xz) = f549a0ab984895a11053505806068bbad22a1dfc
RMD160 (libsoup-2.66.2.tar.xz) = 787dc933e36ac75edb95438d47a4e495de5550ab
SHA512 (libsoup-2.66.2.tar.xz) = 1df443470239f23d22301e37e36f3d34963352ee0122f317cd15b19d90115831091bddcee27bc6f0d4994adcf4e5bd9c0395de2bd7f39ae305ba0edea7789092
Size (libsoup-2.66.2.tar.xz) = 1446024 bytes
SHA1 (patch-meson.build) = 688bae137b5c99b9710f9474df2f969b62422d5a
SHA1 (libsoup-2.68.1.tar.xz) = d3f15038fae4f48ae386cfdf53ae12382ab7524b
RMD160 (libsoup-2.68.1.tar.xz) = 91c5858f61967d2ac90040d47ab79f518e75977a
SHA512 (libsoup-2.68.1.tar.xz) = e670de61c7a20994cafcddf8eb33d5210d6b623955c66ca21fc13c13d0596e72d0f487e6cc29cde73edcff6307dedd33063013a49643081830876209a336c46b
Size (libsoup-2.68.1.tar.xz) = 1486664 bytes
6 changes: 3 additions & 3 deletions net/libsoup/options.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: options.mk,v 1.6 2019/08/18 08:13:30 wiz Exp $
# $NetBSD: options.mk,v 1.7 2019/10/10 12:43:28 wiz Exp $

PKG_OPTIONS_VAR= PKG_OPTIONS.libsoup
PKG_SUPPORTED_OPTIONS= gssapi
Expand All @@ -8,8 +8,8 @@ PKG_SUGGESTED_OPTIONS=

.if !empty(PKG_OPTIONS:Mgssapi)
. include "../../mk/krb5.buildlink3.mk"
MESON_ARGS+= -Dgssapi=true
MESON_ARGS+= -Dgssapi=enabled
MESON_ARGS+= -Dkrb5_config=${KRB5_CONFIG}
.else
MESON_ARGS+= -Dgssapi=false
MESON_ARGS+= -Dgssapi=disabled
.endif
16 changes: 0 additions & 16 deletions net/libsoup/patches/patch-meson.build

This file was deleted.

0 comments on commit d11e0c9

Please sign in to comment.