Skip to content

Commit

Permalink
Update to texmath-0.12.4
Browse files Browse the repository at this point in the history
texmath (0.12.4)

  * TeX reader: handle hyperref better (#186).  We don't parse it as a link,
    but we pass its contents through rather than failing.

  * Update scripts and data in `lib/` directory. These are not build
    dependencies, but they were used to produce some of the large
    tables in the source code.  Fixed the scripts and Makefile to work
    with recent texmath and cabal.  Removed two very large unicode data
    files that can be downloaded when needed.  (This reduces the size of
    the source tarball considerably.) Remove `lib/toascii` (no longer used).

  * Update MMLDict using latest unicode.xml.

  * TeX reader: support siunitx `\qty`, `\qtyrange`, `\unit` (#185).

  * Remove Text.TeXMath.Compat.  We can now safely require mtl >= 2.2.1.

  * Use symbolMap from ToTeX to shorten the long hardcoded symbols list.
    Now we only hard-code items that differ what what is in symbolMap.
    This reduces the code size by thousands of lines.

  * Unicode.ToTeX: export `symbolMap` [API change].  This uses the data in
  `records` to create a backwards mapping from TeX commands to Exps (ESymbol
      elements).  This can replace most of the hardcoded list in the current
  TeX reader.

  * Split out TeXMath.Readers.TeX.Commands internal module.
    This makes the TeX reader shorter and should help compile times.

  * OMML reader: better handling of m:t nodes (#151).
    Previously we parsed an m:t element as an EIdentifier if it contains a
    single letter, but an EText TextNormal if it contains more than one.  This
    gave bad results in some cases.  It is better to reserve EText for the
    case where the m:nor property is specified for "normal text."

  * Require base >= 4.11.

  * Remove `network-uri` flag from stack.yaml.


texmath (0.12.3.3)

  * OMML writer: use nary only for operators supported by LibreOffice
    (Albert Krewinkel).  LibreOffice (and possibly Word, too) can handle
    only a small set of operators in an `nary` element.

  * TeX writer: use `\xleftarrow`, `\xrightarrow` where sensible
    (Albert Krewinkel).  The commands are generated for expressions over `←`
    or `→`. Besides being more idiomatic, this change also prevents the
    generation of invalid LaTeX, as `\leftarrow` and `\rightarrow` are not
    math operators and hence may not be followed by `\limit`.
    Both commands are part of amsmath.sty.

  * TeX reader:

    + Improve angled-bracket support (Albert Krewinkel).
      The amsmath package allows `\left<` and `\right>` as alternatives to
      `\left\langle` and `\right\rangle`, respectively.
    + Ignore stared version of `\tag` (Albert Krewinkel).
    + Support \dots{c,b,m,i,o} from amsmath (#179).
    + Change symbol returned for \dots{b,i,m} from `…` to `⋯`
      (Albert Krewinkel).

texmath (0.12.3.2)

  * OMML writer: remove m:nor element in math operators (#178).
    This caused the document's main font, rather than the math
    font, to be used in formatting operators, which is undesirable.

texmath (0.12.3.1)

  * MathML reader: don't allow mfenced attributes to inherit (#177).
    When open and close attributes aren't given on an mfenced,
    we should use defaults rather than inheriting these from a
    parent mfenced.

texmath (0.12.3)

  * TeX reader: implement logic to convert a Bin symbol to
    an Op to Op when it occurs at the beginning of a group,
    or after an Open, Pun, or Op symbol. This will give much
    better results for unary `-` (#176).

  * OMML writer: fixed rendering of EDelimited (#173).
    We now properly render "middles" (separators).
  • Loading branch information
depressed-pho committed Feb 12, 2022
1 parent 6c41d47 commit a02ad51
Show file tree
Hide file tree
Showing 4 changed files with 13 additions and 12 deletions.
6 changes: 3 additions & 3 deletions textproc/hs-texmath/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.24 2022/01/18 02:48:28 pho Exp $
# $NetBSD: Makefile,v 1.25 2022/02/12 08:01:36 pho Exp $

DISTNAME= texmath-0.12.2
PKGREVISION= 2
DISTNAME= texmath-0.12.4
CATEGORIES= textproc

MAINTAINER= szptvlfn@NetBSD.org
Expand All @@ -12,6 +11,7 @@ CONFIGURE_ARGS+= -fexecutable

.include "../../converters/hs-aeson/buildlink3.mk" # Only used by the executable
.include "../../textproc/hs-pandoc-types/buildlink3.mk"
.include "../../devel/hs-split/buildlink3.mk"
.include "../../devel/hs-syb/buildlink3.mk"
.include "../../textproc/hs-xml/buildlink3.mk"
.include "../../net/hs-network-uri/buildlink3.mk" # Only used by the executable
Expand Down
8 changes: 4 additions & 4 deletions textproc/hs-texmath/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.4 2021/04/24 17:18:03 pho Exp $
@comment $NetBSD: PLIST,v 1.5 2022/02/12 08:01:36 pho Exp $
bin/texmath
lib/texmath-${PKGVERSION}/${HS_VERSION}/package-description
lib/texmath-${PKGVERSION}/${HS_VERSION}/package-id
Expand All @@ -9,9 +9,6 @@ lib/${HS_PLATFORM}/${HS_PKGID}/Paths_texmath.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Text/TeXMath.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Text/TeXMath.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Text/TeXMath.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Text/TeXMath/Compat.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Text/TeXMath/Compat.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Text/TeXMath/Compat.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Text/TeXMath/Readers/MathML.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Text/TeXMath/Readers/MathML.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Text/TeXMath/Readers/MathML.p_hi
Expand All @@ -27,6 +24,9 @@ lib/${HS_PLATFORM}/${HS_PKGID}/Text/TeXMath/Readers/OMML.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Text/TeXMath/Readers/TeX.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Text/TeXMath/Readers/TeX.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Text/TeXMath/Readers/TeX.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Text/TeXMath/Readers/TeX/Commands.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Text/TeXMath/Readers/TeX/Commands.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Text/TeXMath/Readers/TeX/Commands.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Text/TeXMath/Readers/TeX/Macros.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Text/TeXMath/Readers/TeX/Macros.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Text/TeXMath/Readers/TeX/Macros.p_hi
Expand Down
3 changes: 2 additions & 1 deletion textproc/hs-texmath/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.24 2022/01/18 02:48:28 pho Exp $
# $NetBSD: buildlink3.mk,v 1.25 2022/02/12 08:01:36 pho Exp $

BUILDLINK_TREE+= hs-texmath

Expand All @@ -10,6 +10,7 @@ BUILDLINK_ABI_DEPENDS.hs-texmath+= hs-texmath>=0.12.2nb2
BUILDLINK_PKGSRCDIR.hs-texmath?= ../../textproc/hs-texmath

.include "../../textproc/hs-pandoc-types/buildlink3.mk"
.include "../../devel/hs-split/buildlink3.mk"
.include "../../devel/hs-syb/buildlink3.mk"
.include "../../textproc/hs-xml/buildlink3.mk"
.endif # HS_TEXMATH_BUILDLINK3_MK
Expand Down
8 changes: 4 additions & 4 deletions textproc/hs-texmath/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.7 2021/10/26 11:22:03 nia Exp $
$NetBSD: distinfo,v 1.8 2022/02/12 08:01:36 pho Exp $

BLAKE2s (texmath-0.12.2.tar.gz) = 43fbb549cfe1dfcd9808af0321e014277894ddabe96bd481fd789e86fbde0baf
SHA512 (texmath-0.12.2.tar.gz) = 89f3dc5c1042980abf06f1e4d3ca6806922f2094c6d7ec2cc1e4673ac16a7aaf73693c5fa5526eac96d6f9f5c2f894f2341295bacebb7216ef49eb8be7cc0424
Size (texmath-0.12.2.tar.gz) = 1807359 bytes
BLAKE2s (texmath-0.12.4.tar.gz) = 989ee2b591117027f7d7b11f6d87d32725082377041b68b5285c0be695b84d00
SHA512 (texmath-0.12.4.tar.gz) = e76f5c8c4756120c8402833826a8ecc0e0a3babf05dc928b68cc3d43e0a3df8dc7aba93b9f8b06ec86ca1453fb460879c34d0d20a346cec8e23c52555f30d00a
Size (texmath-0.12.4.tar.gz) = 1012215 bytes

0 comments on commit a02ad51

Please sign in to comment.