Skip to content

Commit

Permalink
Update to skylighting-core-0.12.2
Browse files Browse the repository at this point in the history
0.12.2
* Parser: handle context shift to external context, e.g.,
  BashOneLine##Bash. Closes #139 (issue with Dockerfile).
* Update xml files from upstream: bash, cmake, markdown, objectivecpp, php,
  sql-postgresql, sql, stan, zshr
* Fix formatting in Color doc-comment (Janek Spaderna).
* Add stan.xml (Brian Ward).

0.12.1
* Update syntax definitions: bash, cmake, dockerfile, gnuassembler,
  markdown, spdx-comments.
* Support hex escapes using \x in regex char classes (#135). These occur in
  a number of syntax definitions and weren't correctly interpreted
  before. Thanks to @Agnishom.
* Support regex property syntax, e.g. \p{Lu}.
* Regex: support \B (non-word-boundary).

0.12
* Properly handle include elements in keyword lists (#124). A number of
  syntaxes (e.g. typescript, scala) include keyword lists from other
  syntaxe,s and previously we weren't able to handle this.
* There are several pieces to this change. We need to store lists where
  other Syntaxes can look them up, so we add an sLists field to Syntax [API
  change], and modify the parser to fill this. We change lists so that
  their values are not just a Text, but a ListItem that can either be a
  textual value or an include directive, specifying a ListName (syntax name
  and list name).
* The Keyword constructor for Matcher now takes, instead of a WordSet,
  Either a ListName or a WordSet (API change).
* Skylighting.Parser now exports resolveKeywords (API change), which
  modifies all Keyword matchers in a syntax so that Left values with a
  ListName become Right values with resolved WordSets. The tokenizer
  applies this function automatically to the SyntaxMap given in Config. But
  it is more efficient to do this conversion just once, rather than every
  time tokenize is called. So we have loadSyntaxesFromDir call it on the
  SyntaxMap. With this optimization, there is not an appreciable
  performance cost to the changes described above.
* Skylighting.Regex: Fix bug with regexes like a{10}b (#133). This requires
  exactly 10 a's; previously we interpreted it as "at least 10."
* skylighting-extract: take a directory as argument rather than files. This
  allows us to use loadSyntaxesFromDir.
* Update xml syntax definitions from upstream: julia, cmake, cpp, isocpp,
  markdown, python, toml.

0.11
* Skylighting.Regex: Support regex subroutines (#118). For example, (?1) is
  replaced by the regex in the first capturing group. So far we only
  support this simple, absolute form, not the relative form (?-1) supported
  by some engines (but not used, I think, in KDE's syntax
  highlighters). This change involves an API change: Regex in
  Skylighting.Regex has a new Subroutine constructor, and the Recurse
  constructor has been removed. Instead of Recurse we use Subroutine 0,
  which unifies the code.
* Skylighting.Regex: handle e.g. [\1] and [\123] (without initial 0) as
  octal escapes (#118). These occur in the zsh.xml syntax definition.
* Pull xml definitions for bash, cmake, python, zsh from upstream.
* README: Add a note about pulling syntax definitions from upstream
  (#138). Update build instructions for recent cabal versions (#131).

0.10.5.2
* Added swift grammar definition (Igor Ranieri).
* Simplify README.md instructions for two-step build.
* Fix link to KDE documentation.
  • Loading branch information
depressed-pho committed Feb 12, 2022
1 parent 4f75036 commit 7e5ab18
Show file tree
Hide file tree
Showing 3 changed files with 9 additions and 10 deletions.
5 changes: 2 additions & 3 deletions textproc/hs-skylighting-core/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.4 2022/01/18 02:48:28 pho Exp $
# $NetBSD: Makefile,v 1.5 2022/02/12 07:23:43 pho Exp $

DISTNAME= skylighting-core-0.10.5.1
PKGREVISION= 2
DISTNAME= skylighting-core-0.12.2
CATEGORIES= textproc

MAINTAINER= pho@cielonegro.org
Expand Down
6 changes: 3 additions & 3 deletions textproc/hs-skylighting-core/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# $NetBSD: buildlink3.mk,v 1.4 2022/01/18 02:48:28 pho Exp $
# $NetBSD: buildlink3.mk,v 1.5 2022/02/12 07:23:43 pho Exp $

BUILDLINK_TREE+= hs-skylighting-core

.if !defined(HS_SKYLIGHTING_CORE_BUILDLINK3_MK)
HS_SKYLIGHTING_CORE_BUILDLINK3_MK:=

BUILDLINK_API_DEPENDS.hs-skylighting-core+= hs-skylighting-core>=0.10.5
BUILDLINK_ABI_DEPENDS.hs-skylighting-core+= hs-skylighting-core>=0.10.5.1nb2
BUILDLINK_API_DEPENDS.hs-skylighting-core+= hs-skylighting-core>=0.12.2
BUILDLINK_ABI_DEPENDS.hs-skylighting-core+= hs-skylighting-core>=0.12.2
BUILDLINK_PKGSRCDIR.hs-skylighting-core?= ../../textproc/hs-skylighting-core

.include "../../converters/hs-aeson/buildlink3.mk"
Expand Down
8 changes: 4 additions & 4 deletions textproc/hs-skylighting-core/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.4 2021/10/26 11:22:03 nia Exp $
$NetBSD: distinfo,v 1.5 2022/02/12 07:23:43 pho Exp $

BLAKE2s (skylighting-core-0.10.5.1.tar.gz) = 8d52b470a7881878b5b62e300ae187e5c623e40755a5b93c257e787500bd8ab9
SHA512 (skylighting-core-0.10.5.1.tar.gz) = 587814cc2f94fed64d2be8f8bf404931606b15e0117bc993cfdf8167fdf0e2cbc033abe74ddc4e4abb0439819ac080da98567b7c9deaac649565be7b7d5e6a74
Size (skylighting-core-0.10.5.1.tar.gz) = 712813 bytes
BLAKE2s (skylighting-core-0.12.2.tar.gz) = 2f732ac826551aa001682154af3646e7e239ce0c17a397f6f10ce91b33fc4088
SHA512 (skylighting-core-0.12.2.tar.gz) = e2ee1033c7fa1bd4119540d316b629019e049f62a14afbd9196a080fa6f40bf3b681c65bc2bdae8cefab71f103841fc346d98a63a13640f46278d429c07052f5
Size (skylighting-core-0.12.2.tar.gz) = 762863 bytes

0 comments on commit 7e5ab18

Please sign in to comment.