Skip to content

Commit

Permalink
(textproc/R-xml2) Updated 1.3.2 to 1.3.6
Browse files Browse the repository at this point in the history
# xml2 1.3.6

* Now compatible with libxml2 2.12.0 and later (@KNnut).

* Fixed format string issues detected in R-devel.

* Remove unused dependencies on glue, withr and lifecycle (@mgirlich).

* `print()` is faster for very long `xml_nodeset` inputs (#366, @MichaelChirico).

* `xml_attr()`, `xml_attrs()`, `xml_double()`, `xml_integer()`, `xml_length()`,
  `xml_name()`, `xml_path()`, `xml_text()`, and `xml_type()` no longer use
  S3 dispatch but instead dispatch in C, leading to considerable performance
  improvements in many cases (@mgirlich, #400).

* `xml_find_int()` analogous to `xml_find_num()` for returning integers
  matched by an XPath (#365, @MichaelChirico).

* `xml_serialize()` now includes the document type so that `xml_unserialize()`
  works also for HTML documents (#407, @HenrikBengtsson).

# xml2 1.3.5

* Small speedup for `xml_find_all()` (@mgirlich, #393).

* Fixes for R CMD check problems.

# xml2 1.3.4

* Fixes for R CMD check problems.

* Windows: update to libxml2 2.10.3

# xml2 1.3.3

* Hadley Wickham is now (again) the maintainer.

* xml2 has been re-licensed as MIT (#317).

* `xml_find_all.xml_node()` fails more informatively the `xpath` parameter is the wrong type (@MichaelChirico)

* `xml_find_all.xml_nodeset()` gains a `flatten` argument to control whether to return a single nodeset or a list of nodesets (#311, @jakejh)

* `write_xml()` and `write_html()` now return NULL invisibly, as they did prior to version 1.3.0 (#307)

* `XPtr` gets explicit copy constructor and assignment operator definitions, which were two missing components of the [Rule of three](https://en.wikipedia.org/wiki/Rule_of_three_(C%2B%2B_programming)) (@MichaelChirico)

* Windows: update to libxml2 2.9.10 and libxslt 1.1.34 and add ucrt libs
  • Loading branch information
mef committed Jan 31, 2024
1 parent 30e8736 commit 7d7bac1
Show file tree
Hide file tree
Showing 2 changed files with 19 additions and 7 deletions.
18 changes: 15 additions & 3 deletions textproc/R-xml2/Makefile
Original file line number Diff line number Diff line change
@@ -1,19 +1,31 @@
# $NetBSD: Makefile,v 1.14 2023/11/08 13:21:04 wiz Exp $
# $NetBSD: Makefile,v 1.15 2024/01/31 21:16:04 mef Exp $

R_PKGNAME= xml2
R_PKGVER= 1.3.2
PKGREVISION= 6
R_PKGVER= 1.3.6
CATEGORIES= textproc

MAINTAINER= pkgsrc-users@NetBSD.org
COMMENT= Parse XML
LICENSE= gnu-gpl-v2 OR gnu-gpl-v3

DEPENDS+= R-cli-[0-9]*:../../devel/R-cli
DEPENDS+= R-rlang-[0-9]*:../../devel/R-rlang

TEST_DEPENDS+= R-covr-[0-9]*:../../devel/R-covr
TEST_DEPENDS+= R-curl-[0-9]*:../../www/R-curl
TEST_DEPENDS+= R-httr-[0-9]*:../../www/R-httr
TEST_DEPENDS+= R-knitr-[0-9]*:../../print/R-knitr
TEST_DEPENDS+= R-mockery-[0-9]*:../../devel/R-mockery
TEST_DEPENDS+= R-rmarkdown-[0-9]*:../../textproc/R-rmarkdown
TEST_DEPENDS+= R-testthat-[0-9]*:../../devel/R-testthat


TEST_DEPENDS+= tex-ec-[0-9]*:../../fonts/tex-ec
TEST_DEPENDS+= tex-inconsolata-[0-9]*:../../fonts/tex-inconsolata
TEST_DEPENDS+= tex-latex-bin-[0-9]*:../../print/tex-latex-bin
TEST_DEPENDS+= tex-xkeyval-[0-9]*:../../print/tex-xkeyval
TEST_DEPENDS+= tex-url-[0-9]*:../../print/tex-url

USE_TOOLS+= perl
USE_LANGUAGES= c c++

Expand Down
8 changes: 4 additions & 4 deletions textproc/R-xml2/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.4 2021/10/26 11:21:33 nia Exp $
$NetBSD: distinfo,v 1.5 2024/01/31 21:16:04 mef Exp $

BLAKE2s (R/xml2_1.3.2.tar.gz) = 047368b73b2ba414af5f97c44dc231e11ad411617b23502667084eb7ad8c8b2f
SHA512 (R/xml2_1.3.2.tar.gz) = f74ceed824c71870bdf9c9a77818a4abf508d084fca49f570c1028fc74b90a23e59e4cab37649138536341e94b06d01d1e3be6341d8de017e10951e58aea174b
Size (R/xml2_1.3.2.tar.gz) = 271876 bytes
BLAKE2s (R/xml2_1.3.6.tar.gz) = 43251c0661c9222bde6c66f1ea1b62eb31ebf9cecdcd3a9fb5d16c86ff75c7ec
SHA512 (R/xml2_1.3.6.tar.gz) = 07da83a92c18a3dd61fc14bc9219b7f0352cc2960ee4f20418683d9248442d1f77ceb1cea51f366ca83ba501caf8741faac7ca29b132cf4cf0153b166cc815aa
Size (R/xml2_1.3.6.tar.gz) = 294715 bytes

0 comments on commit 7d7bac1

Please sign in to comment.