Skip to content

Commit

Permalink
(devel/R-evaluate) Updated 0.23 to 1.0.1
Browse files Browse the repository at this point in the history
# evaluate 1.0.1

* Fix buglet revealed when by using `rlang::abort()` inside of `evaluate()`.

# evaluate 1.0.0

* Setting `ACTIONS_STEP_DEBUG=1` (as in a failing GHA workflow) will
  automatically set `log_echo` and `log_warning` to `TRUE` (#175).

* evaluate works on R 3.6.0 once again.

* `evaluate()` improvements:

  * Now terminates on the first error in a multi-expression input, i.e.
    `1;stop('2');3` will no longer evaluate the third component. This
    matches console behaviour more closely.

  * Calls from conditions emitted by top-level code are automatically stripped
    (#150).

  * Result has a class (`evaluate_evaluation`/`list`) with a basic print method.

  * Plots created before messages/warnings/errors are correctly captured (#28).

* Handler improvements:

  * The default `value` handler now evaluates `print()` in a child of the
    evaluation environment. This largely makes evaluate easier to test, but
    should make defining S3 methods for print a little easier (#192).

  * The `source` output handler is now passed the entire complete input
    expression, not just the first component.

* `evalute(include_timing)` has been deprecated. I can't find any use of it on
  GitHub, and it adds substantial code complexity for little gain.

* `is.value()` has been removed since it tests for an object that evaluate
  never creates.

* New `local_reproducible_output()` helper that sets various options and env
  vars to help ensure consistency of output across environments.

* `parse_all()` adds a `\n` to the end of every line, even the last one if it
  didn't have one in the input. Additionally, it no longer has a default
  method, which will generate better errors if you pass in something unexpected.

* New `trim_intermediate_plots()` drops intermediate plots to reveal the
  complete/final plot (#206).

* `watchout()` is no longer exported; it's really an implementation detail that
  should never have been leaked to the public interface.

# evaluate 0.24.0

* The `source` output handler can now take two arguments (the unparsed `src`
  and the parsed `call`) and choose to affect the displayed source.
* The package now depends on R 4.0.0 in order to decrease our maintenance burden.
  • Loading branch information
mef committed Oct 18, 2024
1 parent 4e37289 commit 6d6c099
Show file tree
Hide file tree
Showing 2 changed files with 6 additions and 6 deletions.
4 changes: 2 additions & 2 deletions devel/R-evaluate/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.12 2024/01/20 06:21:37 mef Exp $
# $NetBSD: Makefile,v 1.13 2024/10/18 12:22:13 mef Exp $

R_PKGNAME= evaluate
R_PKGVER= 0.23
R_PKGVER= 1.0.1
CATEGORIES= devel

MAINTAINER= pkgsrc-users@NetBSD.org
Expand Down
8 changes: 4 additions & 4 deletions devel/R-evaluate/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.13 2024/01/20 06:21:37 mef Exp $
$NetBSD: distinfo,v 1.14 2024/10/18 12:22:13 mef Exp $

BLAKE2s (R/evaluate_0.23.tar.gz) = 57bc914a0bd480b527a28d42cc998eec6f29c14adb38dc9aafa5cc1ae8aeb69e
SHA512 (R/evaluate_0.23.tar.gz) = d08dabbb8d485e3e680d2746732550b9cd622826194e998a913c645dbfcf5910a2085d8faba93d720887cb6caa832f8adcb3102c0db08fcdaf1f14ebcacd3316
Size (R/evaluate_0.23.tar.gz) = 28346 bytes
BLAKE2s (R/evaluate_1.0.1.tar.gz) = d527d2840d6101f6584a6006eef69745c94b65fbc0d5c0a89dbbf81bcfb3e598
SHA512 (R/evaluate_1.0.1.tar.gz) = 403edacde1df1a673ab1b65f820f8cd750a6f82eae285e61fbba132714f4f3797f1928b2e7b7104c76149c5c929c895f8b7905c5e4d39b391f4ec757d5799d86
Size (R/evaluate_1.0.1.tar.gz) = 34873 bytes

0 comments on commit 6d6c099

Please sign in to comment.