Skip to content

Commit

Permalink
textproc/hs-skylighting-core: Update to 0.14
Browse files Browse the repository at this point in the history
0.14
* Add rWeakDeliminators field to Rule. [API change]
* Make WordDetect sensitive to weakDeliminator. This fixes parsing of
  floats beginning with '0.' in C (#174).
* Add debiancontrol syntax (#173).

0.13.4.1
* Update syntax definitions: ada, bash, cmake, css, html, isocpp, java,
  javascript, kotlin, latex, makefile, markdown, php, python, qml, r, sass,
  scss, typescript, zsh.
* Don't require word boundary at end of Int, Float, HlCHex, HlCOct
  (#170). KDE does not. This fixes things like 7L in R.

0.13.4
* Add dosbat syntax (MS DOS batch file) (#169).
* Derive Bounded Instance for TokenType (#168, Pavan Pikhi). Add Bounded to
  the derived instances for the TokenType type. This allows consumers to
  use [minBound .. maxBound] to generate a list of all token types when
  writing a Style.
* Require xml-conduit >= 1.9.1.3. This fixes a bug that prevents parsing
  certain DOCTYPE declarations, e.g. in agda.xml.
* Updated cmake syntax definition.

0.13.3
* Add gap language (#167).
* Update syntax definitions.
* Add patches for agda.xml and dtd.xml, to wor around a bug in xml-conduit:
  snoyberg/xml#187
* Store compiled regexes in RE (#166, Jonathan Coates). This changes the RE
  type to (lazily) compile the regex when constructed, rather than in the
  tokenizer. This allows us to avoid re-compiling regexes for each separate
  tokenize call, instead sharing them globally. We try to hide the
  internals of this, exposing the previous interface (RE { reString,
  reCaseSensitive }) with pattern synonyms.
* ConTeXt: fix handling of spaces in non-normal tokens (Albert
  Krewinkel). This ensures that multiple spaces won't be collapsed into a
  single space.

0.13.2.1
* Update tango style for new token types (#164). The original tango style
  didn't have colors defined for many token types that have been added
  since it was added. This commit updates the style to support them. Thanks
  to @danbraswell for providing the values needed.
  • Loading branch information
depressed-pho committed Oct 30, 2023
1 parent 78b39d1 commit 3c58404
Show file tree
Hide file tree
Showing 4 changed files with 16 additions and 12 deletions.
7 changes: 4 additions & 3 deletions textproc/hs-skylighting-core/Makefile
Original file line number Diff line number Diff line change
@@ -1,13 +1,14 @@
# $NetBSD: Makefile,v 1.13 2023/10/09 04:54:54 pho Exp $
# $NetBSD: Makefile,v 1.14 2023/10/30 12:59:07 pho Exp $

DISTNAME= skylighting-core-0.13.2
PKGREVISION= 2
DISTNAME= skylighting-core-0.14
CATEGORIES= textproc

MAINTAINER= pho@cielonegro.org
COMMENT= Syntax highlighting library core
LICENSE= modified-bsd

CONFIGURE_ARGS+= -fexecutable

.include "../../converters/hs-aeson/buildlink3.mk"
.include "../../textproc/hs-attoparsec/buildlink3.mk"
.include "../../converters/hs-base64-bytestring/buildlink3.mk"
Expand Down
7 changes: 5 additions & 2 deletions textproc/hs-skylighting-core/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
@comment $NetBSD: PLIST,v 1.3 2023/01/27 14:44:11 pho Exp $
@comment $NetBSD: PLIST,v 1.4 2023/10/30 12:59:07 pho Exp $
bin/skylighting-extract
lib/skylighting-core-${PKGVERSION}/${HS_VERSION}/package-description
lib/skylighting-core-${PKGVERSION}/${HS_VERSION}/package-id
${PLIST.shlibs}lib/${HS_PLATFORM}/libHS${HS_PKGID}-${HS_VER}.so
Expand Down Expand Up @@ -37,7 +38,7 @@ lib/${HS_PLATFORM}/${HS_PKGID}/Skylighting/Types.hi
${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/Skylighting/Types.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/libHS${HS_PKGID}.a
${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/libHS${HS_PKGID}_p.a
${PLIST.doc}share/doc/${HS_PLATFORM}/skylighting-core-${PKGVERSION}/LICENSE
share/doc/${HS_PLATFORM}/skylighting-core-${PKGVERSION}/LICENSE
${PLIST.doc}share/doc/${HS_PLATFORM}/skylighting-core-${PKGVERSION}/html/Skylighting-Core.html
${PLIST.doc}share/doc/${HS_PLATFORM}/skylighting-core-${PKGVERSION}/html/Skylighting-Loader.html
${PLIST.doc}share/doc/${HS_PLATFORM}/skylighting-core-${PKGVERSION}/html/Skylighting-Parser.html
Expand Down Expand Up @@ -67,10 +68,12 @@ ${PLIST.doc}share/doc/${HS_PLATFORM}/skylighting-core-${PKGVERSION}/html/doc-ind
${PLIST.doc}share/doc/${HS_PLATFORM}/skylighting-core-${PKGVERSION}/html/doc-index-W.html
${PLIST.doc}share/doc/${HS_PLATFORM}/skylighting-core-${PKGVERSION}/html/doc-index-Z.html
${PLIST.doc}share/doc/${HS_PLATFORM}/skylighting-core-${PKGVERSION}/html/doc-index.html
${PLIST.doc}share/doc/${HS_PLATFORM}/skylighting-core-${PKGVERSION}/html/doc-index.json
${PLIST.doc}share/doc/${HS_PLATFORM}/skylighting-core-${PKGVERSION}/html/haddock-bundle.min.js
${PLIST.doc}share/doc/${HS_PLATFORM}/skylighting-core-${PKGVERSION}/html/index.html
${PLIST.doc}share/doc/${HS_PLATFORM}/skylighting-core-${PKGVERSION}/html/linuwial.css
${PLIST.doc}share/doc/${HS_PLATFORM}/skylighting-core-${PKGVERSION}/html/meta.json
${PLIST.doc}share/doc/${HS_PLATFORM}/skylighting-core-${PKGVERSION}/html/quick-jump.css
${PLIST.doc}share/doc/${HS_PLATFORM}/skylighting-core-${PKGVERSION}/html/quick-jump.min.js
${PLIST.doc}share/doc/${HS_PLATFORM}/skylighting-core-${PKGVERSION}/html/skylighting-core.haddock
${PLIST.doc}share/doc/${HS_PLATFORM}/skylighting-core-${PKGVERSION}/html/synopsis.png
6 changes: 3 additions & 3 deletions textproc/hs-skylighting-core/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# $NetBSD: buildlink3.mk,v 1.13 2023/10/09 04:54:54 pho Exp $
# $NetBSD: buildlink3.mk,v 1.14 2023/10/30 12:59:07 pho Exp $

BUILDLINK_TREE+= hs-skylighting-core

.if !defined(HS_SKYLIGHTING_CORE_BUILDLINK3_MK)
HS_SKYLIGHTING_CORE_BUILDLINK3_MK:=

BUILDLINK_API_DEPENDS.hs-skylighting-core+= hs-skylighting-core>=0.13.2
BUILDLINK_ABI_DEPENDS.hs-skylighting-core+= hs-skylighting-core>=0.13.2nb2
BUILDLINK_API_DEPENDS.hs-skylighting-core+= hs-skylighting-core>=0.14
BUILDLINK_ABI_DEPENDS.hs-skylighting-core+= hs-skylighting-core>=0.14
BUILDLINK_PKGSRCDIR.hs-skylighting-core?= ../../textproc/hs-skylighting-core

.include "../../converters/hs-aeson/buildlink3.mk"
Expand Down
8 changes: 4 additions & 4 deletions textproc/hs-skylighting-core/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.6 2023/01/27 14:44:11 pho Exp $
$NetBSD: distinfo,v 1.7 2023/10/30 12:59:07 pho Exp $

BLAKE2s (skylighting-core-0.13.2.tar.gz) = f535b9c1834e55d48d95fc5fe15d6d3763a5b487f0acd004de379361fd739efa
SHA512 (skylighting-core-0.13.2.tar.gz) = 35cbb8f7bd7382d66b9618baecc0acf7d3f2cbb280df94a0a3c23b92372f0b5ecf0d2c87fe76be2d12feb3f7c84a73f01b5646579c523ca1edbe87b855695302
Size (skylighting-core-0.13.2.tar.gz) = 806784 bytes
BLAKE2s (skylighting-core-0.14.tar.gz) = 0c6afd047041b00748a79494e005e91ae55aad93fc710e29804c2b9207a94d69
SHA512 (skylighting-core-0.14.tar.gz) = 7b1ae0160c656eb38b765b9d545b065aaa07bf02acddbf74bdff42914d74b07e556df7f33e67557870d4582a0f9e871b6f4ffad4cb17082ad91bb64e89569753
Size (skylighting-core-0.14.tar.gz) = 864021 bytes

0 comments on commit 3c58404

Please sign in to comment.