Skip to content

Commit

Permalink
devel/git-cliff: update to 1.2.0
Browse files Browse the repository at this point in the history
[1.2.0] - 2023-04-28

Read detailed information about this release:
https://git-cliff.org/blog/git-cliff-1.2.0

Features
    (args) Update clap and clap extras to v4 (#137)
    (commit) Make the fields of Signature public
    (config) Add a custom configuration file for the repository
    (config) Support placing configuration inside pyproject.toml (#147)
    (docker) Generate SBOM/provenance for the Docker image
    (parser) Support using regex group values (#145)

Bug Fixes
    (ci) Use MUSL build of cargo-tarpaulin
    (ci) Update cargo-tarpaulin installation command for CI
    (config) [breaking] Nested environment config overrides (#157)
    (config) Set max of limit_commits to the number of commits (#140)
    (deploy) Set the node cache dependency path
    (docker) Remove target directory from .dockerignore
    (release) Use the correct argument in release script
    (website) Fix broken links

Refactor
    (cd) Remove unnecessary config update
    (ci) Test the website deployment with a different job
    (lib) [breaking] Move changelog module to git-cliff-core
    (test) Handle errors for changelog module tests
    (website) Update header location

Documentation
    (blog) Add blog post about what's new in 1.2.0
    (blog) Update the blog post style
    (config) Update the sections
    (config) Add comments to the default configuration file
    (contributing) Mention the nightly requirement for rustfmt
    (contributing) Update MSRV
    (examples) Move examples to separate file
    (github) Update the pull request template about GitHub labels
    (github) Update pull request template
    (github) Update issue templates
    (github) Update funding options
    (github) Add security policy
    (readme) Update README.md about documentation website
    (readme) Add tj-actions/git-cliff to the list of actions (#152)
    (readme) Add discord badge
    (readme) Add release-plz to related projects (#151)
    (readme) Fix typos in README.md
    (readme) Remove unneeded word in README.md (#141)
    (readme) Add link to the Console #141 interview about git-cliff
    (website) Add Twitter link to banner
    (website) Move documentation to the website (#153)

Styling
    (docs) Fix the grammar for tj-actions
    (docs) Update the formatting for python integration example
    (readme) Update the style for project name
    (readme) Apply formatting
    (website) Update the style for environment variable section

Testing
    (deploy) Test the website deployment for pull requests

Miscellaneous Tasks
    (cargo) Update MSRV to 1.64.0
    (cd) Temporarily switch back to action-rs/toolchain
    (ci) Switch to dtolnay/rust-toolchain action
    (ci) Update runner images
    (deps) Bump actions/configure-pages from 1 to 3
    (deps) Bump actions/deploy-pages from 1 to 2
    (deps) Upgrade transitive dependencies
    (deps) Update clap dependencies
    (deps) Upgrade workspace dependencies
    (deps) Upgrade core dependencies
    (docker) Update versions in Dockerfile
    (docker) Bump the action versions in docker workflow
    (docker) Bump build-push-action to v4
    (editorconfig) Fix editorconfig syntax
    (editorconfig) Update editorconfig for better code readability
    (examples) Remove EXAMPLES.md
    (github) Integrate Dependabot
    (github) Integrate bors
    (github) Add contact links for issues
    (website) Add workflow file for deploying the website
    (website) Move website to website folder
    (website) Move website to docs for GitHub pages deployment
  • Loading branch information
0323pin committed Apr 30, 2023
1 parent fe589cb commit 0cff730
Show file tree
Hide file tree
Showing 5 changed files with 83 additions and 1,163 deletions.
5 changes: 2 additions & 3 deletions devel/git-cliff/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.25 2023/04/27 12:32:36 pin Exp $
# $NetBSD: Makefile,v 1.26 2023/04/30 19:53:24 pin Exp $

DISTNAME= git-cliff-1.1.2
PKGREVISION= 1
DISTNAME= git-cliff-1.2.0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GITHUB:=orhun/}
GITHUB_TAG= v${PKGVERSION_NOREV}
Expand Down
31 changes: 20 additions & 11 deletions devel/git-cliff/cargo-depends.mk
Original file line number Diff line number Diff line change
@@ -1,9 +1,14 @@
# $NetBSD: cargo-depends.mk,v 1.21 2023/04/27 12:32:36 pin Exp $
# $NetBSD: cargo-depends.mk,v 1.22 2023/04/30 19:53:24 pin Exp $

CARGO_CRATE_DEPENDS+= adler-1.0.2
CARGO_CRATE_DEPENDS+= aho-corasick-0.7.20
CARGO_CRATE_DEPENDS+= aho-corasick-1.0.1
CARGO_CRATE_DEPENDS+= android_system_properties-0.1.5
CARGO_CRATE_DEPENDS+= anstream-0.3.1
CARGO_CRATE_DEPENDS+= anstyle-1.0.0
CARGO_CRATE_DEPENDS+= anstyle-parse-0.2.0
CARGO_CRATE_DEPENDS+= anstyle-query-1.0.0
CARGO_CRATE_DEPENDS+= anstyle-wincon-1.0.1
CARGO_CRATE_DEPENDS+= async-trait-0.1.68
CARGO_CRATE_DEPENDS+= atty-0.2.14
CARGO_CRATE_DEPENDS+= autocfg-1.1.0
Expand All @@ -17,12 +22,14 @@ CARGO_CRATE_DEPENDS+= cfg-if-1.0.0
CARGO_CRATE_DEPENDS+= chrono-0.4.24
CARGO_CRATE_DEPENDS+= chrono-tz-0.6.1
CARGO_CRATE_DEPENDS+= chrono-tz-build-0.0.2
CARGO_CRATE_DEPENDS+= clap-3.2.24
CARGO_CRATE_DEPENDS+= clap_complete-3.2.5
CARGO_CRATE_DEPENDS+= clap_derive-3.2.24
CARGO_CRATE_DEPENDS+= clap_lex-0.2.4
CARGO_CRATE_DEPENDS+= clap_mangen-0.1.11
CARGO_CRATE_DEPENDS+= clap-4.2.5
CARGO_CRATE_DEPENDS+= clap_builder-4.2.5
CARGO_CRATE_DEPENDS+= clap_complete-4.2.1
CARGO_CRATE_DEPENDS+= clap_derive-4.2.0
CARGO_CRATE_DEPENDS+= clap_lex-0.4.1
CARGO_CRATE_DEPENDS+= clap_mangen-0.2.10
CARGO_CRATE_DEPENDS+= codespan-reporting-0.11.1
CARGO_CRATE_DEPENDS+= colorchoice-1.0.0
CARGO_CRATE_DEPENDS+= config-0.13.3
CARGO_CRATE_DEPENDS+= core-foundation-sys-0.8.4
CARGO_CRATE_DEPENDS+= cpufeatures-0.2.7
Expand Down Expand Up @@ -66,6 +73,7 @@ CARGO_CRATE_DEPENDS+= idna-0.3.0
CARGO_CRATE_DEPENDS+= ignore-0.4.20
CARGO_CRATE_DEPENDS+= indexmap-1.9.3
CARGO_CRATE_DEPENDS+= io-lifetimes-1.0.10
CARGO_CRATE_DEPENDS+= is-terminal-0.4.7
CARGO_CRATE_DEPENDS+= itoa-1.0.6
CARGO_CRATE_DEPENDS+= jobserver-0.1.26
CARGO_CRATE_DEPENDS+= js-sys-0.3.61
Expand All @@ -78,7 +86,7 @@ CARGO_CRATE_DEPENDS+= libm-0.2.6
CARGO_CRATE_DEPENDS+= libz-sys-1.1.8
CARGO_CRATE_DEPENDS+= link-cplusplus-1.0.8
CARGO_CRATE_DEPENDS+= linked-hash-map-0.5.6
CARGO_CRATE_DEPENDS+= linux-raw-sys-0.3.4
CARGO_CRATE_DEPENDS+= linux-raw-sys-0.3.5
CARGO_CRATE_DEPENDS+= log-0.4.17
CARGO_CRATE_DEPENDS+= memchr-2.5.0
CARGO_CRATE_DEPENDS+= minimal-lexical-0.2.1
Expand All @@ -87,7 +95,6 @@ CARGO_CRATE_DEPENDS+= nom-7.1.3
CARGO_CRATE_DEPENDS+= num-integer-0.1.45
CARGO_CRATE_DEPENDS+= num-traits-0.2.15
CARGO_CRATE_DEPENDS+= once_cell-1.17.1
CARGO_CRATE_DEPENDS+= os_str_bytes-6.5.0
CARGO_CRATE_DEPENDS+= output_vt100-0.1.3
CARGO_CRATE_DEPENDS+= parse-zoneinfo-0.3.0
CARGO_CRATE_DEPENDS+= pathdiff-0.2.1
Expand All @@ -104,8 +111,6 @@ CARGO_CRATE_DEPENDS+= pkg-config-0.3.26
CARGO_CRATE_DEPENDS+= ppv-lite86-0.2.17
CARGO_CRATE_DEPENDS+= pretty_assertions-1.3.0
CARGO_CRATE_DEPENDS+= pretty_env_logger-0.4.0
CARGO_CRATE_DEPENDS+= proc-macro-error-1.0.4
CARGO_CRATE_DEPENDS+= proc-macro-error-attr-1.0.4
CARGO_CRATE_DEPENDS+= proc-macro2-1.0.56
CARGO_CRATE_DEPENDS+= quick-error-1.2.3
CARGO_CRATE_DEPENDS+= quote-1.0.26
Expand All @@ -132,6 +137,7 @@ CARGO_CRATE_DEPENDS+= serde-1.0.160
CARGO_CRATE_DEPENDS+= serde_derive-1.0.160
CARGO_CRATE_DEPENDS+= serde_json-1.0.96
CARGO_CRATE_DEPENDS+= serde_regex-1.1.0
CARGO_CRATE_DEPENDS+= serde_spanned-0.6.1
CARGO_CRATE_DEPENDS+= sha2-0.10.6
CARGO_CRATE_DEPENDS+= siphasher-0.3.10
CARGO_CRATE_DEPENDS+= slug-0.1.4
Expand All @@ -142,13 +148,15 @@ CARGO_CRATE_DEPENDS+= syn-2.0.15
CARGO_CRATE_DEPENDS+= tera-1.18.1
CARGO_CRATE_DEPENDS+= termcolor-1.2.0
CARGO_CRATE_DEPENDS+= terminal_size-0.2.6
CARGO_CRATE_DEPENDS+= textwrap-0.16.0
CARGO_CRATE_DEPENDS+= thiserror-1.0.40
CARGO_CRATE_DEPENDS+= thiserror-impl-1.0.40
CARGO_CRATE_DEPENDS+= thread_local-1.1.4
CARGO_CRATE_DEPENDS+= tinyvec-1.6.0
CARGO_CRATE_DEPENDS+= tinyvec_macros-0.1.1
CARGO_CRATE_DEPENDS+= toml-0.5.11
CARGO_CRATE_DEPENDS+= toml-0.7.3
CARGO_CRATE_DEPENDS+= toml_datetime-0.6.1
CARGO_CRATE_DEPENDS+= toml_edit-0.19.8
CARGO_CRATE_DEPENDS+= typenum-1.16.0
CARGO_CRATE_DEPENDS+= ucd-trie-0.1.5
CARGO_CRATE_DEPENDS+= uncased-0.9.7
Expand All @@ -167,6 +175,7 @@ CARGO_CRATE_DEPENDS+= untrusted-0.7.1
CARGO_CRATE_DEPENDS+= update-informer-0.6.0
CARGO_CRATE_DEPENDS+= ureq-2.6.2
CARGO_CRATE_DEPENDS+= url-2.3.1
CARGO_CRATE_DEPENDS+= utf8parse-0.2.1
CARGO_CRATE_DEPENDS+= vcpkg-0.2.15
CARGO_CRATE_DEPENDS+= version_check-0.9.4
CARGO_CRATE_DEPENDS+= walkdir-2.3.3
Expand Down
Loading

0 comments on commit 0cff730

Please sign in to comment.