Skip to content

Commit

Permalink
Update to 14.0.4
Browse files Browse the repository at this point in the history
Changelog:
Changes
    Allow overwrite.cli.url without trailing slash (server#11772)
    Remove duplicate call to decodeURIComponent (server#11781)
    Check for empty string (server#11783)
    Add "Referrer-Policy" to htaccess file, addresses issue #11099 (server#11798)
    Always query the lookup server in a global scale setup (server#11800)
    Fix a case where "password_by_talk" was not a boolean (server#11851)
    Add .l10nignore files for compiled assets (server#11925)
    Properly escape column name in "createFunction" call (server#11929)
    Allow userId to be null (server#11939)
    Allow "same-origin" as "Referrer-Policy" (Backport to stable14) (server#11950)
    Do not emit preHooks twice on non-part-storage (server#11961)
    Filter null values for UserManager::getByEmail (server#11976)
    Allow local delivery of schedule message while prohibiting FreeBusy requests (server#11979)
    Load apps/APP/l10n/*.js and themes/THEME/apps/APP/l10n/*.js (server#11990)
    Lazy open first source stream in assemblystream (server#11994)
    Fix opening a section again in the Files app (server#11995)
    Remove cookies from Clear-Site-Data Header (server#12005)
    Forwarded ExpiredTokenException (server#12032)
    Allow chunked uploads even if your quota is not sufficient (server#12040)
    Improve encrypt all / decrypt all (server#12045)
    Double check for failed cache with a shared storage (server#12108)
    Implement the size of an assembly stream (server#12111)
    Bring the browser window of an actor to the foreground when acting as him (server#12120)
    Move acceptance tests that crash the PHP built-in server to Apache (server#12121)
    Remove unneeded empty search attribute values, fixes #12086 (server#12122)
    Fixes wrong variable usage (server#12137)
    LDAP: announce display name changes so that addressbook picks it up (server#12141)
    Bruteforce protection handling in combination with (server#12160)
    Add global site selector as user back-end which doesn't support password confirmation (server#12184)
    Do not set indeterminate state for file shares (server#12187)
    Revert "Wait for cron to finish before running upgrade command" (server#12197)
    Fix bug #12151: fix list formatting by correcting malformed html (server#12202)
    A folder should get a folder mimetype (server#12297)
    Use the proper server for the apptoken flow login (server#12299)
    Do not log FileLock as exception (server#12300)
    Set the filemodel before rending the detailsview (server#12301)
    Disabled ldap fix (server#12331)
    Fix - Add to favorites not working in IE11 (server#12339)
    Remove arrow function for ie compatibility (server#12341)
    Fix default types of activity event member variables (server#12353)
    Suppress wrong audit log messages about failed login attempts (server#12372)
    Add fix for IE11 flexbox height bug (server#12374)
    Properly search the root of a shared external storage (server#12375)
    Fix app update available check (server#12412)
    Use nextcloud-password-confirmation (server#12416)
    Fix IE rule for min width (server#12431)
    Added cache override to ensure an always up-to-date accessibility css (server#12432)
    Unique contraint and deadlock fixes for filecache and file_locks (server#12433)
    Fix app menu calculation for random size of the right header (server#12440)
    Fix missing quickaccess favorite folder on add (server#12441)
    Fixes dav share issue with owner (server#12459)
    Fix wrong share popover opening on share link (server#12482)
    Only use width and opacity for transition (server#12492)
    Forward object not found error in swift as dav 404 (server#12502)
    Fix the warning appearing in the admin section when mail_smtpmode is not configured (server#12529)
    Remove unused svg api route (server#12542)
    Bearer tokens are app token (server#12545)
    Handle permission in update of share better (server#12561)
    Correctly restrict affected users when using command to send emails (activity#312)
    Improve code blocks in markdown rendering (files_texteditor#121)
    Properly escape column name in "createFunction" call (survey_client#85)
  • Loading branch information
ryoon committed Dec 1, 2018
1 parent c6250a4 commit 0705704
Show file tree
Hide file tree
Showing 3 changed files with 20 additions and 14 deletions.
4 changes: 2 additions & 2 deletions www/php-nextcloud/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.17 2018/11/22 12:28:11 ryoon Exp $
# $NetBSD: Makefile,v 1.18 2018/12/01 09:53:27 ryoon Exp $
#

DISTNAME= nextcloud-14.0.3
DISTNAME= nextcloud-14.0.4
PKGNAME= ${PHP_PKG_PREFIX}-${DISTNAME}
CATEGORIES= www
MASTER_SITES= https://download.nextcloud.com/server/releases/
Expand Down
20 changes: 13 additions & 7 deletions www/php-nextcloud/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.14 2018/11/22 12:28:11 ryoon Exp $
@comment $NetBSD: PLIST,v 1.15 2018/12/01 09:53:27 ryoon Exp $
share/nextcloud/.htaccess
share/nextcloud/.user.ini
share/nextcloud/3rdparty/.drone.yml
Expand Down Expand Up @@ -4057,6 +4057,7 @@ share/nextcloud/apps/cloud_federation_api/lib/Capabilities.php
share/nextcloud/apps/cloud_federation_api/lib/Config.php
share/nextcloud/apps/cloud_federation_api/lib/Controller/RequestHandlerController.php
share/nextcloud/apps/comments/.bowerrc
share/nextcloud/apps/comments/.l10nignore
share/nextcloud/apps/comments/appinfo/app.php
share/nextcloud/apps/comments/appinfo/info.xml
share/nextcloud/apps/comments/appinfo/routes.php
Expand Down Expand Up @@ -4479,6 +4480,7 @@ share/nextcloud/apps/dav/lib/CalDAV/CalendarManager.php
share/nextcloud/apps/dav/lib/CalDAV/CalendarObject.php
share/nextcloud/apps/dav/lib/CalDAV/CalendarRoot.php
share/nextcloud/apps/dav/lib/CalDAV/InvitationResponse/InvitationResponseServer.php
share/nextcloud/apps/dav/lib/CalDAV/Outbox.php
share/nextcloud/apps/dav/lib/CalDAV/Plugin.php
share/nextcloud/apps/dav/lib/CalDAV/Principal/Collection.php
share/nextcloud/apps/dav/lib/CalDAV/Principal/User.php
Expand Down Expand Up @@ -5198,6 +5200,7 @@ share/nextcloud/apps/federation/lib/SyncFederationAddressBooks.php
share/nextcloud/apps/federation/lib/SyncJob.php
share/nextcloud/apps/federation/lib/TrustedServers.php
share/nextcloud/apps/federation/templates/settings-admin.php
share/nextcloud/apps/files/.l10nignore
share/nextcloud/apps/files/ajax/download.php
share/nextcloud/apps/files/ajax/list.php
share/nextcloud/apps/files/appinfo/app.php
Expand Down Expand Up @@ -6979,8 +6982,6 @@ share/nextcloud/apps/files_texteditor/js/sidebarpreview.js
share/nextcloud/apps/files_texteditor/l10n/.gitkeep
share/nextcloud/apps/files_texteditor/l10n/ast.js
share/nextcloud/apps/files_texteditor/l10n/ast.json
share/nextcloud/apps/files_texteditor/l10n/az.js
share/nextcloud/apps/files_texteditor/l10n/az.json
share/nextcloud/apps/files_texteditor/l10n/bg.js
share/nextcloud/apps/files_texteditor/l10n/bg.json
share/nextcloud/apps/files_texteditor/l10n/ca.js
Expand Down Expand Up @@ -7356,6 +7357,7 @@ share/nextcloud/apps/files_trashbin/lib/Storage.php
share/nextcloud/apps/files_trashbin/lib/Trashbin.php
share/nextcloud/apps/files_trashbin/list.php
share/nextcloud/apps/files_trashbin/templates/index.php
share/nextcloud/apps/files_versions/.l10nignore
share/nextcloud/apps/files_versions/ajax/getVersions.php
share/nextcloud/apps/files_versions/ajax/rollbackVersion.php
share/nextcloud/apps/files_versions/appinfo/app.php
Expand Down Expand Up @@ -8406,6 +8408,7 @@ share/nextcloud/apps/nextcloud_announcements/lib/Notification/Notifier.php
share/nextcloud/apps/nextcloud_announcements/lib/Settings/Admin.php
share/nextcloud/apps/nextcloud_announcements/templates/admin.php
share/nextcloud/apps/notifications/.babelrc.js
share/nextcloud/apps/notifications/.l10nignore
share/nextcloud/apps/notifications/COPYING
share/nextcloud/apps/notifications/appinfo/app.php
share/nextcloud/apps/notifications/appinfo/database.xml
Expand Down Expand Up @@ -8568,6 +8571,7 @@ share/nextcloud/apps/notifications/lib/Exceptions/NotificationNotFoundException.
share/nextcloud/apps/notifications/lib/Handler.php
share/nextcloud/apps/notifications/lib/Notifier/AdminNotifications.php
share/nextcloud/apps/notifications/lib/Push.php
share/nextcloud/apps/oauth2/.l10nignore
share/nextcloud/apps/oauth2/appinfo/database.xml
share/nextcloud/apps/oauth2/appinfo/info.xml
share/nextcloud/apps/oauth2/appinfo/routes.php
Expand Down Expand Up @@ -9259,7 +9263,7 @@ share/nextcloud/apps/support/lib/Sections/ServerSection.php
share/nextcloud/apps/support/lib/Service/SubscriptionService.php
share/nextcloud/apps/support/lib/Settings/Admin.php
share/nextcloud/apps/support/lib/Settings/Section.php
share/nextcloud/apps/support/resources/Why the Nextcloud Subscription?.pdf
share/nextcloud/apps/support/resources/Why the Nextcloud Subscription.pdf
share/nextcloud/apps/support/templates/admin.php
share/nextcloud/apps/survey_client/COPYING
share/nextcloud/apps/survey_client/ISSUE_TEMPLATE.md
Expand Down Expand Up @@ -9899,6 +9903,7 @@ share/nextcloud/apps/twofactor_backupcodes/lib/Service/BackupCodeStorage.php
share/nextcloud/apps/twofactor_backupcodes/lib/Settings/Personal.php
share/nextcloud/apps/twofactor_backupcodes/templates/challenge.php
share/nextcloud/apps/twofactor_backupcodes/templates/personal.php
share/nextcloud/apps/updatenotification/.l10nignore
share/nextcloud/apps/updatenotification/appinfo/app.php
share/nextcloud/apps/updatenotification/appinfo/info.xml
share/nextcloud/apps/updatenotification/appinfo/routes.php
Expand Down Expand Up @@ -10637,6 +10642,7 @@ share/nextcloud/apps/workflowengine/templates/admin.php
share/nextcloud/config/.htaccess
share/nextcloud/config/config.sample.php
share/nextcloud/console.php
share/nextcloud/core/.l10nignore
share/nextcloud/core/Application.php
share/nextcloud/core/BackgroundJobs/BackgroundCleanupUpdaterBackupsJob.php
share/nextcloud/core/Command/App/CheckCode.php
Expand Down Expand Up @@ -10860,7 +10866,6 @@ share/nextcloud/core/doc/admin/_images/sharing-files-1.png
share/nextcloud/core/doc/admin/_images/skeleton-files.png
share/nextcloud/core/doc/admin/_images/skeleton-files1.png
share/nextcloud/core/doc/admin/_images/smb.png
share/nextcloud/core/doc/admin/_images/smtp-config-php-sendmail.png
share/nextcloud/core/doc/admin/_images/smtp-config-smtp.png
share/nextcloud/core/doc/admin/_images/smtp-config-wizard.png
share/nextcloud/core/doc/admin/_images/theming.png
Expand Down Expand Up @@ -11654,6 +11659,8 @@ share/nextcloud/core/js/update.js
share/nextcloud/core/js/visitortimezone.js
share/nextcloud/core/l10n/af.js
share/nextcloud/core/l10n/af.json
share/nextcloud/core/l10n/ar.js
share/nextcloud/core/l10n/ar.json
share/nextcloud/core/l10n/ast.js
share/nextcloud/core/l10n/ast.json
share/nextcloud/core/l10n/bg.js
Expand Down Expand Up @@ -11770,8 +11777,6 @@ share/nextcloud/core/l10n/tr.js
share/nextcloud/core/l10n/tr.json
share/nextcloud/core/l10n/uk.js
share/nextcloud/core/l10n/uk.json
share/nextcloud/core/l10n/uz.js
share/nextcloud/core/l10n/uz.json
share/nextcloud/core/l10n/vi.js
share/nextcloud/core/l10n/vi.json
share/nextcloud/core/l10n/zh_CN.js
Expand Down Expand Up @@ -13019,6 +13024,7 @@ share/nextcloud/resources/config/mimetypemapping.dist.json
share/nextcloud/resources/locales.json
share/nextcloud/robots.txt
share/nextcloud/settings/.babelrc.js
share/nextcloud/settings/.l10nignore
share/nextcloud/settings/Activity/Provider.php
share/nextcloud/settings/Activity/SecurityFilter.php
share/nextcloud/settings/Activity/SecurityProvider.php
Expand Down
10 changes: 5 additions & 5 deletions www/php-nextcloud/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.15 2018/11/22 12:28:11 ryoon Exp $
$NetBSD: distinfo,v 1.16 2018/12/01 09:53:27 ryoon Exp $

SHA1 (nextcloud-14.0.3.tar.bz2) = de6876c9b615faaeb9210ca777c11a9b01a889e7
RMD160 (nextcloud-14.0.3.tar.bz2) = f76d2c226c96e1dccc7f6606d1a7b5f5d33e6a28
SHA512 (nextcloud-14.0.3.tar.bz2) = 09f224d5e55496dcad4d743a0b62af407b4e1fece009fea19d87ac32672cec83bde135e25607236971af0ba32804cc5ebff9295472c276eb2898e21400c6e2c5
Size (nextcloud-14.0.3.tar.bz2) = 49713609 bytes
SHA1 (nextcloud-14.0.4.tar.bz2) = cb2f9b9fb337dc4944537fc93f27fcf921521498
RMD160 (nextcloud-14.0.4.tar.bz2) = dd7e26db6c0f73a14b9c6fac978fe8eccaeb8491
SHA512 (nextcloud-14.0.4.tar.bz2) = a53eb90645619d6558c93304c43ca86cf00cacf8a0f783e699f5041c7b5eb1c9ee8719d4bde5cc16bd1c7b90529d9b100c79e1ce14cc8f8192158c705c8db09e
Size (nextcloud-14.0.4.tar.bz2) = 49827498 bytes

0 comments on commit 0705704

Please sign in to comment.