Skip to content
Reza-DariusPublic

About

asynchronous TCP/IP networking stack

Resources

Stars

3 stars

Watchers

0 watching

Forks

Latest commit

 

History

32 Commits

Folders and files

NameName
Last commit message
Last commit date
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Repository files navigation

tcup

Tcup is an asynchronous virtual networking interface capable of handling TCP/IP traffic

Working Features

  • uses linux TAP devices to create a virtual interface
  • handles Ethernet Frames (RFC 1042) and ARP (RFC 826)
  • handles ICMP echoes (RFC 792)
  • handles TCP Listen (RFC 793)

Current WIP

  • RTO
  • Retransmission Queue
  • UDS based IPC protocol
  • Berkley Socket API

Getting Started (coming soon)

build with cargo

cargo install tcup

run with elevated permissions and run it with an ip and subnet

sudo setcap cap_net_admin=ep /usr/bin/tcup
tcup 10.0.0.4/24

open a port with your language of choice and enjoy some reliable packets!

About

asynchronous TCP/IP networking stack

Resources

Stars

3 stars

Watchers

0 watching

Forks

Releases

Packages

Contributors

Languages