Skip to content

Commit

Permalink
service_identity: update to 23.1.0.
Browse files Browse the repository at this point in the history
## [23.1.0](pyca/service-identity@21.1.0...23.1.0) - 2023-06-14

### Removed

- All Python versions up to and including 3.7 have been dropped.
- Support for `commonName` in certificates has been dropped.
  It has been deprecated since 2017 and isn't supported by any major browser.
- The oldest supported pyOpenSSL version (when using the `pyopenssl` backend) is now 17.0.0.
  When using such an old pyOpenSSL version, you have to pin *cryptography* yourself to ensure compatibility between them.
  Please check out [`contraints/oldest-pyopenssl.txt`](https://github.com/pyca/service-identity/blob/main/tests/constraints/oldest-pyopenssl.txt) to verify what we are testing against.


### Deprecated

- If you've used `service_identity.(cryptography|pyopenssl).extract_ids()`, please switch to the new names `extract_patterns()`.
  [#56](pyca/service-identity#56)


### Added

- `service_identity.(cryptography|pyopenssl).extract_patterns()` are now public APIs (FKA `extract_ids()`).
  You can use them to extract the patterns from a certificate without verifying anything.
  [#55](pyca/service-identity#55)
- *service-identity* is now fully typed.
  [#57](pyca/service-identity#57)
  • Loading branch information
0-wiz-0 committed Jul 1, 2023
1 parent 17fb79e commit f991fef
Show file tree
Hide file tree
Showing 3 changed files with 23 additions and 28 deletions.
15 changes: 8 additions & 7 deletions security/py-service_identity/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,6 @@
# $NetBSD: Makefile,v 1.11 2023/05/05 09:02:12 wiz Exp $
# $NetBSD: Makefile,v 1.12 2023/07/01 11:29:20 wiz Exp $

DISTNAME= service-identity-21.1.0
# to match previous pkgsrc name
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/-/_/}
DISTNAME= service_identity-23.1.0
CATEGORIES= security python
MASTER_SITES= ${MASTER_SITE_PYPI:=s/service_identity/}

Expand All @@ -11,6 +9,9 @@ HOMEPAGE= https://pypi.python.org/pypi/service_identity
COMMENT= Service identity verification for pyOpenSSL
LICENSE= mit

TOOL_DEPENDS+= ${PYPKGPREFIX}-hatchling-[0-9]*:../../devel/py-hatchling
TOOL_DEPENDS+= ${PYPKGPREFIX}-hatch-vcs-[0-9]*:../../devel/py-hatch-vcs
TOOL_DEPENDS+= ${PYPKGPREFIX}-hatch-fancy-pypi-readme-[0-9]*:../../devel/py-hatch-fancy-pypi-readme
DEPENDS+= ${PYPKGPREFIX}-asn1-[0-9]*:../../security/py-asn1
DEPENDS+= ${PYPKGPREFIX}-asn1-modules-[0-9]*:../../security/py-asn1-modules
DEPENDS+= ${PYPKGPREFIX}-attrs>=19.1.0:../../devel/py-attrs
Expand All @@ -19,13 +20,13 @@ DEPENDS+= ${PYPKGPREFIX}-six-[0-9]*:../../lang/py-six
DEPENDS+= ${PYPKGPREFIX}-idna-[0-9]*:../../www/py-idna
TEST_DEPENDS+= ${PYPKGPREFIX}-test-[0-9]*:../../devel/py-test

PYTHON_VERSIONS_INCOMPATIBLE= 27
PYTHON_VERSIONS_INCOMPATIBLE= 27 37

TEST_ENV+= PYTHONPATH=${WRKSRC}/build/lib
# needs 'make install'
do-test:
cd ${WRKSRC} && ${SETENV} ${TEST_ENV} pytest-${PYVERSSUFFIX}

.include "../../lang/python/egg.mk"
.include "../../lang/python/wheel.mk"
PYTHON_VERSIONED_DEPENDENCIES+= cryptography
PYTHON_VERSIONED_DEPENDENCIES+= OpenSSL
.include "../../lang/python/versioned_dependencies.mk"
Expand Down
28 changes: 11 additions & 17 deletions security/py-service_identity/PLIST
Original file line number Diff line number Diff line change
@@ -1,25 +1,19 @@
@comment $NetBSD: PLIST,v 1.3 2017/05/29 11:22:51 wiz Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/not-zip-safe
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
@comment $NetBSD: PLIST,v 1.4 2023/07/01 11:29:20 wiz Exp $
${PYSITELIB}/${WHEEL_INFODIR}/INSTALLER
${PYSITELIB}/${WHEEL_INFODIR}/METADATA
${PYSITELIB}/${WHEEL_INFODIR}/RECORD
${PYSITELIB}/${WHEEL_INFODIR}/REQUESTED
${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
${PYSITELIB}/${WHEEL_INFODIR}/direct_url.json
${PYSITELIB}/${WHEEL_INFODIR}/licenses/LICENSE
${PYSITELIB}/service_identity/__init__.py
${PYSITELIB}/service_identity/__init__.pyc
${PYSITELIB}/service_identity/__init__.pyo
${PYSITELIB}/service_identity/_common.py
${PYSITELIB}/service_identity/_common.pyc
${PYSITELIB}/service_identity/_common.pyo
${PYSITELIB}/service_identity/_compat.py
${PYSITELIB}/service_identity/_compat.pyc
${PYSITELIB}/service_identity/_compat.pyo
${PYSITELIB}/service_identity/cryptography.py
${PYSITELIB}/service_identity/cryptography.pyc
${PYSITELIB}/service_identity/cryptography.pyo
${PYSITELIB}/service_identity/exceptions.py
${PYSITELIB}/service_identity/exceptions.pyc
${PYSITELIB}/service_identity/exceptions.pyo
${PYSITELIB}/service_identity/hazmat.py
${PYSITELIB}/service_identity/hazmat.pyc
${PYSITELIB}/service_identity/py.typed
${PYSITELIB}/service_identity/pyopenssl.py
${PYSITELIB}/service_identity/pyopenssl.pyc
${PYSITELIB}/service_identity/pyopenssl.pyo
8 changes: 4 additions & 4 deletions security/py-service_identity/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.8 2023/05/05 09:02:12 wiz Exp $
$NetBSD: distinfo,v 1.9 2023/07/01 11:29:20 wiz Exp $

BLAKE2s (service-identity-21.1.0.tar.gz) = 54b28202f38c671a05437e055a5f3605ff7d247f4780fb56bbc0cb56837636cc
SHA512 (service-identity-21.1.0.tar.gz) = 36a6f7cb30871bd38da865521503c622a70318f8c5cdc74b0565bdc292bb3b84682bf3afe050d007b21f27d0c54ba0bfe1cd71b63fb13fa42cbaef66cb115c2b
Size (service-identity-21.1.0.tar.gz) = 40073 bytes
BLAKE2s (service_identity-23.1.0.tar.gz) = b484afc1fcc1f6c280d43231d3c3c3aa40dfb286b39f17cd70a11957ddd18939
SHA512 (service_identity-23.1.0.tar.gz) = bc53f563050811a2b40dbfcf1e0a1b1b5677e2b48ed4e94e37d29735baea49ed7a7099d656444c0054fa2c23ae96026e67919cf24b01a3ae6b3549fd25dfe4d1
Size (service_identity-23.1.0.tar.gz) = 39840 bytes

0 comments on commit f991fef

Please sign in to comment.