Skip to content

Commit

Permalink
p5-Crypt-OpenPGP: update to 1.15.
Browse files Browse the repository at this point in the history
1.15 -- Wed Oct 02 07:45:07 ADT 2024

    [Module Status]
    Crypt::OpenPGP has a new maintainer.  Current work is to merge past PRs that
    are fairly simple to review and test.  Other issues will be reviewed
    as time permits.

    [Changes since 1.12]
    - Release of TRIAL 1.14 as production
    - PR #15 - (@nielslaukens) Added UserAttribute class (unparsed)
    - PR #16 - (@nielslaukens) Bugfix: allow multiple 'Preferred hash/compression algorithms'
    - PR #17 - (@nielslaukens) Added UserAttribute class (unparsed)
    - PR #18 - (@nielslaukens) Bugfix: parse notation data subpacket of Signature correctly
    - PR #19 - (@nielslaukens) Support unknown algos
    - Closed RT#53323: Failing on 64bit machines
    - Fix RT#123452 Require at least one Random Source
    - GH PR#29 (@andyjack) Add use strict to increase kwalitee
    - GH PR#31 (@gozer) ElGamal: key's p can be a large integer, use Bigint
    - GH PR#32 (@Shildus). Add support for SHA-2 (SHA-512, SHA-256,...) signatures verification

    [Detailed Changelog]
    - d23dc25 Fix the version regex in dist.ini
    - 4acfd00 Add to .gitignore
    - 2a6c65a Add note on Random Number Module requirements
    - 46fbd15 Add back the number of tests
    - 7ef4fda Added SubSignature with notation to test suite
    - 451bd6e Added support for unknown key algorithms
    - 548bb07 Added ECC public key to test suite
    - 6e0c442 Use done testing instead of a test plan
    - ac14115 Bugfix: parse notation data subpacket of Signature correctly
    - ffa9e30 Added support for unparsed SubPackets
    - 66897ea Added SubSignature packet to test suite
    - a72137e Bugfix: allow multiple 'Preferred hash/compression algorithms'
    - 50f9a30 Added UserAttribute class (unparsed)
    - 26632de Added User Attribute test packet to test suite
    - 9e7d578 Added test to run packets through a parse/save cycle
    - 0727bbe RT#123452 Require at least one Random Source
    - a30bc95 Closed RT#53323: Failing on 64bit machines
    - 67c4ee9 Fix Bignum subtraction
    - 8c21506 v1.13
    - 04010a5 (tag: 1.13) Add some additional Dist::Zilla configuration
    - 51ae276 Whitespace and alignment changes
    - 17ad689 Add use strict to increase kwalitee
    - 4221098 ElGamal: key's p can be a large integer, use Bigint
    - f3f20a0 Add support for SHA-2 (SHA-512, SHA-256,...) signatures verification.

1.14 -- Tue Oct 01 18:53:32 ADT 2024

    [Module Status]
    Crypt::OpenPGP has a new maintainer.  Current work is to merge past PRs that
    are fairly simple to review and test.  Other issues will be reviewed
    as time permits.

    @nielslaukens provided a number of PRs at https://github.com/btrott/Crypt-OpenPGP/pulls

    - PR #15 - Added UserAttribute class (unparsed)
    - PR #16 - Bugfix: allow multiple 'Preferred hash/compression algorithms'
    - PR #17 - Added UserAttribute class (unparsed)
    - PR #18 - Bugfix: parse notation data subpacket of Signature correctly
    - PR #19 - Support unknown algos
    - Closed RT#53323: Failing on 64bit machines
    - Fix RT#123452 Require at least one Random Source

    [Detailed Changelog]
    - d23dc25 Fix the version regex in dist.ini
    - 4acfd00 Add to .gitignore
    - 2a6c65a Add note on Random Number Module requirements
    - 46fbd15 Add back the number of tests
    - 7ef4fda Added SubSignature with notation to test suite
    - 451bd6e Added support for unknown key algorithms
    - 548bb07 Added ECC public key to test suite
    - 6e0c442 Use done testing instead of a test plan
    - ac14115 Bugfix: parse notation data subpacket of Signature correctly
    - ffa9e30 Added support for unparsed SubPackets
    - 66897ea Added SubSignature packet to test suite
    - a72137e Bugfix: allow multiple 'Preferred hash/compression algorithms'
    - 50f9a30 Added UserAttribute class (unparsed)
    - 26632de Added User Attribute test packet to test suite
    - 9e7d578 Added test to run packets through a parse/save cycle
    - 0727bbe RT#123452 Require at least one Random Source
    - a30bc95 Closed RT#53323: Failing on 64bit machines
    - 67c4ee9 Fix Bignum subtraction

1.13 -- Sun Sep 29 23:13:17 ADT 2024

    [Module Status]
    Crypt::OpenPGP has a new maintainer.  Current work is to merge past PRs that
    are fairly simple to review and test.  Other issues will be reviewed
    as time permits.

    - GH PR#29 Add use strict to increase kwalitee
    - GH PR#31 ElGamal: key's p can be a large integer, use Bigint
    - GH PR#32 Add support for SHA-2 (SHA-512, SHA-256,...) signatures verification.
  • Loading branch information
0-wiz-0 committed Oct 7, 2024
1 parent b6f0034 commit ead9d65
Show file tree
Hide file tree
Showing 2 changed files with 13 additions and 9 deletions.
14 changes: 9 additions & 5 deletions security/p5-Crypt-OpenPGP/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.45 2023/07/06 09:41:22 wiz Exp $
# $NetBSD: Makefile,v 1.46 2024/10/07 20:02:56 wiz Exp $

DISTNAME= Crypt-OpenPGP-1.12
DISTNAME= Crypt-OpenPGP-1.15
PKGNAME= p5-${DISTNAME}
PKGREVISION= 9
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Crypt/}

Expand All @@ -11,6 +10,8 @@ HOMEPAGE= https://metacpan.org/release/Crypt-OpenPGP
COMMENT= Pure-Perl OpenPGP implementation
LICENSE= ${PERL5_LICENSE}

TOOL_DEPENDS+= p5-Test-Exception-[0-9]*:../../devel/p5-Test-Exception

# for /usr/pkg/bin/pgplet -> ../lib/perl5/vendor_perl/bin/pgplet
DEPENDS+= p5-Term-ReadKey-[0-9]*:../../devel/p5-Term-ReadKey

Expand All @@ -31,8 +32,11 @@ DEPENDS+= p5-File-HomeDir-[0-9]*:../../devel/p5-File-HomeDir
DEPENDS+= p5-URI-[0-9]*:../../www/p5-URI
# contains LWP::UserAgent
DEPENDS+= p5-libwww>=5.10:../../www/p5-libwww

TOOL_DEPENDS+= p5-Test-Exception-[0-9]*:../../devel/p5-Test-Exception
# configure warns about missing these, but the tests work without them
# TODO: check if they are needed and add them
#Warning: prerequisite Alt::Crypt::RSA::BigInt 0 not found.
#Warning: prerequisite Bytes::Random::Secure 0 not found.
#Warning: prerequisite Crypt::IDEA 0 not found.

USE_LANGUAGES= # empty
PERL5_PACKLIST= auto/Crypt/OpenPGP/.packlist
Expand Down
8 changes: 4 additions & 4 deletions security/p5-Crypt-OpenPGP/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.10 2021/10/26 11:17:27 nia Exp $
$NetBSD: distinfo,v 1.11 2024/10/07 20:02:56 wiz Exp $

BLAKE2s (Crypt-OpenPGP-1.12.tar.gz) = 5a16a2a35993141e4a937acbebe4430c2d3095760d4cf96d990a4a28ce171f9d
SHA512 (Crypt-OpenPGP-1.12.tar.gz) = 7cbdd1e125d686aea6e6de66572e3d2d03f08d048481b757b9fa51f7d3d0b39dce1f4105a18600b4d546001bf39baeefb199c25449be21d038685cb21174caf6
Size (Crypt-OpenPGP-1.12.tar.gz) = 103125 bytes
BLAKE2s (Crypt-OpenPGP-1.15.tar.gz) = 73976f355e7709fa501cc20b3a9c05a7fb2bfa9c2244bee9fd8dde33bff0afbb
SHA512 (Crypt-OpenPGP-1.15.tar.gz) = ee3b074644a568c4adacd65a38dac3871bb0dd06f51bed96207dec720617c259ff71bdd5f29f5932ea99495384854fece98b9bfe6d7adddf991915cc7096db6b
Size (Crypt-OpenPGP-1.15.tar.gz) = 114938 bytes

0 comments on commit ead9d65

Please sign in to comment.