Skip to content

Commit

Permalink
Update net/powerdns* to 4.1.0.
Browse files Browse the repository at this point in the history
PowerDNS Authoritative Server 4.1.0
===========================================================

- Improved performance: 400% speedup in some scenarios
- Crypto API: DNSSEC fully configurable via RESTful API
- Improved documentation
- Database related improvements
- Enhanced tooling
- Support for TCP Fast Open
- Support for non-local bind
- Support for Botan 2.x (and removal of support for Botan 1.10)
- Our packages now ship with PKCS #11 support.
- Recursor passthrough removal

Full changelog:

  https://doc.powerdns.com/authoritative/changelog/4.1.html



PowerDNS Authoritative Server 4.0.5
===========================================================

Fixes
- Fix for missing check on API operations (CVE-2017-15091)
- Bindbackend: do not corrupt data supplied by other backends in
  getAllDomains
- API: prevent sending nameservers list and zone-level NS in rrsets
- gpgsql: make statement names actually unique
- Fix remotebackend params
- Fix godbc query logging
- For create-slave-zone, actually add all slaves, and not only first n
  times
- Fix a regression in axfr-rectify + test
- When making a netmask from a comboaddress, we neglected to zero the
  port
- Fix libatomic detection on ppc64
- Catch DNSName exception in the Zoneparser
- Publish inactive KSK/CSK as CDNSKEY/CDS
- Handle AFSDB record separately due to record structure.
- Treat requestor's payload size lower than 512 as equal to 512
- Correctly purge entries from the caches after a transfer
- Handle a signing pipe worker dying with work still pending
- Ignore SOA-EDIT for PRESIGNED zones.
- Check return value for all getTSIGKey calls.

Improvements
- Fix ldap-strict autoptr feature, including a test
- mydnsbackend: Add getAllDomains
- Stubresolver: Use only recursor setting if given
- LuaWrapper: Allow embedded NULs in strings received from Lua
- sdig: Clarify that the ednssubnet option takes "subnet/mask"
- Tests: Ensure all required tools are available
- PowerDNS sdig does not truncate trailing bits of EDNS Client Subnet
  mask
- LuaJIT 2.1: Lua fallback functionality no longer uses Lua namespace
- Add support for Botan 2.x
- Ship ldapbackend schema files in tarball
- Collection of schema changes
- Fix typo in two log messages
- Add help text on autodetecting systemd support
- Use a unique pointer for bind backend's d_of
- Fix some of the issues found by @jpmens
  • Loading branch information
mamash committed Jan 2, 2018
1 parent 95790e3 commit de0b43a
Show file tree
Hide file tree
Showing 13 changed files with 92 additions and 105 deletions.
4 changes: 2 additions & 2 deletions net/powerdns-geoip/PLIST
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
@comment $NetBSD: PLIST,v 1.1 2017/03/09 13:50:07 fhajny Exp $
lib/pdns/pdns/libgeoipbackend.la
@comment $NetBSD: PLIST,v 1.2 2018/01/02 12:18:15 fhajny Exp $
lib/pdns/libgeoipbackend.la
6 changes: 4 additions & 2 deletions net/powerdns-ldap/PLIST
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
@comment $NetBSD: PLIST,v 1.4 2014/12/10 14:50:09 fhajny Exp $
lib/pdns/pdns/libldapbackend.la
@comment $NetBSD: PLIST,v 1.5 2018/01/02 12:18:15 fhajny Exp $
lib/pdns/libldapbackend.la
share/doc/pdns/dnsdomain2.schema
share/doc/pdns/pdns-domaininfo.schema
5 changes: 3 additions & 2 deletions net/powerdns-mysql/PLIST
Original file line number Diff line number Diff line change
@@ -1,5 +1,6 @@
@comment $NetBSD: PLIST,v 1.5 2014/12/10 14:50:09 fhajny Exp $
lib/pdns/pdns/libgmysqlbackend.la
@comment $NetBSD: PLIST,v 1.6 2018/01/02 12:18:15 fhajny Exp $
lib/pdns/libgmysqlbackend.la
share/doc/pdns/3.4.0_to_4.1.0_schema.mysql.sql
share/doc/pdns/dnssec-3.x_to_3.4.0_schema.mysql.sql
share/doc/pdns/nodnssec-3.x_to_3.4.0_schema.mysql.sql
share/doc/pdns/schema.mysql.sql
4 changes: 2 additions & 2 deletions net/powerdns-odbc/PLIST
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
@comment $NetBSD: PLIST,v 1.1 2017/03/09 13:52:34 fhajny Exp $
lib/pdns/pdns/libgodbcbackend.la
@comment $NetBSD: PLIST,v 1.2 2018/01/02 12:18:15 fhajny Exp $
lib/pdns/libgodbcbackend.la
share/doc/pdns/schema.mssql.sql
5 changes: 3 additions & 2 deletions net/powerdns-pgsql/PLIST
Original file line number Diff line number Diff line change
@@ -1,5 +1,6 @@
@comment $NetBSD: PLIST,v 1.4 2014/12/10 14:50:09 fhajny Exp $
lib/pdns/pdns/libgpgsqlbackend.la
@comment $NetBSD: PLIST,v 1.5 2018/01/02 12:18:16 fhajny Exp $
lib/pdns/libgpgsqlbackend.la
share/doc/pdns/3.4.0_to_4.1.0_schema.pgsql.sql
share/doc/pdns/dnssec-3.x_to_3.4.0_schema.pgsql.sql
share/doc/pdns/nodnssec-3.x_to_3.4.0_schema.pgsql.sql
share/doc/pdns/schema.pgsql.sql
5 changes: 2 additions & 3 deletions net/powerdns/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,5 @@
# $NetBSD: Makefile,v 1.31 2018/01/01 21:18:49 adam Exp $
# $NetBSD: Makefile,v 1.32 2018/01/02 12:18:15 fhajny Exp $

PKGREVISION= 4
.include "Makefile.common"

PKGNAME= ${DISTNAME:S/pdns/powerdns/}
Expand Down Expand Up @@ -28,6 +27,6 @@ LDFLAGS.SunOS+= -lsocket -lnsl

INSTALL_MAKE_FLAGS+= sysconfdir=${EGDIR}

CHECK_WRKREF_SKIP+= sbin/pdns_server
#CHECK_WRKREF_SKIP+= sbin/pdns_server

.include "../../mk/bsd.pkg.mk"
8 changes: 2 additions & 6 deletions net/powerdns/Makefile.common
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile.common,v 1.19 2017/09/03 08:53:13 wiz Exp $
# $NetBSD: Makefile.common,v 1.20 2018/01/02 12:18:15 fhajny Exp $

PDNS_VERSION= 4.0.4
PDNS_VERSION= 4.1.0
DISTNAME= pdns-${PDNS_VERSION}
CATEGORIES= net
MASTER_SITES= http://downloads.powerdns.com/releases/
Expand All @@ -17,13 +17,9 @@ GNU_CONFIGURE= yes

BUILD_DEPENDS+= ragel-[0-9]*:../../devel/ragel

GNU_CONFIGURE_LIBSUBDIR=pdns

CONFIGURE_ARGS+= --without-lua
CONFIGURE_ARGS+= --with-boost=${BUILDLINK_PREFIX.boost-headers}

BUILDLINK_TRANSFORM+= rm:-fstack-protector

.include "../../mk/dlopen.buildlink3.mk"
.include "../../devel/boost-headers/buildlink3.mk"
.include "../../devel/boost-libs/buildlink3.mk"
Expand Down
38 changes: 19 additions & 19 deletions net/powerdns/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.9 2017/03/09 13:32:54 fhajny Exp $
@comment $NetBSD: PLIST,v 1.10 2018/01/02 12:18:15 fhajny Exp $
${PLIST.tools}bin/dnsbulktest
${PLIST.tools}bin/dnsgram
${PLIST.tools}bin/dnsreplay
Expand All @@ -18,29 +18,29 @@ ${PLIST.tools}bin/sdig
${PLIST.tools}bin/stubquery
bin/zone2json
bin/zone2sql
${PLIST.bind}lib/pdns/pdns/libbindbackend.la
${PLIST.sqlite}lib/pdns/pdns/libgsqlite3backend.la
${PLIST.pipe}lib/pdns/pdns/libpipebackend.la
${PLIST.random}lib/pdns/pdns/librandombackend.la
${PLIST.remote}lib/pdns/pdns/libremotebackend.la
man/man1/calidns.1
${PLIST.bind}lib/pdns/libbindbackend.la
${PLIST.sqlite}lib/pdns/libgsqlite3backend.la
${PLIST.pipe}lib/pdns/libpipebackend.la
${PLIST.random}lib/pdns/librandombackend.la
${PLIST.remote}lib/pdns/libremotebackend.la
${PLIST.tools}man/man1/calidns.1
man/man1/dnsbulktest.1
man/man1/dnsgram.1
man/man1/dnsreplay.1
man/man1/dnsscan.1
man/man1/dnsscope.1
${PLIST.tools}man/man1/dnsgram.1
${PLIST.tools}man/man1/dnsreplay.1
${PLIST.tools}man/man1/dnsscan.1
${PLIST.tools}man/man1/dnsscope.1
man/man1/dnstcpbench.1
man/man1/dnswasher.1
man/man1/dumresp.1
man/man1/ixplore.1
man/man1/nproxy.1
man/man1/nsec3dig.1
${PLIST.tools}man/man1/dnswasher.1
${PLIST.tools}man/man1/dumresp.1
${PLIST.tools}man/man1/ixplore.1
${PLIST.tools}man/man1/nproxy.1
${PLIST.tools}man/man1/nsec3dig.1
man/man1/pdns_control.1
man/man1/pdns_notify.1
${PLIST.tools}man/man1/pdns_notify.1
man/man1/pdns_server.1
man/man1/pdnsutil.1
man/man1/saxfr.1
man/man1/sdig.1
${PLIST.tools}man/man1/saxfr.1
${PLIST.tools}man/man1/sdig.1
man/man1/zone2json.1
man/man1/zone2ldap.1
man/man1/zone2sql.1
Expand Down
16 changes: 8 additions & 8 deletions net/powerdns/distinfo
Original file line number Diff line number Diff line change
@@ -1,13 +1,13 @@
$NetBSD: distinfo,v 1.26 2017/08/24 20:59:22 he Exp $
$NetBSD: distinfo,v 1.27 2018/01/02 12:18:15 fhajny Exp $

SHA1 (pdns-4.0.4.tar.bz2) = 27a7421d363e2d8c6dac1404a8c1c96bc6e93f46
RMD160 (pdns-4.0.4.tar.bz2) = b21f87c79162d3a6b1952d96093088ede17e9690
SHA512 (pdns-4.0.4.tar.bz2) = 4ef4705cd990b03976775167c7c37850d45907e198549feda5f5701172e008e3f1f74a35a9bebdb24b63dec15ff63cb2cc9dfc8f92e4e1012e0539c5a88b845b
Size (pdns-4.0.4.tar.bz2) = 1320327 bytes
SHA1 (patch-configure) = f5f4c2d9b635b223f2379a330bfae497ef62191e
SHA1 (pdns-4.1.0.tar.bz2) = f786d27d60032bf268a63a88c77396e31f6622b1
RMD160 (pdns-4.1.0.tar.bz2) = ef033ccb035d24e0d287cd013a9637103a8b3692
SHA512 (pdns-4.1.0.tar.bz2) = 4b2b42f4893f8aac3cf07a6c8a3c999cb728a5907a710f1a5c9c8d08377ecb63e202e5eececbefc069c8f1d97a29b2aa607da7cf2bcc6335a72222418e409e77
Size (pdns-4.1.0.tar.bz2) = 1116905 bytes
SHA1 (patch-configure) = afc7e76dd3e19b092750bc43992a118193c98715
SHA1 (patch-ext_json11_json11.cpp) = a8ffe67156a836841aef8a6bba134a82283f381e
SHA1 (patch-m4_pdns__check__os.m4) = db98d2c892f2e53e42745026749f2ab2a691ed4a
SHA1 (patch-m4_pdns__check__os.m4) = c7a8d91c519ae7ca0616dfc08fa04402fca950d0
SHA1 (patch-pdns_dns.hh) = 626eb4e29b7fcd82fbe056036c157c1e85fa49ca
SHA1 (patch-pdns_dnsscope.cc) = b289b750686b25041c3e291fb0d3d562beb36eaf
SHA1 (patch-pdns_iputils.hh) = 7507f6b080c9aa5e71068b3e9e92e71de6fc2b15
SHA1 (patch-pdns_iputils.hh) = 714277322ea721ea0439fc6aa0265bd290219e8b
SHA1 (patch-pdns_qtype.hh) = 0f8bca4c0cafea9a5257a08077fa42b4c52127f5
5 changes: 2 additions & 3 deletions net/powerdns/options.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: options.mk,v 1.5 2017/03/09 13:32:54 fhajny Exp $
# $NetBSD: options.mk,v 1.6 2018/01/02 12:18:15 fhajny Exp $

PKG_OPTIONS_VAR= PKG_OPTIONS.powerdns
PKG_SUPPORTED_OPTIONS= bind botan pipe random remote sqlite tools zeromq
Expand All @@ -14,9 +14,8 @@ PLIST.bind= yes
.endif

.if !empty(PKG_OPTIONS:Mbotan)
CONFIGURE_ARGS+= --enable-botan1.10
.include "../../devel/gmp/buildlink3.mk"
.include "../../security/botan/buildlink3.mk"
.include "../../security/botan-devel/buildlink3.mk"
.endif

.if !empty(PKG_OPTIONS:Mpipe)
Expand Down
40 changes: 29 additions & 11 deletions net/powerdns/patches/patch-configure
Original file line number Diff line number Diff line change
@@ -1,35 +1,53 @@
$NetBSD: patch-configure,v 1.6 2017/08/24 20:59:22 he Exp $
$NetBSD: patch-configure,v 1.7 2018/01/02 12:18:15 fhajny Exp $

Regen after excluding -latomic test on NetBSD.

--- configure.orig 2017-08-24 16:29:40.591346034 +0000
--- configure.orig 2017-11-30 09:43:31.000000000 +0000
+++ configure
@@ -5567,9 +5567,14 @@ else
@@ -5569,9 +5569,14 @@ else
fi


- case "$host" in
- mips* | powerpc* )
- mips* | powerpc-* )
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the linker accepts -latomic" >&5
+ case "$host_os" in
+ netbsd*)
+ : # no -latomic
+ ;;
+ *)
+ case "$host" in
+ mips* | powerpc* )
+ mips* | powerpc-* )
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the linker accepts -latomic" >&5
$as_echo_n "checking whether the linker accepts -latomic... " >&6; }
if ${ax_cv_check_ldflags___latomic+:} false; then :
$as_echo_n "(cached) " >&6
@@ -5606,7 +5611,9 @@ else
LDFLAGS="-latomic $LDFLAGS"
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
@@ -5593,7 +5598,9 @@ else

fi

- LDFLAGS="-latomic $LDFLAGS"
+ LDFLAGS="-latomic $LDFLAGS"
rm -f core conftest.err conftest.$ac_objext \
- conftest$ac_exeext conftest.$ac_ext
+ conftest$ac_exeext conftest.$ac_ext
+ ;;
+ esac
;;
esac

@@ -20586,7 +20593,7 @@ fi

if test "x$PG_CONFIG" != "x" -o "x$PGSQL_LIBS" = "x"; then :

- if test "x$PG_CONFIG" == "x"; then :
+ if test "x$PG_CONFIG" = "x"; then :

# Extract the first word of "pg_config", so it can be a program name with args.
set dummy pg_config; ac_word=$2
@@ -20630,7 +20637,7 @@ fi


fi
- if test "x$PG_CONFIG" == "x"; then :
+ if test "x$PG_CONFIG" = "x"; then :

as_fn_error $? "Can not find pg_config, use --with-pg-config to specify the path to pg_config" "$LINENO" 5

28 changes: 15 additions & 13 deletions net/powerdns/patches/patch-m4_pdns__check__os.m4
Original file line number Diff line number Diff line change
@@ -1,32 +1,34 @@
$NetBSD: patch-m4_pdns__check__os.m4,v 1.1 2017/08/24 20:59:22 he Exp $
$NetBSD: patch-m4_pdns__check__os.m4,v 1.2 2018/01/02 12:18:15 fhajny Exp $

Don't insist on -latomic on mips & powerpc if on NetBSD.

--- m4/pdns_check_os.m4.orig 2017-06-22 20:07:25.000000000 +0000
--- m4/pdns_check_os.m4.orig 2017-11-30 09:43:22.000000000 +0000
+++ m4/pdns_check_os.m4
@@ -35,13 +35,20 @@ AC_DEFUN([PDNS_CHECK_OS],[
@@ -35,14 +35,21 @@ AC_DEFUN([PDNS_CHECK_OS],[
AM_CONDITIONAL([HAVE_LINUX], [test "x$have_linux" = "xyes"])
AM_CONDITIONAL([HAVE_SOLARIS], [test "x$have_solaris" = "xyes"])
- case "$host" in
- mips* | powerpc* )
- AX_CHECK_LINK_FLAG([-latomic],
- [ : ],
- [ AC_MSG_ERROR([Unable to link against libatomic, cannot continue]) ]
- )
- mips* | powerpc-* )
- AC_MSG_CHECKING([whether the linker accepts -latomic])
- LDFLAGS="-latomic $LDFLAGS"
- AC_LINK_IFELSE([m4_default([],[AC_LANG_PROGRAM()])],
- [AC_MSG_RESULT([yes])],
- [AC_MSG_ERROR([Unable to link against libatomic, cannot continue])]
- )
+ case "$host_os" in
+ netbsd*)
+ : # no -latomic
+ ;;
+ *)
+ case "$host" in
+ mips* | powerpc* )
+ AX_CHECK_LINK_FLAG([-latomic],
+ [ : ],
+ [ AC_MSG_ERROR([Unable to link against libatomic, cannot continue]) ]
+ )
+ mips* | powerpc-* )
+ AC_MSG_CHECKING([whether the linker accepts -latomic])
+ LDFLAGS="-latomic $LDFLAGS"
+ AC_LINK_IFELSE([m4_default([],[AC_LANG_PROGRAM()])],
+ [AC_MSG_RESULT([yes])],
+ [AC_MSG_ERROR([Unable to link against libatomic, cannot continue])]
+ )
+ ;;
+ esac
;;
Expand Down
33 changes: 1 addition & 32 deletions net/powerdns/patches/patch-pdns_iputils.hh
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-pdns_iputils.hh,v 1.2 2017/03/29 11:46:03 fhajny Exp $
$NetBSD: patch-pdns_iputils.hh,v 1.3 2018/01/02 12:18:15 fhajny Exp $

- Do not use IP_PKTINFO on NetBSD, the structure is not as expected.
- Backport fix for SunOS segfault problem, see:
Expand All @@ -17,34 +17,3 @@ $NetBSD: patch-pdns_iputils.hh,v 1.2 2017/03/29 11:46:03 fhajny Exp $
#ifdef __APPLE__
#include <libkern/OSByteOrder.h>

@@ -59,23 +63,22 @@
#define le64toh(x) OSSwapLittleToHostInt64(x)
#endif

-// for illumos
-#ifdef BE_64
+#ifdef __sun

#define htobe16(x) BE_16(x)
#define htole16(x) LE_16(x)
-#define be16toh(x) BE_IN16(x)
-#define le16toh(x) LE_IN16(x)
+#define be16toh(x) BE_IN16(&(x))
+#define le16toh(x) LE_IN16(&(x))

#define htobe32(x) BE_32(x)
#define htole32(x) LE_32(x)
-#define be32toh(x) BE_IN32(x)
-#define le32toh(x) LE_IN32(x)
+#define be32toh(x) BE_IN32(&(x))
+#define le32toh(x) LE_IN32(&(x))

#define htobe64(x) BE_64(x)
#define htole64(x) LE_64(x)
-#define be64toh(x) BE_IN64(x)
-#define le64toh(x) LE_IN64(x)
+#define be64toh(x) BE_IN64(&(x))
+#define le64toh(x) LE_IN64(&(x))

#endif

0 comments on commit de0b43a

Please sign in to comment.