Skip to content

Commit

Permalink
Update to 0.12.0. From the changelog:
Browse files Browse the repository at this point in the history
* Fix out-of-tree builds with CMake.
  Issue #86

* Fix issue found with Clang regarding invalid suffix on a literal
  Issue #110

* Check now responds to a few errors in a more clear way when it cannot run tests.
  PR #122, #123

* Fix missing pid_t definition in check.h on Windows
  Issue #78

* The maximum message size of check assertions is now configurable.
  Issue #127

* Check support added for Visual Studios 2010, 2012, 2013, 2015, and
  2017 both for x86/64 and ARM.
  PR #129, Issue #125

* Changed license of example CMake files to BSD (was previously LGPL).
  Issue #131

* Fix issue with floating point macros on MinGW
  Issue #101

* Avoid issue in unit test output checking where a shell's built-in printf
  command does not work properly, but the printf program itself is correct.

* Emit only valid XML characters in XML logging (assumes ASCII encoding).
  Bug #103

* Add LGPL header to files where it was missing; update FSF address in LGPL headers
  Bug #110

* Strip timestamps from examples using filterdiff if available. This
  allow build output to be reproducible.
  Bug #112

* Use double slash for regular expressions in checkmk for better Solaris support.

* Improve CMake build files for better Visual Studio 2015 support.
  Pull Request #19

* Fix potential SIGSEGV in Check related to the disk filling up during a test.
  Pull Request #21

* Support added for applying tags to test cases and selectively running
  test cases based on tags.
  Pull Request #44

* Macros for comparing memory regions (ck_assert_mem_eq, ck_assert_mem_ne)
  have been added.
  Pull Request #64

* Macros for comparing floating point numbers have been added.
  Pull Request #69

* Macros for comparing string, but allowing for NULL (ck_assert_pstr_eq,
  ck_assert_pstr_ne) have been added.
  Pull Request #80

* Macros for checking if a pointer is NULL or not have been added.
  Pull Request #87
  • Loading branch information
schmonz committed Mar 30, 2018
1 parent 71cf456 commit b15edf6
Show file tree
Hide file tree
Showing 3 changed files with 14 additions and 11 deletions.
11 changes: 8 additions & 3 deletions devel/check/Makefile
Original file line number Diff line number Diff line change
@@ -1,22 +1,27 @@
# $NetBSD: Makefile,v 1.21 2016/06/17 02:25:47 schmonz Exp $
# $NetBSD: Makefile,v 1.22 2018/03/30 19:16:55 schmonz Exp $
#

DISTNAME= check-0.10.0
DISTNAME= check-0.12.0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=check/}
MASTER_SITES= ${MASTER_SITE_GITHUB:=libcheck/}

MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://check.sourceforge.net/
COMMENT= Unit test framework for C
LICENSE= gnu-lgpl-v2.1

GNU_CONFIGURE= yes
#CONFIGURE_ENV= ac_cv_path_AWK_PATH=gawk
USE_TOOLS= automake autoreconf makeinfo # gawk
USE_LIBTOOL= yes
INFO_FILES= yes

PKGCONFIG_OVERRIDE= check.pc.in

TEST_TARGET= check

pre-configure:
cd ${WRKSRC} && autoreconf -fiv

.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
4 changes: 1 addition & 3 deletions devel/check/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.9 2013/10/03 14:48:07 taca Exp $
@comment $NetBSD: PLIST,v 1.10 2018/03/30 19:16:55 schmonz Exp $
include/check.h
include/check_stdint.h
info/check.info
Expand All @@ -8,10 +8,8 @@ man/man1/checkmk.1
share/aclocal/check.m4
share/doc/check/COPYING.LESSER
share/doc/check/ChangeLog
share/doc/check/ChangeLogOld
share/doc/check/NEWS
share/doc/check/README
share/doc/check/SVNChangeLog
share/doc/check/example/Makefile.am
share/doc/check/example/README
share/doc/check/example/configure.ac
Expand Down
10 changes: 5 additions & 5 deletions devel/check/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.17 2016/06/17 02:25:47 schmonz Exp $
$NetBSD: distinfo,v 1.18 2018/03/30 19:16:55 schmonz Exp $

SHA1 (check-0.10.0.tar.gz) = 35d3a53446aea7b21a770faedb358d0fc7cba76d
RMD160 (check-0.10.0.tar.gz) = fbd36eff66e010cbea3d2c0c503e4b4d4a91e730
SHA512 (check-0.10.0.tar.gz) = 82103a98382c41cf16f172ded66c0399d3da6eceb6728aab11120c028e8796f6d545a98dc4aa5f76ee68c0bfd1f842a4dd371f5d670c8ba84ce4209812bf1ac5
Size (check-0.10.0.tar.gz) = 769119 bytes
SHA1 (check-0.12.0.tar.gz) = 2c10a4c09af75f32d58239097ab249ec60f38e88
RMD160 (check-0.12.0.tar.gz) = bc2246f95268ae3dc0b45a9fed6832ab3dce7836
SHA512 (check-0.12.0.tar.gz) = f7b6452b69f999a90e86a8582d980c0c1b74ba5629ee34455724463ba62bfe3501ad0415aa771170f5c638a7a253f123bf87cbef25aadc6569a7a3a4d10fce90
Size (check-0.12.0.tar.gz) = 281127 bytes

0 comments on commit b15edf6

Please sign in to comment.