Skip to content

Commit

Permalink
tree-sitter: update to 0.22.6.
Browse files Browse the repository at this point in the history
Features

    Improve handling of serialization buffer overflows (#3318)
    Reverse iteration through node parents (#3214)
    cli: Support NO_COLOR (#3299)
    cli: Add test listing and allow users to parse a specific test number (#3067)
    grammar: Add "inherits" field if available (#3295)

Bug Fixes

    Correctly load field data from wasm languages
    Improve error message when the tree-sitter field is malformed
    Don't error out on package.json lookup errors if --no-bindings is passed (#3323)
    cli: Keep default cc flags in build
    cli: Properly account for multi-grammar repos when using docker to build a wasm parser (#3337)
    generate: Don't check arbitrarily named dirs
    generate: Take AsRef<Path> for the path parameter to avoid clones (#3322)
    highlight: Correct signature of ts_highlighter_add_language
    lib: Do not return field names for extras (#3330)
    lib: Advance the lookahead end byte by 4 when there's an invalid code point (#3305)
    rust: Update README example (#3307)
    rust: Use unix + wasi cfg instead of not windows for fd (#3304)
    test: Allow newlines in between test name and attribute
    wasm: Correct childrenFromFieldXXX method signatures (#3301)
    xtask: Always bump every crate in tandem
    zig: Make usable as a zig dependency (#3315)

Documentation

    Mention build command variables
    Swap \s for \\s in query example
    highlight: Typo (#3290)

Refactor

    tests: Migrate remaining grammar.json tests to grammar.js (#3325)

Build System and CI

    Add nightly rustfmt to workflow for linting (#3333)
    Fix address sanitizer step (#3188)
    deps: Bump cc from 1.0.92 to 1.0.94 in the cargo group (#3298)
    deps: Bump the cargo group with 6 updates (#3313)
    xtask: Bump build.zig.zon version when bumping versions
  • Loading branch information
0-wiz-0 committed May 12, 2024
1 parent abb5364 commit 96e59f3
Show file tree
Hide file tree
Showing 2 changed files with 6 additions and 6 deletions.
4 changes: 2 additions & 2 deletions textproc/tree-sitter/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.7 2024/04/18 09:06:41 wiz Exp $
# $NetBSD: Makefile,v 1.8 2024/05/12 18:40:08 wiz Exp $

DISTNAME= tree-sitter-0.22.5
DISTNAME= tree-sitter-0.22.6
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GITHUB:=tree-sitter/}
GITHUB_TAG= v${PKGVERSION_NOREV}
Expand Down
8 changes: 4 additions & 4 deletions textproc/tree-sitter/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.7 2024/04/18 09:06:41 wiz Exp $
$NetBSD: distinfo,v 1.8 2024/05/12 18:40:08 wiz Exp $

BLAKE2s (tree-sitter-0.22.5.tar.gz) = 2e3c8a4c1d4f95d615cc5b5a43318db82e687299f8bda1ec4a598a59aeed43b7
SHA512 (tree-sitter-0.22.5.tar.gz) = cff3902e8f6e0211b6d4fafecf9f0d73a2bf73efed68df0d6e8798aac3e685cbcc882fb698ebc10115e72bcf46b59aabd0b14dd402a08d3b42cfceffea5aab2c
Size (tree-sitter-0.22.5.tar.gz) = 3035094 bytes
BLAKE2s (tree-sitter-0.22.6.tar.gz) = 0edc7922a82deea528ade3e0bb6627ccff919117804f84c5b89a5760ed8857ec
SHA512 (tree-sitter-0.22.6.tar.gz) = bf0b87bb9ce16b049824e53933986ac451a7b7f432df39ee9d4546627d740ae689af9e838a53cc50e29d66d6d85d51dab7490d66a429a14bcc9d0b8e2935a63a
Size (tree-sitter-0.22.6.tar.gz) = 3036954 bytes
SHA1 (patch-Makefile) = 05d71cceda39bd1c83d015064fad562fbb077975

0 comments on commit 96e59f3

Please sign in to comment.