Skip to content

Commit

Permalink
chat/iamb: update to 0.0.10
Browse files Browse the repository at this point in the history
Features / Improvements ✨

    Support marking a room as a direct message room (#92)
    Add external_edit_file_suffix to config (#253)
    Allow typing newline with <S-Enter> and enable keyboard enhancement protocol (#272)
    Display file sizes for attachments (#278)
    Implement set/unset/show for alternative and canonical aliases (#279)
    Allow notifications on open room if terminal not focused (#281)
    Add command to set per-room notification levels (#305)
    Add message slash commands (#317)
    Support reacting literally with non-Emojis (#320)
    Include room name in desktop notifications (#326)
    Add ban/unban/kick room commands (#327)
    Add command for setting room history visibility (#328)
    Add commands for viewing and clearing unreads (#332)

Documentation / README updates 📚

    Update Welcome window to reference TOML instead of JSON (#254)
    Add FreeBSD installation instructions (#280)
    Fix openSUSE link and installation command in README (#283)
    Add Hombrew as install method on MacOS (#303)

Bug Fixes 🐞

    Fix reaction count when there are duplicate reaction events from a user (#239)
    Prevent sending duplicate reaction events (#240)
    Use color overrides for users when message_user_color is enabled (#245)
    Fix image preview placement when messages are preceded by a date in the timeline (#257)
    Trim :editor output and check if it's empty (#275)
    Add error for missing username on :logout (#277)
    Remove timeout for desktop notifications (#314)
    Fix underflow panics when using TextPrinter::push_span_nobreak (#322)
    Remove modifyOtherKeys enablement (#324)
    Avoid treating simple messages as Markdown (#325)
    Handle message marks on non-64-bit platforms (#329)

Building / Housekeeping 🧹

    Update to ratatui-image@1.0.0 (#241)
    Update Cargo.toml to v0.0.10-alpha.1 and update dependencies (#269)
    Update to modalkit{,-ratatui}@0.0.19 (#273)
    Fix LICENSE file (#274)
    Add missing darwin build dependency (#286)
    Fix newer Clippy warnings for 1.80 (#301)
    Add FreeDesktop MetaInfo file (#315)
    Update to modalkit{,-ratatui}@0.0.20 (#319)
    Add metadata for cargo-deb and cargo-generate-rpm (#321)
    Build cross-platform binaries and packages of main (#323)
  • Loading branch information
0323pin committed Aug 22, 2024
1 parent 0d6a5c1 commit 78cdc55
Show file tree
Hide file tree
Showing 3 changed files with 897 additions and 847 deletions.
6 changes: 4 additions & 2 deletions chat/iamb/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.4 2024/03/29 20:43:19 pin Exp $
# $NetBSD: Makefile,v 1.5 2024/08/22 12:14:51 pin Exp $

DISTNAME= iamb-0.0.9
DISTNAME= iamb-0.0.10
CATEGORIES= chat
MASTER_SITES= ${MASTER_SITE_GITHUB:=ulyssa/}
GITHUB_TAG= v${PKGVERSION_NOREV}
Expand All @@ -12,6 +12,8 @@ LICENSE= apache-2.0

.include "cargo-depends.mk"

RUST_REQ= 1.70.0

INSTALLATION_DIRS= ${PKGMANDIR}/man1 ${PKGMANDIR}/man5 \
share/examples/iamb share/icons/hicolor/scalable/apps \
share/applications
Expand Down
Loading

0 comments on commit 78cdc55

Please sign in to comment.