Skip to content

Commit

Permalink
net/trippy: update to 0.4.0
Browse files Browse the repository at this point in the history
0.4.0 - 2022-05-18
Added
-Added -P (--target-port) flag to allow specifying the target port (1, 2)
-Added ability to tracing with either a fixed source or a fixed destination port
 for both udp and tcp tracing (#43)
-Display source and destination ports in Tui (#156)
-Added the -A (--source-address) flag to allow specifying the source address
 (#162)
-Added the -I (--interface) flag to allow specifying the source interface (#142)
-Added the -Q (--tos) flag to allow specifying the TOS (DSCP+ECN) IPv4 header
 value (#38)

Changed
-Changed tcp tracing to use a standard (non-raw) socket to be able to detect the
 target (#134)
-Changed udp tracing to use a standard (non-raw) socket (#155)
-Renamed the --tui-max-addresses-per-hop flag as tui-max-addrs (#165)
-Reorder the cli flags in the help output (#163)
-Change short alias for flag max_round_duration from -I to -T (1)
-Added short cli flags for source-port (-S), first-ttl (-f) and tui-max-addrs
 (-M) (1)

Fixed
-Checksums for udp packets were not being set (obsoleted by #155) (#159)
-TimeExceeded responses from the target address were not being handled (1)
-The largest time-to-live for a given round was being calculated incorrectly in
 some cases (1)
  • Loading branch information
0323pin committed May 18, 2022
1 parent 3c20ccb commit 6dcb869
Show file tree
Hide file tree
Showing 3 changed files with 91 additions and 95 deletions.
4 changes: 2 additions & 2 deletions net/trippy/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.2 2022/05/09 21:44:20 pin Exp $
# $NetBSD: Makefile,v 1.3 2022/05/18 12:08:44 pin Exp $

DISTNAME= trippy-0.3.1
DISTNAME= trippy-0.4.0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GITHUB:=fujiapple852/}

Expand Down
45 changes: 22 additions & 23 deletions net/trippy/cargo-depends.mk
Original file line number Diff line number Diff line change
@@ -1,7 +1,8 @@
# $NetBSD: cargo-depends.mk,v 1.2 2022/05/09 21:44:20 pin Exp $
# $NetBSD: cargo-depends.mk,v 1.3 2022/05/18 12:08:44 pin Exp $

CARGO_CRATE_DEPENDS+= aho-corasick-0.7.18
CARGO_CRATE_DEPENDS+= anyhow-1.0.57
CARGO_CRATE_DEPENDS+= arrayvec-0.7.2
CARGO_CRATE_DEPENDS+= async-trait-0.1.53
CARGO_CRATE_DEPENDS+= atty-0.2.14
CARGO_CRATE_DEPENDS+= autocfg-1.1.0
Expand All @@ -12,8 +13,8 @@ CARGO_CRATE_DEPENDS+= cassowary-0.3.0
CARGO_CRATE_DEPENDS+= cc-1.0.73
CARGO_CRATE_DEPENDS+= cfg-if-1.0.0
CARGO_CRATE_DEPENDS+= chrono-0.4.19
CARGO_CRATE_DEPENDS+= clap-3.1.17
CARGO_CRATE_DEPENDS+= clap_derive-3.1.7
CARGO_CRATE_DEPENDS+= clap-3.1.18
CARGO_CRATE_DEPENDS+= clap_derive-3.1.18
CARGO_CRATE_DEPENDS+= clap_lex-0.2.0
CARGO_CRATE_DEPENDS+= comfy-table-5.0.1
CARGO_CRATE_DEPENDS+= convert_case-0.4.0
Expand Down Expand Up @@ -54,26 +55,24 @@ CARGO_CRATE_DEPENDS+= ipnetwork-0.18.0
CARGO_CRATE_DEPENDS+= itertools-0.10.3
CARGO_CRATE_DEPENDS+= itoa-1.0.1
CARGO_CRATE_DEPENDS+= lazy_static-1.4.0
CARGO_CRATE_DEPENDS+= libc-0.2.124
CARGO_CRATE_DEPENDS+= libc-0.2.125
CARGO_CRATE_DEPENDS+= linked-hash-map-0.5.4
CARGO_CRATE_DEPENDS+= lock_api-0.4.7
CARGO_CRATE_DEPENDS+= log-0.4.16
CARGO_CRATE_DEPENDS+= log-0.4.17
CARGO_CRATE_DEPENDS+= lru-cache-0.1.2
CARGO_CRATE_DEPENDS+= match_cfg-0.1.0
CARGO_CRATE_DEPENDS+= matches-0.1.9
CARGO_CRATE_DEPENDS+= memchr-2.4.1
CARGO_CRATE_DEPENDS+= memchr-2.5.0
CARGO_CRATE_DEPENDS+= memoffset-0.6.5
CARGO_CRATE_DEPENDS+= mio-0.8.2
CARGO_CRATE_DEPENDS+= miow-0.3.7
CARGO_CRATE_DEPENDS+= mio-0.8.3
CARGO_CRATE_DEPENDS+= nix-0.24.1
CARGO_CRATE_DEPENDS+= ntapi-0.3.7
CARGO_CRATE_DEPENDS+= num-integer-0.1.44
CARGO_CRATE_DEPENDS+= num-traits-0.2.14
CARGO_CRATE_DEPENDS+= num-integer-0.1.45
CARGO_CRATE_DEPENDS+= num-traits-0.2.15
CARGO_CRATE_DEPENDS+= num_cpus-1.13.1
CARGO_CRATE_DEPENDS+= once_cell-1.10.0
CARGO_CRATE_DEPENDS+= os_str_bytes-6.0.0
CARGO_CRATE_DEPENDS+= parking_lot-0.12.0
CARGO_CRATE_DEPENDS+= parking_lot_core-0.9.2
CARGO_CRATE_DEPENDS+= parking_lot_core-0.9.3
CARGO_CRATE_DEPENDS+= percent-encoding-2.1.0
CARGO_CRATE_DEPENDS+= pin-project-lite-0.2.9
CARGO_CRATE_DEPENDS+= pin-utils-0.1.0
Expand All @@ -88,7 +87,7 @@ CARGO_CRATE_DEPENDS+= pnet_transport-0.29.0
CARGO_CRATE_DEPENDS+= ppv-lite86-0.2.16
CARGO_CRATE_DEPENDS+= proc-macro-error-1.0.4
CARGO_CRATE_DEPENDS+= proc-macro-error-attr-1.0.4
CARGO_CRATE_DEPENDS+= proc-macro2-1.0.37
CARGO_CRATE_DEPENDS+= proc-macro2-1.0.38
CARGO_CRATE_DEPENDS+= quick-error-1.2.3
CARGO_CRATE_DEPENDS+= quote-1.0.18
CARGO_CRATE_DEPENDS+= rand-0.8.5
Expand All @@ -102,7 +101,7 @@ CARGO_CRATE_DEPENDS+= rustc_version-0.4.0
CARGO_CRATE_DEPENDS+= rustversion-1.0.6
CARGO_CRATE_DEPENDS+= ryu-1.0.9
CARGO_CRATE_DEPENDS+= scopeguard-1.1.0
CARGO_CRATE_DEPENDS+= semver-1.0.7
CARGO_CRATE_DEPENDS+= semver-1.0.9
CARGO_CRATE_DEPENDS+= serde-1.0.137
CARGO_CRATE_DEPENDS+= serde_derive-1.0.137
CARGO_CRATE_DEPENDS+= serde_json-1.0.81
Expand All @@ -115,7 +114,7 @@ CARGO_CRATE_DEPENDS+= socket2-0.4.4
CARGO_CRATE_DEPENDS+= strsim-0.10.0
CARGO_CRATE_DEPENDS+= strum-0.23.0
CARGO_CRATE_DEPENDS+= strum_macros-0.23.1
CARGO_CRATE_DEPENDS+= syn-1.0.91
CARGO_CRATE_DEPENDS+= syn-1.0.93
CARGO_CRATE_DEPENDS+= termcolor-1.1.3
CARGO_CRATE_DEPENDS+= terminal_size-0.1.17
CARGO_CRATE_DEPENDS+= textwrap-0.15.0
Expand All @@ -124,15 +123,15 @@ CARGO_CRATE_DEPENDS+= thiserror-impl-1.0.31
CARGO_CRATE_DEPENDS+= time-0.1.44
CARGO_CRATE_DEPENDS+= tinyvec-1.6.0
CARGO_CRATE_DEPENDS+= tinyvec_macros-0.1.0
CARGO_CRATE_DEPENDS+= tokio-1.18.0
CARGO_CRATE_DEPENDS+= tokio-1.18.2
CARGO_CRATE_DEPENDS+= trust-dns-proto-0.21.2
CARGO_CRATE_DEPENDS+= trust-dns-resolver-0.21.2
CARGO_CRATE_DEPENDS+= tui-0.18.0
CARGO_CRATE_DEPENDS+= unicode-bidi-0.3.8
CARGO_CRATE_DEPENDS+= unicode-normalization-0.1.19
CARGO_CRATE_DEPENDS+= unicode-segmentation-1.9.0
CARGO_CRATE_DEPENDS+= unicode-width-0.1.9
CARGO_CRATE_DEPENDS+= unicode-xid-0.2.2
CARGO_CRATE_DEPENDS+= unicode-xid-0.2.3
CARGO_CRATE_DEPENDS+= url-2.2.2
CARGO_CRATE_DEPENDS+= version_check-0.9.4
CARGO_CRATE_DEPENDS+= wasi-0.10.0+wasi-snapshot-preview1
Expand All @@ -142,10 +141,10 @@ CARGO_CRATE_DEPENDS+= winapi-0.3.9
CARGO_CRATE_DEPENDS+= winapi-i686-pc-windows-gnu-0.4.0
CARGO_CRATE_DEPENDS+= winapi-util-0.1.5
CARGO_CRATE_DEPENDS+= winapi-x86_64-pc-windows-gnu-0.4.0
CARGO_CRATE_DEPENDS+= windows-sys-0.34.0
CARGO_CRATE_DEPENDS+= windows_aarch64_msvc-0.34.0
CARGO_CRATE_DEPENDS+= windows_i686_gnu-0.34.0
CARGO_CRATE_DEPENDS+= windows_i686_msvc-0.34.0
CARGO_CRATE_DEPENDS+= windows_x86_64_gnu-0.34.0
CARGO_CRATE_DEPENDS+= windows_x86_64_msvc-0.34.0
CARGO_CRATE_DEPENDS+= windows-sys-0.36.1
CARGO_CRATE_DEPENDS+= windows_aarch64_msvc-0.36.1
CARGO_CRATE_DEPENDS+= windows_i686_gnu-0.36.1
CARGO_CRATE_DEPENDS+= windows_i686_msvc-0.36.1
CARGO_CRATE_DEPENDS+= windows_x86_64_gnu-0.36.1
CARGO_CRATE_DEPENDS+= windows_x86_64_msvc-0.36.1
CARGO_CRATE_DEPENDS+= winreg-0.7.0
Loading

0 comments on commit 6dcb869

Please sign in to comment.