Skip to content

Commit

Permalink
Update to 1.148
Browse files Browse the repository at this point in the history
Update DEPENDS

Upstream changes:
1.148 Sat Jan  7 15:20:07 CST 2023

    [Possible breakage]
    Removed Perl::Critic::Utils::DataConversion. Any add-on policies that used
    it will need to copy the functions from there into their own code.

    [Documentation]
    ProhibitCascadingIfElse no longer suggests using given/when.

    [Internals]
    We no longer require Test::Deep for testing.

    Test::Kwalitee is now only recommended, not required.

    Random microoptimizations, like using hashes for array contents checking,
    and using any() instead of calling grep as a boolean.


1.146 Wed Dec 21 21:05:20 CST 2022

    [New features]
    ProhibitBarewordDirHandles now checks for sysopen as well as open. Thanks,
    Tadeusz Sośnierz. (GH #732)

    Added a Dockerfile in the extras/ directory for those who want to run P::C
    in a container. Thanks, Isaac Gittins. (GH #832)

    Subroutines::ProhibitBuiltinHomonyms now can take an "allows" parameter to
    specify subroutines that won't violate the policy. Thanks, UTAGAWA Kiki.
    (GH #14, #932)

    ProhibitStringyEval now allows package declarations in evals when
    allow_includes = true. This is a common way packages are declared.
    Thanks, Chris Novakovic. (GH #908)

    [Bug Fixes]
    Fixed some problems with how Perl::Critic determined scope. Thanks, Tom
    Wyant. (GH #793)

    Fixed improper violation for lexical subroutines in
    Subroutines::ProhibitBuiltinHomonyms. Thanks, TOYAMA Nao. (GH #973, #955,
    #546)

    ValuesAndExpressions::RequireNumberSeparators no longer complains if your
    version numbers do not have number separators in them. Thanks, Tom Wyant.
    (GH #856, #904)

    Fixed a false positive with split() in ProhibitUnusedCapture. Thanks, Tom
    Wyant. (GH #888)

    [Internals]
    We no longer use or need IO::String. Thanks, Graham Knop. (GH #997)

    Removed requirements and mentions of modules no longer used:
    * Fatal
    * IO::String
    * IPC::Open2
    * Pod::Parser
    * Task::Weaken


1.144 Mon Dec  5 09:44:04 PM CST 2022

    Perl::Critic now requires Perl 5.10.1.

    [New features]
    The ProhibitAugmentedAssignmentInDeclaration policy now allows augmented
    assignments to "our" variables, if the allow_our option is enabled.
    Thanks, Graham Knop. (GH #993)

    ProhibitExplicitISA now recommends "use parent" instead of "use base".
    (GH #987)

    RequireUseWarnings now recognizes that "use v5.36" implies warnings.
    Thanks, Andrew Grechkin. (GH #984)

    Subroutines::ProhibitNestedSubs now allows lexical subroutines can
    now be inside of other subroutines. Thanks, TOYAMA Nao. (GH #946,
    #971, #972)

    RequireUseStrict now knows that Test::Spec enables it. (GH #906)

    ProhibitUnusedCapture now understands @{^CAPTURE} and %{^CAPTURE_ALL} that
    were added in Perl 5.26.0. Thanks, Tom Wyant. (GH #778)

    Allow numeric operators on special number strings 'NaN' and 'inf'. Thanks,
    Omer Gazit. (GH #803)

    [Fixes]
    Miscellanea::ProhibitUselessNoCritic no longer filters out errors about
    itself, just as Miscellanea::ProhibitUnrestrictedNoCritic cannot. Thanks,
    Bernhard Schmalhofer. (GH #939)

    Fixed GH #878: bareword filehandle dies on `open(CHECK, '/foo');`. Thanks,
    Tom Wyant.

    [Internals]
    Updated to using Perl 5.10.1. Starting migrating to Perl 5.10-isms like
    defined-or. Thanks, James Raspass.

    [Documentation]
    Updated some outdated docs in Perl::Critic::Utils. Thanks, Slaven Rezić.
    (GH #951)


1.142 Mon Nov 28 08:12:14 PM CST 2022

    This is the last version of Perl::Critic that will run on Perl 5.6.1.  The
    next release will require Perl 5.10.1.

    [New Features]
    Add new policy InputOutput::ProhibitBarewordDirHandles, comparable to
    ProhibitBarewordFilehanles.  Thanks, raf. (GH #912)

    References::ProhibitDoubleSigils policy now allows for Perl's
    postfix dereference syntax and does not report a policy violation.
    Thanks to Ilya Rassadin (GH #578)

    Added Test::Class::Moose and MooseX::MethodAttributes::Role to the
    list of modules that are equivalent to "use strict".  (GH #808, GH #886)

    Subroutines::RequireArgUnpacking now detects anonymous subroutines with
    attributes, prototypes or signatures.  Thanks, Tom Wyant. (GH #684)

    ProhibitVoidMap and ProhibitVoidGrep now detect void context inside subs,
    such as:

        sub { map { foo($_) } @list; return }

    Thanks, James Raspass. (GH #905)

    RequireArgUnpacking now allows a closure to be recognized as a way that
    subroutine arguments can be unpacked.  This is specified with an optional
    allow_closures configuration option.  Thanks, Tom Wyant. (GH #737)

    ProhibitTwoArgOpen now disallows one-arg opens as well. Also, it
    no longer allows two-arg opening of STDIN/STDOUT/STDERR.  Thanks,
    Dan Book. (GH #652, #653)

    [Fixes]
    ProhibitLeadingZeros would not handle sysopen and lexical variables
    correctly. This has been fixed. Thanks, Tom Wyant. (GH #789)

    [Documentation]
    We note that the any() function is available in both List::MoreUtils and
    List::SomeUtils.

    Added instructions to perlcritic on how to integrate with Visual Studio
    Code.  Thanks, sigzero.

    [Internals]
    Switch to using List::SomeUtils instead of List::MoreUtils.
  • Loading branch information
wen committed Jan 8, 2023
1 parent 79aa789 commit 5d6b9a7
Show file tree
Hide file tree
Showing 2 changed files with 7 additions and 13 deletions.
12 changes: 3 additions & 9 deletions devel/p5-Perl-Critic/Makefile
Original file line number Diff line number Diff line change
@@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.47 2022/06/28 11:33:05 wiz Exp $
# $NetBSD: Makefile,v 1.48 2023/01/08 00:22:27 wen Exp $
#

DISTNAME= Perl-Critic-1.140
DISTNAME= Perl-Critic-1.148
PKGNAME= p5-${DISTNAME}
PKGREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Perl/}

Expand All @@ -18,26 +17,21 @@ DEPENDS+= p5-B-Keywords>=1.05:../../devel/p5-B-Keywords
DEPENDS+= p5-Config-Tiny>=2:../../devel/p5-Config-Tiny
DEPENDS+= p5-Exception-Class>=1.23:../../devel/p5-Exception-Class
DEPENDS+= p5-File-Which-[0-9]*:../../devel/p5-File-Which
DEPENDS+= p5-IO-String-[0-9]*:../../devel/p5-IO-String
DEPENDS+= p5-List-MoreUtils>=0.19:../../devel/p5-List-MoreUtils
DEPENDS+= p5-List-SomeUtils>=0.55:../../devel/p5-List-SomeUtils
DEPENDS+= p5-Module-Pluggable>=3.1:../../devel/p5-Module-Pluggable
DEPENDS+= p5-PPI>=1.265:../../devel/p5-PPI
DEPENDS+= p5-PPIx-QuoteLike>=0:../../textproc/p5-PPIx-QuoteLike
DEPENDS+= p5-PPIx-Regexp>=0.022:../../devel/p5-PPIx-Regexp
DEPENDS+= p5-PPIx-Utilities>=1.001:../../devel/p5-PPIx-Utilities
DEPENDS+= p5-Perl-Tidy-[0-9]*:../../devel/p5-Perl-Tidy
DEPENDS+= p5-Pod-Spell>=1:../../textproc/p5-Pod-Spell
DEPENDS+= p5-Pod-Parser>=1.63:../../textproc/p5-Pod-Parser
DEPENDS+= p5-Readonly>=2.0:../../devel/p5-Readonly
DEPENDS+= p5-String-Format>=1.13:../../devel/p5-String-Format
DEPENDS+= p5-Task-Weaken-[0-9]*:../../devel/p5-Task-Weaken

TEST_DEPENDS+= p5-Test-Deep-[0-9]*:../../devel/p5-Test-Deep
TEST_DEPENDS+= p5-Module-Pluggable-[0-9]*:../../devel/p5-Module-Pluggable

# Recommended dependencies
DEPENDS+= p5-Readonly-XS-[0-9]*:../../devel/p5-Readonly-XS
#DEPENDS+= p5-Regexp-Parser>=0.20:../../devel/p5-Regexp-Parser

USE_LANGUAGES= # empty
PERL5_PACKLIST= auto/Perl/Critic/.packlist
Expand Down
8 changes: 4 additions & 4 deletions devel/p5-Perl-Critic/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.29 2021/10/26 10:17:18 nia Exp $
$NetBSD: distinfo,v 1.30 2023/01/08 00:22:27 wen Exp $

BLAKE2s (Perl-Critic-1.140.tar.gz) = 04cf995471a5b3a4d0265e6ed5f83b9f00da32bc9d62d30b08e26c3b3dfddb7b
SHA512 (Perl-Critic-1.140.tar.gz) = 46afc8260d2b500edbb29836be993f065270ed9ffa6aa00611a980b294025b794286bc820afeabb94b7d1cdd9bfb4e715e44e466fb0340cb9d938e031b54a6f0
Size (Perl-Critic-1.140.tar.gz) = 650449 bytes
BLAKE2s (Perl-Critic-1.148.tar.gz) = b20c25c45d433d8d9153a86bb4378a312ee5ed4a20342a0a76d4d5a1b3bd7487
SHA512 (Perl-Critic-1.148.tar.gz) = 833e29f6bb91811180fc668d5f9feb1fdee8d4f18a7703cff0c6cfb73953e527f7b568836741c59b5d80bd9d56ce82cdeb5dc627df83823cb0fb9f4eac924ce0
Size (Perl-Critic-1.148.tar.gz) = 662222 bytes

0 comments on commit 5d6b9a7

Please sign in to comment.